[Solved] Debian fails to install on UEFI

New to Debian (Or Linux in general)? Ask your questions here!

[Solved] Debian fails to install on UEFI

Postby Augiz » 2018-09-03 22:41

Hello, to clarify the laptop I'm trying to install debian on is Lenovo Ideapad 120s-14IAP.
Basically what happens it freezes on splash screen.

Using Debian 9.5 amd64 architecture, compiled into usb drive with rufus.
On UEFI architecture it just freezes on splash screen (lenovo logo), on Legacy bios it installs, but then its not possible to dual boot.
The very same usb with the very same debian works fine on my other two computers.

Ubuntu and linux mint (from same usb drive) installs just fine and works well on this laptop on UEFI. So the problem must be within debian.

Tried multiple usb drives too - no success.

Thanks for help.
Last edited by Augiz on 2018-09-09 22:16, edited 1 time in total.
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby stevepusser » 2018-09-04 01:26

In UEFI mode on your machine, have you disabled Secure Boot and fast boot?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-04 12:25

Yeah secure boot is disabled (if it weren't - debian would just drop warning). There's no fast boot option in bios but on windows settings its disabled.

As I said the screen just freezes on splash screen, which doesn't happen with linux mint or ubuntu on the very same settings.
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby None1975 » 2018-09-04 12:29

Please write the technical details of your computer.
OS: Debian 9.5 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 669
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-04 14:15

Pentium n4200, 4gb ram, 120gb ssd (not emmc), hd resolution. Laptop only has usb 3 ports (maybe thats the catch?). But i only own few usb 2.0 drives. Regardless ubuntu installs so does mint.

Is there a way to install debian on legacy then make it bootable from uefi?
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby p.H » 2018-09-04 14:28

Augiz wrote:Using Debian 9.5 amd64 architecture, compiled into usb drive with rufus.

In "dd mode" ?

Augiz wrote:On UEFI architecture it just freezes on splash screen (lenovo logo)

Can you elaborate ? Can you select the USB media containing the Debian installer, then is the GRUB menu displayed ?

Augiz wrote:Ubuntu and linux mint (from same usb drive) installs just fine and works well on this laptop on UEFI.

FWIW, Ubuntu and Mint support UEFI secure boot. Debian does not (yet).

Augiz wrote:Is there a way to install debian on legacy then make it bootable from uefi?

Yes.
The hard part will be to set up the multiboot with Windows.
p.H
 
Posts: 631
Joined: 2017-09-17 07:12

Re: Debian fails to install on UEFI

Postby bw123 » 2018-09-04 14:30

Found this on websearch for debian+Ideapad+20s-14IAP there is a link to an older reddit that explains some BIOS settings that worked on another Ideapad 120s-12IAP

https://www.reddit.com/r/linux4noobs/co ... ot_ubuntu/
User avatar
bw123
 
Posts: 3522
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-04 14:47

Tried both iso and dd - same result.

picture of where computer freezes: https://i.imgur.com/0qdO6BR.jpg
(cursor mark top left corner but its frozen as well)

picture of bios settings: https://i.imgur.com/r6gj70i.jpg
Cant find a way to mess up with greyed options - "platform mode" and "secure boot mode" (which is set to custom).
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby milomak » 2018-09-04 14:55

just to be clear that's the system splash screen? the one that appears on boot? so you don't get to the grub menu?
iMac Late-2015 27" 5K Retina - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1803
Joined: 2009-06-09 22:20

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-04 15:00

milomak wrote:just to be clear that's the system splash screen? the one that appears on boot? so you don't get to the grub menu?


Correct. If I have the "secure boot"="on", the "secure boot status" still stays on disabled and the result stays the same.
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby p.H » 2018-09-04 15:03

Augiz wrote:Cant find a way to mess up with greyed options - "platform mode" and "secure boot mode" (which is set to custom).

Can't see the pictures right now but on some UEFI firmwares you must set a password to unlock secure boot settings.

You did not answer this :
In the UEFI boot menu, can you select the USB media containing the Debian installer ?
p.H
 
Posts: 631
Joined: 2017-09-17 07:12

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-04 15:07

p.H wrote:
Augiz wrote:Cant find a way to mess up with greyed options - "platform mode" and "secure boot mode" (which is set to custom).

Can't see the pictures right now but on some UEFI firmwares you must set a password to unlock secure boot settings.

You did not answer this :
Can you select the USB media containing the Debian installer, then is the GRUB menu displayed ?


I can see usb with debian being recognised from bios boot order screen, and its obviously the #1 on the list.

But you know when pc is loading you get that splash screen with manufacturer logo - "Asus", "Lenovo" or whatever - after which the OS boots right in. So yea I get stuck on that splash.
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby p.H » 2018-09-05 07:21

Do you mean that the "lenovo" splash screen is displayed after you selected to boot from the USB drive ?
p.H
 
Posts: 631
Joined: 2017-09-17 07:12

Re: Debian fails to install on UEFI

Postby Augiz » 2018-09-05 18:11

Correct, and just freezes on that.
Augiz
 
Posts: 12
Joined: 2017-11-26 22:02

Re: Debian fails to install on UEFI

Postby milomak » 2018-09-05 20:34

which install media have you chosen?
iMac Late-2015 27" 5K Retina - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1803
Joined: 2009-06-09 22:20

Next

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable