libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is not

New to Debian (Or Linux in general)? Ask your questions here!

libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is not

Postby heliosh » 2018-10-16 07:50

Hi,

I'm running debian unstable and i was using the rc2 of wsjtx 2.0.0 (installed from deb package from their website).
After an apt update && apt upgrade this morning there seem to be a dependency issue:

Code: Select all
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libqt5serialport5 (>= 5.2); however:
  Package libqt5serialport5 is not installed.
 wsjtx depends on libqt5multimedia5-plugins (>= 5.2); however:
  Package libqt5multimedia5-plugins is not installed.
 wsjtx depends on libqt5multimedia5 (>= 5.6.0~beta); however:
  Package libqt5multimedia5 is not installed.
 wsjtx depends on libqt5serialport5 (>= 5.6.0); however:
  Package libqt5serialport5 is not installed.


If i try to install an above libqt5-package manually I get:
Code: Select all
libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is not installable


What do I have to do, to get the libqt5-packages installed again?

Thanks
heliosh
 
Posts: 5
Joined: 2018-10-16 07:38

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby dilberts_left_nut » 2018-10-16 09:30

heliosh wrote:After an apt update && apt upgrade this morning there seem to be a dependency issue

That's a common situation when you run sid and/or use foreign packages.

From https://packages.debian.org/sid/libqt5serialport5 it looks like you need libqt5core5a
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4902
Joined: 2009-10-05 07:54
Location: enzed

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby heliosh » 2018-10-16 10:58

Code: Select all
libqt5core5a is already the newest version (5.11.2+dfsg-3)
heliosh
 
Posts: 5
Joined: 2018-10-16 07:38

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby stevepusser » 2018-10-16 17:55

Then you have to go down the ladder of uninstallable packages until you find the culprit:
Code: Select all
apt install qtbase-abi-5-11-0


If it fails because of another problem package, rinse and repeat with the new package. But since that package was built on Ubuntu, it may not be a problem you can solve.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10122
Joined: 2009-10-06 05:53

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby heliosh » 2018-10-16 19:01

stevepusser wrote:Then you have to go down the ladder of uninstallable packages until you find the culprit:
Code: Select all
apt install qtbase-abi-5-11-0



There is the problem:
Code: Select all
Package qtbase-abi-5-11-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'qtbase-abi-5-11-0' has no installation candidate


I don't understand how this works:
Code: Select all
apt install qtbase-abi-5-11-2
Note, selecting 'libqt5core5a' instead of 'qtbase-abi-5-11-2'
libqt5core5a is already the newest version (5.11.2+dfsg-3).

How do I get libqt5serialport5 to use version 5.11.2? Or do I just have to wait until the package maintainer does the adaption?
heliosh
 
Posts: 5
Joined: 2018-10-16 07:38

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby GarryRicketson » 2018-10-16 19:39

I don't mean to be discouraging , but did you see what Steve said ?:
by stevepusser » But since that package was built on Ubuntu, it may not be a problem you can solve.


Also it might be educational to read:
https://wiki.debian.org/DontBreakDebian

All though this was not a Ubuntu ppa, if it was compiled and built on Ubuntu, as Steve says, the main problem is Debian is not Ubuntu, I notice in the link to the site where you got it, the source code is available, my approach would be to get the source code, and try compiling it , and build it on your Debian system, so you end up with a package built on Debian, instead of on Ubuntu.
by heliosh »Or do I just have to wait until the package maintainer does the adaption?

Well, if you just wait,there is no guarantee the developer or maintaner will do anything to address the problem, or fix it, they might not even be aware of it.
If it is important to you to have this program, you should probably work directly with them, and try to build it on Debian, instead of Ubuntu.
https://physics.princeton.edu/pulsar/k1jt/support.html
Bug Reports
One of your responsibilities as a WSJT-X user is to help the volunteer programmers to make the program better. Bugs may be reported to the WSJTgroup (email address given above) or to the WSJT Developers email list (wsjt-devel@lists.sourceforge.net). Again, you will need to join subscribe to the list in order to post there.

To be useful, bug reports should include at least the following information:


Another option might be to try it on a Ubuntu system, and see if it works on that.
Any way, the point is just waiting for somebody else to do something, is not really a good approach,
One of your responsibilities as a WSJT-X user is to help the volunteer programmers to make the program better.
User avatar
GarryRicketson
 
Posts: 5161
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby bw123 » 2018-10-16 20:05

heliosh wrote:
Code: Select all
libqt5core5a is already the newest version (5.11.2+dfsg-3)


this version is from experimental? sid says 5.11.1
https://packages.debian.org/search?keyw ... bqt5core5a

other ver still here
http://ftp.us.debian.org/debian/pool/ma ... ource-src/
User avatar
bw123
 
Posts: 3517
Joined: 2011-05-09 06:02
Location: TN_USA

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby heliosh » 2018-10-16 20:18

GarryRicketson wrote:I don't mean to be discouraging , but did you see what Steve said ?:

Yes, but as far as I can tell the problem is not the package from the website, but the debian packages libqt5serialport5 and libqt5multimedia5, which can't be installed even if the wsjtx package is removed.
That's why I'm asking here and not there.


bw123 wrote:this version is from experimental? sid says 5.11.1
https://packages.debian.org/search?keyw ... bqt5core5a


Sid says 5.11.2 for amd64.
heliosh
 
Posts: 5
Joined: 2018-10-16 07:38

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby bw123 » 2018-10-16 20:49

okay look, stubborn person, I dloaded them both just for you

Code: Select all
/home/me/libqt5core5a_5.11.1+dfsg-9_amd64.deb       2343/2746               85%
 Provides: qtbase-abi-5-11-0
/home/me/libqt5core5a_5.11.2+dfsg-3_amd64.deb       2343/2746               85%
 Provides: qtbase-abi-5-11-2



My apologies if this offends, but if you don;t know what to do with this information, maybe you shouldn't use sid?
Last edited by bw123 on 2018-10-16 21:05, edited 1 time in total.
User avatar
bw123
 
Posts: 3517
Joined: 2011-05-09 06:02
Location: TN_USA

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby GarryRicketson » 2018-10-16 21:00

Well, I don't feel like arguing, do what you want, or don't do anything, and just wait, hoping somebody else will take care of it. Debian testing, SID, and experimental, are , well, you know for testing and developing,
but the debian packages libqt5serialport5 and libqt5multimedia5, which can't be installed

I think you are missing my point, either way,you should be communicating with the maintainers, and developers, and let them know about this problem, it might all ready be a known bug, https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=libqt5core5a;dist=unstable

https://packages.debian.org/sid/libqt5core5a
Package: libqt5core5a (5.11.2+dfsg-3 and others)

https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=libqt5core5a;dist=unstable
Debian Bug report logs: Bugs in package libqt5core5a (versions 5.10.1+dfsg-7 [kfreebsd-i386], 5.11.1+dfsg-9 [mipsel], 5.11.2+dfsg-3 [amd64, armel, i386, mips], 5.10.1+dfsg-5 [kfreebsd-amd64]) in unstable

Maintainers for libqt5core5a are Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>.


If you think it is a problem with the Debian packages, obviously you should contact the maintainers about it,... here like the forum name says: we are just Debian User Forums, Debian users, most of us have very little or nothing to do with the maintaining and development of these packages, Steve is involved some what, with some for the MX Linux, and also has back ports he has made, and maintains, so when he says something
like:
by stevepusser » But since that package was built on Ubuntu, it may not be a problem you can solve.

I take his word for it, but I would add, it might be something you and others involved in the development of these packages, can solve, the key being to compile and build the entire package, including the libraries that are in Debian repos, but do the compiling, build on Debian, instead of Ubuntu.
User avatar
GarryRicketson
 
Posts: 5161
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby heliosh » 2018-10-17 08:08

heliosh
 
Posts: 5
Joined: 2018-10-16 07:38

Re: libqt5serialport5 : Depends: qtbase-abi-5-11-0 but it is

Postby stevepusser » 2018-10-17 17:18

Sid breaks things. A lot. That's why it's named after Sid from Toy Story.

apt-listbugs is your friend in this case.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10122
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable