Legacy and UEFI

New to Debian (Or Linux in general)? Ask your questions here!

Legacy and UEFI

Postby Ezingers » 2018-10-20 15:15

To tell you the truth, I never heard of the option of choosing a different bios boot modes like Legacy or UEFI. That is not until I got a new HP laptop last November. It came with Windows 10. I had already planed on putting a linux on it and I have been using Debian for over four years now so I attempted to load Debian 9 on it and of course it wouldn't load. I have been using the netinst.iso sense I got the laptop because I didn't know if HP uses free or non-free firmware. Anyway, I I went in to the bios to check the boot order thinking that's why it wasn't working. That was one of the reason it wasn't working. But it had two configurations, one boot order for UEFI and one for Legacy. I didn't think anything of it at the time. I saved the new configuration and tried loading it again and still wouldn't load. So I went back in to the bios system and that's when I noticed that the Legacy was disabled. So I highlighted it and the description of Legacy and UEFI and what would happen if I enabled Legacy. It said the Legacy was for older OS like Windows 7 and earlier and UEFI was for newer OS like Windows 8 and 10. So I enabled Legacy and loaded Debian again. This time it worked. Out of curiosity, I tried to load Windows 10 and it wouldn't load until I disable Legacy again, Recently I wanted to upgrade debian and my system needed a serous cleaning anyway, So I downloaded debian-9.5.0-amd64-netinst.iso.torrent and and got the iso and made a disk. I disabled the Legacy in the bios sense this version suppose to support the UEFI mode, and again it wouldn't load. After I enabled Legacy, it worked. It doesn't make sense. If it really support UEFI, shouldn't it act the same way as when I first made the transition from Windows 10 to Debian 9? Do you know if this is going to change in Debian 10 Buster? This is new to me, but I do imagine that the way it looks right now that Legacy will be faded out eventually. Hope you can help me to understand this.
Thank You
Ezingers
 
Posts: 39
Joined: 2015-02-28 18:32

Re: Legacy and UEFI

Postby Head_on_a_Stick » 2018-10-20 15:22

Have you tried disabling Secure Boot?

Debian 9 should install in UEFI mode but not if Secure Boot is enabled; I think Debian 10 should support Secure Boot though.

EDIT: also, is your <Return> key broken? :mrgreen:
I suffer from depression and may lash out occasionally, try not to take it personally.
User avatar
Head_on_a_Stick
 
Posts: 8172
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Legacy and UEFI

Postby milomak » 2018-10-20 16:25

it was difficult to read the op so didn't finish it. perhaps if there were paragraphs i could be more helpful.

i can say that i run uefi on a win10 laptop. it in fact runs grub as the boot option

i run debian efi on a macos as well

i'm not sure what your issue is. but i have been able to run debian on 2 different efi systems
iMac Late-2015 27" 5K Retina - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1806
Joined: 2009-06-09 22:20


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable