Error with `apt`

New to Debian (Or Linux in general)? Ask your questions here!

Error with `apt`

Postby person » 2018-11-12 04:40

I'm not sure what's going on. I've looked everywhere, but can't find answers. I just started using linux today. Help would be greatly apprecieated.

Code: Select all
sha-pc@debian:~$ sudo apt-get install lmms
apt-get: relocation error: /usr/lib/i386-linux-gnu/libapt-private.so.0.0: symbol _ZN3URIcvNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEB5cxx11Ev
/version APTPKG_5.0 not defined in file libapt-pkg.so.5.0 with link time reference
person
 
Posts: 2
Joined: 2018-11-12 04:30

Re: Error with `apt`

Postby bw123 » 2018-11-12 05:01

That's great news. I hope you have fun with it. Since you are new, be sure and used debian stretch. Buster is a little ways off yet, and sid is just plain crazy all the time.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=911090
Code: Select all
 apt policy libapt-pkg5.0
libapt-pkg5.0:
  Installed: 1.4.8
  Candidate: 1.4.8
  Version table:
 *** 1.4.8 500
        500 http://http.us.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
User avatar
bw123
 
Posts: 3585
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Error with `apt`

Postby person » 2018-11-12 05:55

bw123 wrote:That's great news. I hope you have fun with it. Since you are new, be sure and used debian stretch. Buster is a little ways off yet, and sid is just plain crazy all the time.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=911090
Code: Select all
 apt policy libapt-pkg5.0
libapt-pkg5.0:
  Installed: 1.4.8
  Candidate: 1.4.8
  Version table:
 *** 1.4.8 500
        500 http://http.us.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

Please explain what you mean.
person
 
Posts: 2
Joined: 2018-11-12 04:30

Re: Error with `apt`

Postby bw123 » 2018-11-12 06:21

According to the bug, you are probably using a development version that is not suitable for new linux users. Don't use testing/unstable repositories. If this is happening on debian stretch with libapt_pkg5.0 ver 1.4.8 then I can't reproduce it.

Let people know what you installed, what image did you download? Welcome to linux, it's different.
User avatar
bw123
 
Posts: 3585
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Error with `apt`

Postby debiman » 2018-11-14 00:58

person wrote:Please explain what you mean.

post the output of the same command bw123 used:
Code: Select all
apt policy libapt-pkg5.0
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18

Re: Error with `apt`

Postby stevepusser » 2018-11-14 03:07

Based on some other threads here and on Reddit, did you have a friend that added the testing repos to Stretch for you to "just get a couple newer packages"?

You now have a FrankenDebian if that was the case.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10282
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable