keyboard crisis

New to Debian (Or Linux in general)? Ask your questions here!

keyboard crisis

Postby oui » 2019-04-10 21:50

Hi

I am French and need also German chars, and von time to time such like ñ ã õ .

Years along was US INTL keyboard exactly the right (it is also the real equipment of 2 real hardware keyboard for my PC's made so by Fujitsu/SIEMENS (KB SLIM MF US INTL, it don't seem to be a special version but a standard option!).

Linux seems to have cancelled that option from the lists of keyboard (but it continues to be activable through setxkbmap us intl !).

The problem is, if it is no pre set by start is, if you forget to activate, and hit on optional chars, it send sonder code to the application and can (often) cancel your actual work without some warning message :oops:

My actual setting panel does not permit to introduce directly the code «us intl» for KbVariant and I see no file in /etc/X11 for keyboard definition, only an empty subdir without some prepared empty (or not) file!

Where is today the right place for such a keyboard definition?

How to name the file and find an operable model (I suppose the text part out the old xorg.conf where it was possible to define up to 4 keyboards and a commute key can be right)?
oui
 
Posts: 99
Joined: 2008-01-29 20:51

Re: keyboard crisis

Postby Head_on_a_Stick » 2019-04-11 04:52

Code: Select all
echo 'setxkbmap us intl' >> ~/.xsessionrc

Or:
Code: Select all
# dpkg-reconfigure keyboard-configuration

Or tell us which desktop environment you are using for more specific advice.

EDIT: corrected typo in dpkg-reconfigure command.
Last edited by Head_on_a_Stick on 2019-04-11 14:38, edited 1 time in total.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: keyboard crisis

Postby oui » 2019-04-11 06:37

Thank you very much Head_of_a_stick

1st method: the file did have no content and now the command is in it without effect

2d method: I suppose that it is the method used by the panel with the same inconvenient: no writing field to simply write «us intl»

note: system miss an "r" in keyboard in your message (if an other user will also try it)

I am using divers environments but mainly the poor JWM (it is possible to add the command setxbmap us intl in the field startup commands from system.jwmrc, but it works restrictive only with JWM. I am looking for a solution like xorg.conf, Puppy Linux continues to use xorg.conf, my full installation don't accept xorg.conf any more and frost after restart, being good for all environments, probably a setting file in /etc or /etc/X11 actually missed in the system :idea:
oui
 
Posts: 99
Joined: 2008-01-29 20:51

Re: keyboard crisis

Postby Head_on_a_Stick » 2019-04-11 14:50

oui wrote:2d method: I suppose that it is the method used by the panel with the same inconvenient: no writing field to simply write «us intl»

Is there not an option for that in the keyboard list?

You could try editing /etc/default/keyboard directly and change these line:
Code: Select all
XKBLAYOUT="us"
XKBVARIANT="intl"

Does that work?

My ~/.xsessionrc suggestion only works for display managers.

oui wrote:my full installation don't accept xorg.conf any more and frost after restart

An Xorg configuration file should certainly work in Debian.

If your system froze then you probably made a mistake in the file, please post what you tried.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable