libpng12.so.0 is missing

New to Debian (Or Linux in general)? Ask your questions here!

libpng12.so.0 is missing

Postby Abormot » 2019-08-22 03:18

I am trying to install Maya 2019 on my Debian 10 destop. Runing comand ./setup gave me this: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Where and how to get libpng12.so.0?
Abormot
 
Posts: 32
Joined: 2019-08-16 16:47

Re: libpng12.so.0 is missing

Postby arzgi » 2019-08-22 10:46

It is not any way advisable to install third party packages, outside debian repos.

https://wiki.debian.org/DontBreakDebian

If you absolutely need that package, you could create symbolic link named lippng12.so.0 which points to Buster's libpng16-16.
arzgi
 
Posts: 461
Joined: 2008-02-21 17:03
Location: Finland

Re: libpng12.so.0 is missing

Postby Abormot » 2019-08-22 13:29

Got you. Can you, please, provide me bash command to do that?
Abormot
 
Posts: 32
Joined: 2019-08-16 16:47

Re: libpng12.so.0 is missing

Postby Wheelerof4te » 2019-08-22 14:12

Why are you asking us? Maya has system requirements page:
https://knowledge.autodesk.com/support/ ... -2019.html

They officially support only RHEL/Centos 7 Linux.
Wheelerof4te
 
Posts: 1423
Joined: 2015-08-30 20:14

Re: libpng12.so.0 is missing

Postby Abormot » 2019-08-22 14:31

Wheelerof4te wrote:Why are you asking us? Maya has system requirements page:
https://knowledge.autodesk.com/support/ ... -2019.html

They officially support only RHEL/Centos 7 Linux.


Wow. Thanks for the link. That is very sad. Will think now what to do. Because I need Maya 2019 for sure on my Debian.
Abormot
 
Posts: 32
Joined: 2019-08-16 16:47

Re: libpng12.so.0 is missing

Postby Abormot » 2019-08-22 14:43

arzgi wrote:It is not any way advisable to install third party packages, outside debian repos.

https://wiki.debian.org/DontBreakDebian

If you absolutely need that package, you could create symbolic link named lippng12.so.0 which points to Buster's libpng16-16.


Ran this: "sudo ln -s /lib/x86_64-linux-gnu/libpng16.so.16 /lib/x86_64-linux-gnu/libpng12.so.0" and it was linked, but after launching ./setup gives this:
./setup-bin: /lib/x86_64-linux-gnu/libpng12.so.0: version `PNG12_0' not found (required by /home/username/Desktop/Autodesk_Maya_2019_Linux_64bit/libQtGui.so.4).

Looks like Maya still wants only original lippng12.so.0. I am sure there will be noting wrong if I will install libpng12.so.0 from CentOS 7.5.

Does anybody know bash command for Debian for installing it from CentOS repository?
Abormot
 
Posts: 32
Joined: 2019-08-16 16:47

Re: libpng12.so.0 is missing

Postby stevepusser » 2019-08-23 00:18

There isn't one. It's your system to experiment with, but you'd be better off to manually download and try to install the deb from Jessie: https://packages.debian.org/jessie/libpng12-0

with apt or gdebi on the command line, so it will be rejected if incompatible. Gdebi's GUI seems to be partly broken as it is in Buster.

Sometimes you can mix and match packages. I just found out I could use Buster's rustc and cargo packages in a Stretch pbuilder chroot (with just one simple additional backport! that's already in stretch-backports) to build the latest Waterfox release, which is based on Firefox 68, and the resulting Waterfox package runs fine on vanilla Stretch.

This means it's very probably possible to build a Firefox 68 package on Stretch, too.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11098
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable