multihead NG

New to Debian (Or Linux in general)? Ask your questions here!

multihead NG

Postby classe » 2019-08-23 02:41

There are 3 monitors:
The first is the laptop monitor;
The second is the VGA External monitor;
The third is the miniDP External monitor;

The problem is that, VGA External monitor keep black-screen. I can set it to display no problem occasionally, but after system rebooted, the VGA External monitor keep black-screen again.

What can I do next?
(system crashed when reboot)

My laptop:
thinkapd w540
buster GNOME (installed from 10.0.0-live+nonfree.iso)
upgrade to 2019-08-23
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106GLM [Quadro K2100M] (rev a1)

Thank you~
classe
 
Posts: 22
Joined: 2018-11-20 05:58

Re: multihead NG

Postby classe » 2019-08-23 11:57

This afternoon, I reinstalled the system using a new USB boot disk(made from 10.0.0-live+free.iso).
After installation at the login screen, I modified the wayland to xorg. Then, the problem changed:

When I set the laptop monitor and VGA external monitor on, only the laptop monitor on, the VGA external monitor is still off;
When I set the laptop monitor and miniDP external monitor on, only the laptop monitor on, the miniDP external monitor is still off;
When I set the laptop monitor off and the VGA&miniDP external monitor on, it worked, but the system would crashed when I reboot from the gnome menu. Every time.

btw:
There are some error tips before system booting, I don't know if it has a relationship.
The error tip:
ACPI Error: Needed type [Reference], found [Integer] 0000000019041fd6 (20180810/exresop-69)
ACPI Error: AD_AML_OPERAND_TYPE, While resolving operands for ......
ACPI Error: Method parse/execution failed \_PRCPU0._PDC, AD_AML_OPERAND_TYPE ........

My laptop:
thinkapd w540
buster GNOME (installed from 10.0.0-live-free.iso)
upgrade to 2019-08-23
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106GLM [Quadro K2100M] (rev a1)
classe
 
Posts: 22
Joined: 2018-11-20 05:58

Re: multihead NG

Postby classe » 2019-08-24 02:39

I tried new installation from 10.0.0-free(not live).

But, the result is, under wayland multi-montior set is OK, under xorg is NG.

So, I guess, there are no problem during my inistallation, only that xorg will be fired......
classe
 
Posts: 22
Joined: 2018-11-20 05:58

Re: multihead NG

Postby classe » 2019-08-24 03:11

I must use the xorg because there are no screen record tools can run on wayland.
But, my multi-monitor can not work fine on xorg, only fine on wayland...

So, I have to return back to stretch 9.9 temporarily, till there are screen record tools in Debian warehouse.
classe
 
Posts: 22
Joined: 2018-11-20 05:58


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable