dconf-editor doesn't work on Debian 10 gnome

New to Debian (Or Linux in general)? Ask your questions here!

dconf-editor doesn't work on Debian 10 gnome

Postby Chiefahol2 » 2019-09-09 00:05

Trying to disable auto mounting in gnome, dconf-editor refuses to let me edit values though?

https://unix.stackexchange.com/questions/273482/disabling-usb-automount-in-gnome3

Code: Select all
In dconf-editor go to org > gnome > desktop > media-handling and turn off both
automount and automount-open


I press the switch on the righthand side to disable it... nothing!

I double click it and another menu opens, with a 'Use default value' switch and 'Custom value' section. Setting 'Use default value' to false unlocks the 'Custom value section'. I set it to 'False' then click the tick button in the bottom right corner that says 'The change will be applied on such request or if you quit this view.'. It changes back instantly so i am still unable to change these values. :|

How does one use dconf-editor on Debian Buster? (gnome)
User avatar
Chiefahol2
 
Posts: 107
Joined: 2016-08-06 22:49

Re: dconf-editor doesn't work on Debian 10 gnome

Postby phenest » 2019-09-09 12:05

Chiefahol2 wrote:I set it to 'False' then click the tick button in the bottom right corner that says 'The change will be applied on such request or if you quit this view.'.

The "tick" button? Or do you mean the "Apply" button?
ASRock H77 Pro4-M i7 3770K - 32GB RAM - Pioneer BDR-209D
User avatar
phenest
 
Posts: 1703
Joined: 2010-03-09 09:38
Location: The Matrix

Re: dconf-editor doesn't work on Debian 10 gnome

Postby Head_on_a_Stick » 2019-09-09 13:53

GUIs are for suckers:
Code: Select all
E485:~$ gsettings get org.gnome.desktop.media-handling automount
true
E485:~$ gsettings get org.gnome.desktop.media-handling automount-open
true
E485:~$ gsettings set org.gnome.desktop.media-handling automount false
E485:~$ gsettings set org.gnome.desktop.media-handling automount-open false
E485:~$ gsettings get org.gnome.desktop.media-handling automount           
false
E485:~$ gsettings get org.gnome.desktop.media-handling automount-open       
false
E485:~$
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: dconf-editor doesn't work on Debian 10 gnome

Postby Chiefahol2 » 2019-09-10 01:32

phenest wrote:
Chiefahol2 wrote:I set it to 'False' then click the tick button in the bottom right corner that says 'The change will be applied on such request or if you quit this view.'.

The "tick" button? Or do you mean the "Apply" button?


It was a green tick symbol in the bottom right corner. I assume it meant 'apply'.

Head_on_a_Stick wrote:GUIs are for suckers:
Code: Select all
E485:~$ gsettings get org.gnome.desktop.media-handling automount
true
E485:~$ gsettings get org.gnome.desktop.media-handling automount-open
true
E485:~$ gsettings set org.gnome.desktop.media-handling automount false
E485:~$ gsettings set org.gnome.desktop.media-handling automount-open false
E485:~$ gsettings get org.gnome.desktop.media-handling automount           
false
E485:~$ gsettings get org.gnome.desktop.media-handling automount-open       
false
E485:~$


This is what i needed, thank you. :)
User avatar
Chiefahol2
 
Posts: 107
Joined: 2016-08-06 22:49


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable