SOLVED: Bumblebee with nvidia primus

New to Debian (Or Linux in general)? Ask your questions here!

SOLVED: Bumblebee with nvidia primus

Postby rossholmes » 2019-09-13 05:13

Hello Guys,

Yes, that would yet another request regarding nvidia. I would like to kindly ask you to support a newbie with setting up bumblebee to work with nvidia proprietary drivers on an optimus capable laptop. Here is what I have done so far:

- Installed packages according to Debian's wiki Bumblebee section:
Code: Select all
sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install bumblebee-nvidia primus libgl1-nvidia-glx primus-libs:i386 libgl1-nvidia-glx:i386

- added my user to bumblebee group
- didn't created xorg.xonf file during post-install as suggested by wiki page

Here is what I did experience:

- optirun runs steam, however doesn't launch any of my games (black screen)
- optirun reports an error no such file or directory when trying to run optirun glxgears -info
- steam was screaming for some nvidia legacy drivers to install
- Nvidia Xserver settings doesn't launch

As I am not a very experienced Linux admin, I don't exactly know how I could start my troubleshooting in order to find out my current setup, and do necessary adjustments if needed. This is why I greatly welcome any suggestions, advice regarding to this.

Many thanks for any help.

UPDATE: I've followed this guide and managed to get everything working correctly.
Posts: 1
Joined: 2019-09-13 04:44

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 7 guests