libcurl 3 on Debian 10?

New to Debian (Or Linux in general)? Ask your questions here!

libcurl 3 on Debian 10?

Postby kerryhall » 2019-10-20 08:28

I have a plugin for a daw that I've been trying for the past several months to get working.

Unfortunately the version of libc was too old, so I was told I needed to upgrade to Debian 10.

I did this, and in addition I tested everything in a vm and confirmed it worked.

I just did a fresh install of Debian 10 on my laptop, but now when I go to test the plugin, I get an error saying I need libcurl3.

First:
How do I install libcurl3 on Debian 10?

Second:
I tested this roughly a few weeks ago with the *exact* same version of the plugin and Debian 10. Was libcurl3 removed in the past few weeks?

This is maddening, I'm stuck in dependency hell right now.
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06

Re: libcurl 3 on Debian 10?

Postby Head_on_a_Stick » 2019-10-20 09:11

Code: Select all
empty@E485 ~ % aptitude search libcurl3
v   libcurl3-dev
v   libcurl3-dev:i386             -                                                                                                                                           
i   libcurl3-gnutls               - easy-to-use client-side URL transfer library (GnuTLS flavour)                                                                             
p   libcurl3-gnutls:i386          - easy-to-use client-side URL transfer library (GnuTLS flavour)                                                                             
v   libcurl3-gnutls-dev           -                                                                                                                                           
v   libcurl3-gnutls-dev:i386
p   libcurl3-nss                  - easy-to-use client-side URL transfer library (NSS flavour)                                                                               
p   libcurl3-nss:i386             - easy-to-use client-side URL transfer library (NSS flavour)                                                                               
v   libcurl3-nss-dev              -                                                                                                                                           
v   libcurl3-nss-dev:i386         -                                                                                                                                           
v   libcurl3-openssl-dev          -                                                                                                                                           
v   libcurl3-openssl-dev:i386     -                                                                                                                                           
empty@E485 ~ %

So try the -dev package.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: libcurl 3 on Debian 10?

Postby arochester » 2019-10-20 09:21

@H_o_a_S

So why does Aptitude show libcurl3-dev when Synaptic doesn't and apt installs libcurl4?
arochester
 
Posts: 1564
Joined: 2010-12-07 19:55

Re: libcurl 3 on Debian 10?

Postby Head_on_a_Stick » 2019-10-20 09:28

arochester wrote:So why does Aptitude show libcurl3-dev when Synaptic doesn't and apt installs libcurl4?

Because libcurl3-dev is a virtual package that has libcurl4-openssl-dev as a dependency. Hopefully that will provide the files the OP needs.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: libcurl 3 on Debian 10?

Postby kerryhall » 2019-10-20 17:24

I tried installing that package, but unfortunately no luck, same issue.

In fact, I get the error saying I need libcurl3 when I just do "ldd myplugin.so".

Perhaps there is a way I can download libcurl3 somehow, just the so file, put it in my home dir, then somehow tell ldd to tell "myplugin.so" to use the downloaded version of libcurl3?

Is this possible? If so, how would I go about it?

Thank you!
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06

Re: libcurl 3 on Debian 10?

Postby Head_on_a_Stick » 2019-10-21 18:02

Search the interweb for 'LD_PRELOAD'.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: libcurl 3 on Debian 10?

Postby kerryhall » 2019-10-21 22:48

Thank you! I will investigate that :)
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable