Install Error

New to Debian (Or Linux in general)? Ask your questions here!

Install Error

Postby gnome84 » 2019-12-02 18:45

Hello,

I have been trying to install Glassfish 5.0 and have been getting the following error:

"
Reading package lists...
Building dependency tree...
Reading state information...
glassfish-javaee is already the newest version (1:2.1.1-b31g+dfsg1-4).
The following packages were automatically installed and are no longer required:
libreadline5 libuv1
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 157 not upgraded.
24 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Setting up python-dnspython (1.15.0-1+deb9u1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-dnspython (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-repoze.lru (0.6-6) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-repoze.lru (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-beautifulsoup (3.2.1-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-beautifulsoup (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-yaml (3.12-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-yaml (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-cssselect (1.0.1-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-cssselect (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-feedparser (5.1.3-3) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-feedparser (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of calibre:
calibre depends on python-beautifulsoup (>= 3.0.5); however:
Package python-beautifulsoup is not configured yet.
calibre depends on python-cssselect (>= 0.7.1); however:
Package python-cssselect is not configured yet.
calibre depends on python-feedparser; however:
Package python-feedparser is not configured yet.

dpkg: error processing package calibre (--configure):
dependency problems - leaving unconfigured
Setting up python-mechanize (1:0.2.5-3) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-mechanize (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-webob (1:1.6.2-2) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-webob (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-dateutil (2.5.3-2) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-dateutil (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-cssutils (1.0-4.1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-cssutils (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-pygments (2.2.0+dfsg-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pygments (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-libxml2 (2.9.4+dfsg1-2.2+deb9u2) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-libxml2 (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-pygame (1.9.1release+dfsg-10+b2) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pygame (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-utidylib (0.3-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-utidylib (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-markdown (2.6.8-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-markdown (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-routes:
python-routes depends on python-repoze.lru; however:
Package python-repoze.lru is not configured yet.

dpkg: error processing package python-routes (--configure):
dependency problems - leaving unconfigured
Setting up python-sip (4.18.1+dfsg-2) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-sip (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up python-pyparsing (2.1.10+dfsg1-1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pyparsing (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-pyqt5:
python-pyqt5 depends on sip-api-11.3; however:
Package sip-api-11.3 is not installed.
Package python-sip which provides sip-api-11.3 is not configured yet.

dpkg: error processing package python-pyqt5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-pyqt5.qtwebkit:
python-pyqt5.qtwebkit depends on python-pyqt5 (= 5.7+dfsg-5); however:
Package python-pyqt5 is not configured yet.

dpkg: error processing package python-pyqt5.qtwebkit (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of calibre-bin:
calibre-bin depends on sip-api-11.3; however:
Package sip-api-11.3 is not installed.
Package python-sip which provides sip-api-11.3 is not configured yet.

dpkg: error processing package calibre-bin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-pyqt5.qtsvg:
python-pyqt5.qtsvg depends on python-pyqt5 (= 5.7+dfsg-5); however:
Package python-pyqt5 is not configured yet.

dpkg: error processing package python-pyqt5.qtsvg (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-cherrypy3:
python-cherrypy3 depends on python-routes; however:
Package python-routes is not configured yet.

dpkg: error processing package python-cherrypy3 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
python-dnspython
python-repoze.lru
python-beautifulsoup
python-yaml
python-cssselect
python-feedparser
calibre
python-mechanize
python-webob
python-dateutil
python-cssutils
python-pygments
python-libxml2
python-pygame
python-utidylib
python-markdown
python-routes
python-sip
python-pyparsing
python-pyqt5
python-pyqt5.qtwebkit
calibre-bin
python-pyqt5.qtsvg
python-cherrypy3
E: Sub-process /usr/bin/dpkg returned an error code (1)
"

Where do I start?
gnome84
 
Posts: 1
Joined: 2019-12-02 18:40

Re: Install Error

Postby Head_on_a_Stick » 2019-12-02 18:52

Post your sources and enclose all terminal output in code tags. Thanks.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Install Error

Postby stevepusser » 2019-12-02 19:14

So much missing information--especially since 5.0 isn't in Debian, nor any version since Jessie.

https://repology.org/project/glassfish/versions

It's also just good forum etiquette to provide a more specific thread title than an oh-so-generic "Install Error". :?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.9, Telegram-desktop 1.8.15, Pale Moon 28.8.0, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11316
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: Kenshin Himura and 13 guests

fashionable