Autologin memory leak?

New to Debian (Or Linux in general)? Ask your questions here!

Autologin memory leak?

Postby infinger » 2019-12-19 09:15

Hi everyone.
First of all, it's not a big problem for me, but I've noticed something strange.
I try to revive my first ever personal computer with 32bit Debian 9.11 help. Everything is ok, except autologing issue.
When I set lightdm.conf to autologin it works, but network-manager and modem-manager-gui autostart applets start with higher (~25-30mb) ram usage.
Then I need to kill their processes and turn on from terminal to work as usual. I tried to change lightdm to slim, nodm, lxdm, but then problem occurs even if I login manualy typing name and password. In other words, I can login only manualy through lightdm to avoid memory problems.
infinger
 
Posts: 8
Joined: 2019-12-19 08:25

Re: Autologin memory leak?

Postby Head_on_a_Stick » 2019-12-19 16:17

Using a display manager with autologin is just silly.

viewtopic.php?f=16&t=123694
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Autologin memory leak?

Postby infinger » 2019-12-19 18:05

I tried solution in this link. I can autologin without dm, but problem still occurs. No matter current LXDE setup or XFCE pure installation.
infinger
 
Posts: 8
Joined: 2019-12-19 08:25

Re: Autologin memory leak?

Postby Head_on_a_Stick » 2019-12-19 18:26

How are you measuring the RAM usage?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Autologin memory leak?

Postby infinger » 2019-12-19 18:31

Lxtask and I check overall memory usage by free command.
infinger
 
Posts: 8
Joined: 2019-12-19 08:25

Re: Autologin memory leak?

Postby Head_on_a_Stick » 2019-12-19 18:33

Is there anything relevant in the journal or ~/.xsession-errors?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Autologin memory leak?

Postby infinger » 2019-12-19 19:13

.xsession-errors
Code: Select all
Xsession: X session started for wstopek at czw, 19 gru 2019, 20:30:28 CET
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/wstopek/.Xauthority
localuser:wstopek being added to access control list
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
OpenGL version: 2.
dbus-update-activation-environment: setting USER=wstopek
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/wstopek
dbus-update-activation-environment: setting DESKTOP_SESSION=LXDE
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=wstopek
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting GDM_LANG=pl_PL.utf8
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=pl_PL.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=LXDE
dbus-update-activation-environment: setting XAUTHORITY=/home/wstopek/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/wstopek
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=LXDE
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/wstopek
** Message: main.vala:102: Session is LXDE
** Message: main.vala:103: DE is LXDE
** Message: main.vala:134: log directory: /home/wstopek/.cache/lxsession/LXDE
** Message: main.vala:135: log path: /home/wstopek/.cache/lxsession/LXDE/run.log
Xsession: X session started for wstopek at czw, 19 gru 2019, 20:35:41 CET
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting XAUTHORITY=/home/wstopek/.Xauthority
localuser:wstopek being added to access control list
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
OpenGL version: 2.
dbus-update-activation-environment: setting MAIL=/var/mail/wstopek
dbus-update-activation-environment: setting USER=wstopek
dbus-update-activation-environment: setting SHLVL=0
dbus-update-activation-environment: setting HOME=/home/wstopek
dbus-update-activation-environment: setting HUSHLOGIN=FALSE
dbus-update-activation-environment: setting QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
dbus-update-activation-environment: setting LOGNAME=wstopek
dbus-update-activation-environment: setting TERM=linux
dbus-update-activation-environment: setting WINDOWPATH=1
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=pl_PL.UTF-8
dbus-update-activation-environment: setting LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
dbus-update-activation-environment: setting XAUTHORITY=/home/wstopek/.Xauthority
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/wstopek
** Message: main.vala:102: Session is LXDE
** Message: main.vala:103: DE is LXDE
** Message: main.vala:134: log directory: /home/wstopek/.cache/lxsession/LXDE
** Message: main.vala:135: log path: /home/wstopek/.cache/lxsession/LXDE/run.log


Nothing unusual I think. As I said, it's not a big problem for me. Perhaps it should stay in manual login mode.
Edit:
I also noticed that network-manager launching in similar Debian 8 setup took longer. I've waited some 3-5 seconds after autologin for enabling the connection. Now (Debian 9.11) it's ready to go just after login.
infinger
 
Posts: 8
Joined: 2019-12-19 08:25


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable