I can't remove libreoffice [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

I can't remove libreoffice [SOLVED]

Postby jozmak » 2020-01-30 15:54

Hello,

I am running debian buster in chromebook container.

I installed libbreoffice from the .deb package a few weeks ago. Yestreday, I downloaded and installed the latest libreoffice version 6.4. It works great. Now, I have two versions installed. I want to remove the older version (6.3), but I can't.

When I run
Code: Select all
jozmak@penguin:~$ sudo dpkg -P libreoffice
dpkg: warning: ignoring request to remove libreoffice which isn't installed
jozmak@penguin:~$ sudo dpkg -r libreoffice
dpkg: warning: ignoring request to remove libreoffice which isn't installed
jozmak@penguin:~$


But libreoffice is instaled
Code: Select all
jozmak@penguin:~$ sudo dpkg -l
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                              Version                                    Architect
=================================================-==========================================-==.
.
.
ii  libreoffice6.3                                    6.3.3.2-2                                  amd64   
ii  libreoffice6.3-base                               6.3.3.2-2                                  amd64   
ii  libreoffice6.3-calc                               6.3.3.2-2                                  amd64   
ii  libreoffice6.3-debian-menus                       6.3.3-2                                    all     
ii  libreoffice6.3-dict-en                            6.3.3.2-2                                  amd64   
ii  libreoffice6.3-dict-es                            6.3.3.2-2                                  amd64   
ii  libreoffice6.3-dict-fr                            6.3.3.2-2                                  amd64   
ii  libreoffice6.3-draw                               6.3.3.2-2                                  amd64   
ii  libreoffice6.3-en-us                              6.3.3.2-2                                  amd64   
ii  libreoffice6.3-impress                            6.3.3.2-2                                  amd64   
ii  libreoffice6.3-math                               6.3.3.2-2                                  amd64   
ii  libreoffice6.3-ure                                6.3.3.2-2                                  amd64   
ii  libreoffice6.3-writer                             6.3.3.2-2                                  amd64   
ii  libreoffice6.4                                    6.4.0.3-3                                  amd64   
ii  libreoffice6.4-base                               6.4.0.3-3                                  amd64   
ii  libreoffice6.4-calc                               6.4.0.3-3                                  amd64   
ii  libreoffice6.4-debian-menus                       6.4.0-3                                    all     
ii  libreoffice6.4-dict-en                            6.4.0.3-3                                  amd64   
ii  libreoffice6.4-dict-es                            6.4.0.3-3                                  amd64   
ii  libreoffice6.4-dict-fr                            6.4.0.3-3                                  amd64   
ii  libreoffice6.4-draw                               6.4.0.3-3                                  amd64   
ii  libreoffice6.4-en-us                              6.4.0.3-3                                  amd64   
ii  libreoffice6.4-impress                            6.4.0.3-3                                  amd64   
ii  libreoffice6.4-math                               6.4.0.3-3                                  amd64   
ii  libreoffice6.4-ure                                6.4.0.3-3                                  amd64   
ii  libreoffice6.4-writer                             6.4.0.3-3                                  amd64   
.
.
.

Does anyone know how can I proceed from here?

I've tried to remove libreoffice by using synaptic but synaptic doesn't work due to the fact that in chromebook the debian container runs under wayland and synaptic is not compatible with wayland.

Thank you
Last edited by jozmak on 2020-01-30 16:46, edited 1 time in total.
jozmak
 
Posts: 52
Joined: 2005-06-17 02:33

Re: I can't remove libreoffice

Postby Head_on_a_Stick » 2020-01-30 16:09

Code: Select all
# aptitude purge libreoffice6.3

If that doesn't remove the rest of the 6.3 suite then you'll have to enter them manually. Use brace expansion to save some effort:
Code: Select all
# aptitude purge libreoffice6.3{,-{base,calc,etc}}

Replace etc with the names of the other packages (separated with commas).
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12770
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: I can't remove libreoffice

Postby jozmak » 2020-01-30 16:45

Thanks a lot.
Aptitude did the trick.
jozmak
 
Posts: 52
Joined: 2005-06-17 02:33


Return to Beginners Questions

Who is online

Users browsing this forum: Cyborg and 3 guests

fashionable