New to Debian (Or Linux in general)? Ask your questions here!


Postby mastokun » 2020-04-14 19:14


I started playing with linux again. I have a problem with installing the Aruba virtual connect. ( VPN/VIA connection to company network).
I get the error VIA-ui error wile loading shared libraties : cannot open shared object file: no such file or directory.
On the installer page I do not see Debian as supported but it does show Ubunbtu. Sinds ubuntu is based on Debian I thought is was wurth a shot.

Was this the wrong call and is this program not working for debian? Or am I missing something ?

Steps I took :

Updated Debian to lastest stable version.
Tried installing with full root.
Tried a few workarounds online with no luck.
apt install libgnome-keyring-common libgnome-keyring-dev -> unable to locate package
sudo apt install libgnome-keyring0 -> no isntallation candidate

program : ... nstall.htm

The installation was successfull but will not start.

Any tips?
Last edited by mastokun on 2020-04-15 04:56, edited 1 time in total.
Posts: 4
Joined: 2020-04-14 19:06

Re: libgnome-keyring

Postby arochester » 2020-04-14 20:29

Posts: 1744
Joined: 2010-12-07 19:55

Re: libgnome-keyring

Postby mastokun » 2020-04-17 20:10

Yes I found that to but not sure that I can confirm my idea that this will not work on Debian 10 ?
Posts: 4
Joined: 2020-04-14 19:06

Re: libgnome-keyring

Postby Head_on_a_Stick » 2020-04-18 10:42

Looks like buster is now using PAM authentication for the keyring:

Perhaps ask the Aruba folks about support.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 12650
Joined: 2014-06-01 17:46
Location: /dev/chair

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 12 guests