Internal hard disk drive not showing in file manager[SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

Internal hard disk drive not showing in file manager[SOLVED]

Postby cydragon » 2020-04-24 19:30

Hi,
I just reinstalled Debian 10 on my desktop computer and noticed my internal hard disk drives were not showing on my file manager to be mounted i checked throught the command lsblk which resulted in:

Code: Select all
NAME                       MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                          8:0    0 223.6G  0 disk 
├─sda1                       8:1    0   512M  0 part  /boot/efi
├─sda2                       8:2    0   244M  0 part  /boot
└─sda3                       8:3    0 222.9G  0 part 
  └─sda3_crypt             254:0    0 222.8G  0 crypt
    ├─dream--pc--vg-root   254:1    0 206.8G  0 lvm   /
    └─dream--pc--vg-swap_1 254:2    0    16G  0 lvm   [SWAP]
sdb                          8:16   0   1.8T  0 disk 
sdc                          8:32   0 931.5G  0 disk 



I then checked through blkid which showed:

Code: Select all
/dev/sda1: UUID="4014-B501" TYPE="vfat" PARTUUID="3b71eb5f-39f6-417c-b462-eb39dc39c5a9"
/dev/sda2: UUID="e1842bac-cf79-4cd2-a542-ee8b40932f29" TYPE="ext2" PARTUUID="6d65a5a0-4118-41ce-9cfc-e0ebc7023d2a"
/dev/sda3: UUID="b5722550-c719-43a5-9540-5a0002ffcc86" TYPE="crypto_LUKS" PARTUUID="6b21b251-5705-441d-9538-575655a778aa"
/dev/sdb: PTUUID="8a3a40fb-b264-437c-863d-bbc11ee65e34" PTTYPE="gpt"
/dev/mapper/sda3_crypt: UUID="rEU5zV-vMuf-6SXU-Pnoh-TSWH-3aZg-XnrPvN" TYPE="LVM2_member"
/dev/sdc: PTUUID="10943a0b-6042-4a33-9e93-585e09b0f784" PTTYPE="gpt"
/dev/mapper/dream--pc--vg-root: UUID="6f6f0628-52ae-482b-a740-8a09170cec06" TYPE="ext4"
/dev/mapper/dream--pc--vg-swap_1: UUID="f2876d9e-2f7f-4255-9fd1-6553557011de" TYPE="swap


Please keep in mind that sdb and sdc are the drives i am trying to mount, i never really had this issue before during my first time i installed Debian on my desktop, i'm not sure on the case of why this is happening, i checked /etc/fstab and noticed it was missing. I did try to edit it and this is what i have, i obviously did it wrong since i got an error for it:

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/dream--pc--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=e1842bac-cf79-4cd2-a542-ee8b40932f29 /boot           ext2    defaults        0    $
# /boot/efi was on /dev/sda1 during installation
UUID=4014-B501  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/dream--pc--vg-swap_1 none            swap    sw              0       0
#internal drives
PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 /dev/sdb   ext2     0       0
PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 /dev/sdc   ext2     0       0


when doing that i got this error:

Code: Select all
mount: /dev/sdb: special device PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 does not exist.
mount: /dev/sdc: special device PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 does not exist.


I checked through fsck for the filesystem type before editing /etc/fstab and this is what i originally had:
Code: Select all
fsck -N /dev/sdb
fsck from util-linux 2.33.1
[/usr/sbin/fsck.ext2 (1) -- /dev/sdb] fsck.ext2 /dev/sdb


after editing /etc/fstab and got the errors, i checked it again for both drives:

Code: Select all
fsck -N /dev/sdc
fsck from util-linux 2.33.1
[/usr/sbin/fsck.ext2 (1) -- /dev/sdc] fsck.ext2 PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784


Code: Select all
fsck -N /dev/sdb
fsck from util-linux 2.33.1
[/usr/sbin/fsck.ext2 (1) -- /dev/sdb] fsck.ext2 PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34


Overall i do i feel like im doing somthing wrong or may be missing somthing, so any help with this would great, thanks!

edit: nevermind i actually used cfdisk this time and fixed it

here is how i did it:

Code: Select all
cfdisk /dev/sdb

mkfs.ext4 /dev/sdb1

Creating filesystem with 488378385 4k blocks and 122101760 inodes
Filesystem UUID: cb35b719-37da-4817-b411-ffd24a52a113
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
        102400000, 214990848

Allocating group tables: done                           
Writing inode tables: done                           
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information:           


done

mkdir /disk

mount -t ext4 /dev/sdb1 /disk

ls -lsa /disk
total 24
 4 drwxr-xr-x  3 root root  4096 Apr 24 16:25 .
 4 drwxr-xr-x 19 root root  4096 Apr 24 16:26 ..
16 drwx------  2 root root 16384 Apr 24 16:25 lost+found


Did the exact same thing for /dev/sdc, now everything is back to normal. I also came across this guide that was helpful too: https://superuser.com/questions/161932/ ... -in-debian

Thanks again! Hopefully this post can help others when have a situation similar to mine. :D
Last edited by cydragon on 2020-04-25 04:01, edited 2 times in total.
cydragon
 
Posts: 6
Joined: 2020-04-24 18:51

Re: Internal hard disk drive not showing in file manager.

Postby 4D696B65 » 2020-04-24 21:01

cydragon wrote:
Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/dream--pc--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=e1842bac-cf79-4cd2-a542-ee8b40932f29 /boot           ext2    defaults        0    $
# /boot/efi was on /dev/sda1 during installation
UUID=4014-B501  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/dream--pc--vg-swap_1 none            swap    sw              0       0
#internal drives
PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 /dev/sdb   ext2     0       0
PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 /dev/sdc   ext2     0       0


when doing that i got this error:

Code: Select all
mount: /dev/sdb: special device PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 does not exist.
mount: /dev/sdc: special device PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 does not exist.



Code: Select all
<UUID> <mount directory> <FS type> <mount options> <dump> <pass>

You have <ptuuid> <file-system> <fs-type> <dump> <pass> You have defined the partition twice and omitted mount options.

Code: Select all
man mount

Code: Select all
man fstab
User avatar
4D696B65
 
Posts: 2469
Joined: 2009-06-28 06:09

Re: Internal hard disk drive not showing in file manager.

Postby cydragon » 2020-04-24 21:16

4D696B65 wrote:
cydragon wrote:
Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/dream--pc--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=e1842bac-cf79-4cd2-a542-ee8b40932f29 /boot           ext2    defaults        0    $
# /boot/efi was on /dev/sda1 during installation
UUID=4014-B501  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/dream--pc--vg-swap_1 none            swap    sw              0       0
#internal drives
PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 /dev/sdb   ext2     0       0
PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 /dev/sdc   ext2     0       0


when doing that i got this error:

Code: Select all
mount: /dev/sdb: special device PTUUID=8a3a40fb-b264-437c-863d-bbc11ee65e34 does not exist.
mount: /dev/sdc: special device PTUUID=10943a0b-6042-4a33-9e93-585e09b0f784 does not exist.



Code: Select all
<UUID> <mount directory> <FS type> <mount options> <dump> <pass>

You have <ptuuid> <file-system> <fs-type> <dump> <pass> You have defined the partition twice and omitted mount options.

Code: Select all
man mount

Code: Select all
man fstab


Oh ok, i'll definitely be sure to keep that in mind, i already took care of /etc/fstab before doing cfdisk. Here is what i have currently on it now:

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/dream--pc--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda2 during installation
UUID=e1842bac-cf79-4cd2-a542-ee8b40932f29 /boot           ext2    defaults        0       2
# /boot/efi was on /dev/sda1 during installation
UUID=4014-B501  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/dream--pc--vg-swap_1 none            swap    sw              0       0


After editing /etc/fstab, I used cfdisk to mount my other drives. I do appreciate you pointing out what i messed up on though. :)
cydragon
 
Posts: 6
Joined: 2020-04-24 18:51


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable