Atom installation on debian 10

New to Debian (Or Linux in general)? Ask your questions here!

Atom installation on debian 10

Postby gregory99 » 2020-06-05 05:28

Hi, I have tried to install Atom unsuccessfully. The icon is present but it doesn't want to open. I have first tried to download it through the website and I extracted the .deb but I didn't know what to do with it. So then I found a solution online on how to install it with the command line I used :
wget -O atom.deb
sudo dpkg -i atom.deb

When I try to open it with the command line it says : "/usr/bin/atom: line 190: 2869 Trace/breakpoint trap nohup "$ATOM_PATH" --executed-from="$(pwd)" --pid=$$ "$@" > "$ATOM_HOME/nohup.out" 2>&1
[2869:0605/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/share/atom/chrome-sandbox is owned by root and has mode 4755."
Posts: 4
Joined: 2020-06-04 14:13

Re: Atom installation on debian 10

Postby cuckooflew » 2020-06-05 07:22

This is not a package from Debian repositories, at least I can't find it listed any way. I suggest installing one of the many editors available in Debian respositories, you would also have the benefit of getting support for those, Does the Atom developers , and promoters not offer any support ?
Before going any further, you should read :
If you're coming to Debian from another operating system, you might be used to installing software that you find on random websites. On Debian installing software from random websites is a bad habit. It's always better to use software from the official Debian repositories if at all possible.

Please follow the link and read the entire page though, there is more important information
With that said, after you read and think about the above, if you really must have this Atom editor,..
The error message is clear and simple :
Code: Select all
You need to make sure that /usr/share/atom/chrome-sandbox is owned by root and has mode 4755."

Did you do this ? Check the permissions as instructed, if need be change them. You could have just done a search, using keywords:
Code: Select all
what does  it mean when it says  owned by root and has mode 4755 
Did you try this before asking ? Please Read.. What we expect you have already Done.
But any way, if you still really want to install this , I think if you do what the error message suggests, it might work. see:
Code: Select all
man chmod
Code: Select all
man chown

Code: Select all
chown root chrome-sandbox
chmod 4755 chrome-sandbox
Please Read.. What we expect you have already Done.
Does any one know about this ?
Users browsing this forum: Google Knows, and
My grand father knows all about everything:
…one flew east, one flew west,
One flew over the cuckoo’s nest.
Posts: 388
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Atom installation on debian 10

Postby pylkko » 2020-06-05 07:34

You can also just install the snap. Then it will make the sandbox and all that. As root, try this:

Code: Select all
apt install snapd
snap install atom --classic

This way you can easily update the software. If you manually install the deb, eventually it will get out of date and Atom packages/plugins will start to not work, then you will have to reinstall the newer version manually again.
User avatar
Posts: 1738
Joined: 2014-11-06 19:02

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 9 guests