update show 377 packages upgrade, upgrade = 364 not upgraded

New to Debian (Or Linux in general)? Ask your questions here!

update show 377 packages upgrade, upgrade = 364 not upgraded

Postby hughparker1 » 2020-06-14 20:13

DELL Inspiron 5559 - Debian Bullseye (edit: UEFI)

Hi, I'm trying to update and it shows 377 packages for upgrade,

but when I try to upgrade, it shows ....

13 upgraded, 0 newly installed, 0 to remove and 364 not upgraded

found a potential solution here (although is is relating to ubuntu.)..

https://askubuntu.com/questions/601/the ... 799#862799

and I tried Cautious solution 1:

Per Pablo's answer, you can run 'sudo apt-get --with-new-pkgs upgrade', and it will install the kept-back packages.

but this didn't have any effect, same result '364 not upgraded'.

I was wondering if I should try Cautious solution 2:

The cautious solution is to run 'sudo apt-get install <list of packages kept back>'. In most cases this will give the kept-back packages what they need to successfully upgrade.

any advice would be appreciated.

P.S. is 'sudo apt-get dist-upgrade' advisable?

P.S.2. this is happening on two different laptops, one UEFI and other is old legacy BIOS

here is some details of my system...

Code: Select all
hugh@DELL-DEBIAN:~$ cat /etc/apt/sources.list
#

deb http://deb.debian.org/debian/ bullseye main contrib non-free

deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free

deb http://deb.debian.org/debian-security bullseye-security main
hugh@DELL-DEBIAN:~$




Code: Select all
hugh@DELL-DEBIAN:~$ sudo apt update
[sudo] password for hugh:
Get:1 http://deb.debian.org/debian bullseye InRelease [116 kB]
Get:2 http://deb.debian.org/debian bullseye-updates InRelease [38.8 kB]
Get:3 http://deb.debian.org/debian-security bullseye-security InRelease [44.1 kB]
Get:4 http://deb.debian.org/debian bullseye/main amd64 Packages.diff/Index [27.9 kB]
Get:5 http://deb.debian.org/debian bullseye/main Translation-en.diff/Index [27.9 kB]
Get:6 http://deb.debian.org/debian bullseye/contrib amd64 Packages.diff/Index [27.8 kB]
Get:7 http://deb.debian.org/debian bullseye/contrib Translation-en.diff/Index [27.8 kB]
Get:8 http://deb.debian.org/debian bullseye/non-free amd64 Packages.diff/Index [27.8 kB]
Get:9 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-12-1400.50.pdiff [47 B]
Get:10 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-12-2000.13.pdiff [590 B]
Get:11 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-13-0200.47.pdiff [19.9 kB]
Get:12 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-13-0800.11.pdiff [209 B]
Get:13 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-13-1400.33.pdiff [33 B]
Get:14 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-14-0200.18.pdiff [51.4 kB]
Get:15 http://deb.debian.org/debian bullseye/main Translation-en 2020-06-12-1400.50.pdiff [46 B]
Get:16 http://deb.debian.org/debian bullseye/main Translation-en 2020-06-13-0200.47.pdiff [2,435 B]
Get:14 http://deb.debian.org/debian bullseye/main amd64 Packages 2020-06-14-0200.18.pdiff [51.4 kB]
Get:17 http://deb.debian.org/debian bullseye/main Translation-en 2020-06-13-1400.33.pdiff [33 B]
Get:18 http://deb.debian.org/debian bullseye/main Translation-en 2020-06-14-0200.18.pdiff [5,566 B]
Get:18 http://deb.debian.org/debian bullseye/main Translation-en 2020-06-14-0200.18.pdiff [5,566 B]
Get:19 http://deb.debian.org/debian bullseye/contrib amd64 Packages 2020-06-14-0200.18.pdiff [1,242 B]
Get:19 http://deb.debian.org/debian bullseye/contrib amd64 Packages 2020-06-14-0200.18.pdiff [1,242 B]
Get:20 http://deb.debian.org/debian bullseye/contrib Translation-en 2020-06-14-0200.18.pdiff [592 B]         
Get:20 http://deb.debian.org/debian bullseye/contrib Translation-en 2020-06-14-0200.18.pdiff [592 B] 
Get:21 http://deb.debian.org/debian bullseye/non-free amd64 Packages 2020-06-12-2000.13.pdiff [286 B]         
Get:22 http://deb.debian.org/debian bullseye/non-free amd64 Packages 2020-06-13-0200.47.pdiff [618 B]         
Get:23 http://deb.debian.org/debian bullseye/non-free amd64 Packages 2020-06-14-0200.18.pdiff [726 B]         
Get:23 http://deb.debian.org/debian bullseye/non-free amd64 Packages 2020-06-14-0200.18.pdiff [726 B]
Fetched 422 kB in 1s (325 kB/s)                                                       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
377 packages can be upgraded. Run 'apt list --upgradable' to see them.
hugh@DELL-DEBIAN:~$




Code: Select all
hugh@DELL-DEBIAN:~$ apt list --upgradable
Listing... Done
alsa-utils/testing 1.2.2-1 amd64 [upgradable from: 1.1.8-2]
apparmor/testing 2.13.4-2 amd64 [upgradable from: 2.13.4-1+b1]
aspell/testing 0.60.8-1 amd64 [upgradable from: 0.60.7~20110707-6]
atril/testing 1.24.0-1 amd64 [upgradable from: 1.20.3-1+deb10u1]
chromium-common/testing 81.0.4044.92-1 amd64 [upgradable from: 80.0.3987.162-1~deb10u1]
chromium-sandbox/testing 81.0.4044.92-1 amd64 [upgradable from: 80.0.3987.162-1~deb10u1]
chromium/testing 81.0.4044.92-1 amd64 [upgradable from: 80.0.3987.162-1~deb10u1]
coinor-libcbc3/testing 2.10.4+repack1-1 amd64 [upgradable from: 2.9.9+repack1-1]
coinor-libcgl1/testing 0.60.3+repack1-2 amd64 [upgradable from: 0.59.10+repack1-1]
coinor-libclp1/testing 1.17.5+repack1-1 amd64 [upgradable from: 1.16.11+repack1-1]
coinor-libcoinutils3v5/testing 2.11.4+repack1-1 amd64 [upgradable from: 2.10.14+repack1-1]
colord/testing 1.4.4-2 amd64 [upgradable from: 1.4.3-4]
cpp-8/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
cups-browsed/testing 1.27.4-1+b1 amd64 [upgradable from: 1.21.6-5]
cups-filters-core-drivers/testing 1.27.4-1+b1 amd64 [upgradable from: 1.21.6-5]
cups-filters/testing 1.27.4-1+b1 amd64 [upgradable from: 1.21.6-5]
espeak-ng-data/testing 1.50+dfsg-6 amd64 [upgradable from: 1.49.2+dfsg-8]
evince-common/testing 3.36.1-1 all [upgradable from: 3.30.2-3+deb10u1]
evince/testing 3.36.1-1 amd64 [upgradable from: 3.30.2-3+deb10u1]
exim4-base/testing 4.94-2 amd64 [upgradable from: 4.92-8+deb10u4]
exim4-config/testing 4.94-2 all [upgradable from: 4.93-16]
exim4-daemon-light/testing 4.94-2 amd64 [upgradable from: 4.92-8+deb10u4]
exo-utils/testing 0.12.11-1 amd64 [upgradable from: 0.12.4-1]
firebird3.0-common-doc/testing 3.0.5.33220.ds4-1 all [upgradable from: 3.0.5.33100.ds4-2]
firebird3.0-common/testing 3.0.5.33220.ds4-1 all [upgradable from: 3.0.5.33100.ds4-2]
firebird3.0-server-core/testing 3.0.5.33220.ds4-1+b1 amd64 [upgradable from: 3.0.5.33100.ds4-2]
firebird3.0-utils/testing 3.0.5.33220.ds4-1+b1 amd64 [upgradable from: 3.0.5.33100.ds4-2]
firefox-esr-l10n-en-gb/testing 68.9.0esr-1 all [upgradable from: 68.8.0esr-1~deb10u1]
firefox-esr/testing 68.9.0esr-1 amd64 [upgradable from: 68.8.0esr-1~deb10u1]
g++-8/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
gcc-8-base/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
gcc-8/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
gdisk/testing 1.0.5-1 amd64 [upgradable from: 1.0.3-1.1]
ghostscript/testing 9.52~dfsg-1 amd64 [upgradable from: 9.27~dfsg-2+deb10u3]
gimp-data/testing 2.10.18-1 all [upgradable from: 2.10.8-2]
gimp/testing 2.10.18-1 amd64 [upgradable from: 2.10.8-2]
gir1.2-freedesktop/testing 1.64.1-1 amd64 [upgradable from: 1.58.3-2]
gir1.2-glib-2.0/testing 1.64.1-1 amd64 [upgradable from: 1.58.3-2]
gir1.2-gst-plugins-base-1.0/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
gir1.2-gstreamer-1.0/testing 1.16.2-2 amd64 [upgradable from: 1.14.4-1]
gir1.2-gtk-3.0/testing 3.24.20-1 amd64 [upgradable from: 3.24.5-1]
gir1.2-pango-1.0/testing 1.44.7-4 amd64 [upgradable from: 1.42.4-8~deb10u1]
gir1.2-polkit-1.0/testing 0.105-26 amd64 [upgradable from: 0.105-25]
gir1.2-soup-2.4/testing 2.70.0-1 amd64 [upgradable from: 2.64.2-2]
glib-networking-services/testing 2.64.2-1 amd64 [upgradable from: 2.58.0-2]
glib-networking/testing 2.64.2-1 amd64 [upgradable from: 2.58.0-2]
gnome-desktop3-data/testing 3.36.2-1 all [upgradable from: 3.30.2.1-2]
groff-base/testing 1.22.4-5 amd64 [upgradable from: 1.22.4-3]
grub-efi-amd64-signed/testing 1+2.04+8 amd64 [upgradable from: 1+2.04+7]
gstreamer1.0-alsa/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
gstreamer1.0-gl/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
gstreamer1.0-libav/testing 1.16.2-2 amd64 [upgradable from: 1.15.0.1+git20180723+db823502-2]
gstreamer1.0-plugins-bad/testing 1.16.2-2.1+b1 amd64 [upgradable from: 1.14.4-1+b1]
gstreamer1.0-plugins-base/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
gstreamer1.0-plugins-good/testing 1.16.2-3 amd64 [upgradable from: 1.14.4-1]
gstreamer1.0-plugins-ugly/testing 1.16.2-2+b1 amd64 [upgradable from: 1.14.4-1]
gstreamer1.0-pulseaudio/testing 1.16.2-3 amd64 [upgradable from: 1.14.4-1]
gstreamer1.0-x/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
guile-2.2-libs/testing 2.2.7+1-5 amd64 [upgradable from: 2.2.4+1-2+deb10u1]
gvfs-common/testing 1.44.1-1 all [upgradable from: 1.38.1-5]
gvfs-daemons/testing 1.44.1-1 amd64 [upgradable from: 1.38.1-5]
gvfs-libs/testing 1.44.1-1 amd64 [upgradable from: 1.38.1-5]
gvfs/testing 1.44.1-1 amd64 [upgradable from: 1.38.1-5]
hplip-data/testing 3.20.5+dfsg0-3 all [upgradable from: 3.18.12+dfsg0-2]
hplip/testing 3.20.5+dfsg0-3 amd64 [upgradable from: 3.18.12+dfsg0-2]
i965-va-driver/testing 2.4.0+dfsg1-1 amd64 [upgradable from: 2.3.0+dfsg1-1]
intel-media-va-driver/testing 20.1.1+dfsg1-1 amd64 [upgradable from: 18.4.1+dfsg1-1]
iproute2/testing 5.7.0-1 amd64 [upgradable from: 4.20.0-2]
iptables/testing 1.8.4-3 amd64 [upgradable from: 1.8.2-4]
keepassx/testing 2.0.3+git20190121.1682ab9-2.1+b1 amd64 [upgradable from: 2.0.3-2]
libalgorithm-diff-xs-perl/testing 0.04-6 amd64 [upgradable from: 0.04-5+b1]
libaom0/testing 1.0.0.errata1-3 amd64 [upgradable from: 1.0.0-3]
libapparmor1/testing 2.13.4-2 amd64 [upgradable from: 2.13.4-1+b1]
libappstream4/testing 0.12.11-1 amd64 [upgradable from: 0.12.5-1]
libapt-pkg-perl/testing 0.1.36+b3 amd64 [upgradable from: 0.1.34+b1]
libasm-java/testing 7.3.1-1 all [upgradable from: 7.2-1]
libasound2-data/testing 1.2.2-2.1 all [upgradable from: 1.1.8-1]
libasound2-plugins/testing 1.2.2-1 amd64 [upgradable from: 1.1.8-1]
libasound2/testing 1.2.2-2.1 amd64 [upgradable from: 1.1.8-1]
libaspell15/testing 0.60.8-1 amd64 [upgradable from: 0.60.7~20110707-6]
libatrildocument3/testing 1.24.0-1 amd64 [upgradable from: 1.20.3-1+deb10u1]
libatrilview3/testing 1.24.0-1 amd64 [upgradable from: 1.20.3-1+deb10u1]
libavcodec58/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libavfilter7/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libavformat58/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libavresample4/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libavutil56/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libayatana-ido3-0.4-0/testing 0.4.90-1 amd64 [upgradable from: 0.4.4-1]
libbabl-0.1-0/testing 0.1.74-1 amd64 [upgradable from: 0.1.62-1]
libblockdev-part2/testing 2.24-1 amd64 [upgradable from: 2.20-7+deb10u1]
libbrotli1/testing 1.0.7-6.1 amd64 [upgradable from: 1.0.7-2]
libc-bin/testing 2.30-8 amd64 [upgradable from: 2.28-10]
libc-dev-bin/testing 2.30-8 amd64 [upgradable from: 2.28-10]
libc6-dev/testing 2.30-8 amd64 [upgradable from: 2.28-10]
libc6/testing 2.30-8 amd64 [upgradable from: 2.28-10]
libcairo-perl/testing 1.107-1 amd64 [upgradable from: 1.106-3+b1]
libcdr-0.1-1/testing 0.1.6-1+b1 amd64 [upgradable from: 0.1.6-1]
libchromaprint1/testing 1.5.0-1 amd64 [upgradable from: 1.4.3-3]
libclone-perl/testing 0.45-1 amd64 [upgradable from: 0.41-1+b1]
libcolord2/testing 1.4.4-2 amd64 [upgradable from: 1.4.3-4]
libcupsfilters1/testing 1.27.4-1+b1 amd64 [upgradable from: 1.21.6-5]
libdc1394-22/testing 2.2.5-2.1 amd64 [upgradable from: 2.2.5-1]
libde265-0/testing 1.0.4-1 amd64 [upgradable from: 1.0.3-1+b1]
libdjvulibre21/testing 3.5.27.1-14 amd64 [upgradable from: 3.5.27.1-10]
libdrm-amdgpu1/testing 2.4.101-2 amd64 [upgradable from: 2.4.97-1]
libdrm2/testing 2.4.101-2 amd64 [upgradable from: 2.4.97-1]
libe-book-0.1-1/testing 0.1.3-1+b3 amd64 [upgradable from: 0.1.3-1+b2]
libegl-mesa0/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libenchant1c2a/testing 1.6.0-11.4 amd64 [upgradable from: 1.6.0-11.1+b1]
libespeak-ng1/testing 1.50+dfsg-6 amd64 [upgradable from: 1.49.2+dfsg-8]
libevdocument3-4/testing 3.36.1-1 amd64 [upgradable from: 3.30.2-3+deb10u1]
libevview3-3/testing 3.36.1-1 amd64 [upgradable from: 3.30.2-3+deb10u1]
libexif12/testing 0.6.22-1 amd64 [upgradable from: 0.6.21-5.1+deb10u1]
libexo-1-0/testing 0.12.11-1 amd64 [upgradable from: 0.12.4-1]
libexo-2-0/testing 0.12.11-1 amd64 [upgradable from: 0.12.4-1]
libfaad2/testing 2.9.2-1 amd64 [upgradable from: 2.8.8-3]
libfbclient2/testing 3.0.5.33220.ds4-1+b1 amd64 [upgradable from: 3.0.5.33100.ds4-2]
libfcgi-perl/testing 0.79-1 amd64 [upgradable from: 0.78-2+b3]
libfile-fcntllock-perl/testing 0.22-3+b6 amd64 [upgradable from: 0.22-3+b5]
libflite1/testing 2.1-release-4 amd64 [upgradable from: 2.1-release-3]
libgail-3-0/testing 3.24.20-1 amd64 [upgradable from: 3.24.5-1]
libgail-common/testing 2.24.32-4 amd64 [upgradable from: 2.24.32-3]
libgail18/testing 2.24.32-4 amd64 [upgradable from: 2.24.32-3]
libgbm1/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libgcc-8-dev/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
libgd3/testing 2.3.0-2 amd64 [upgradable from: 2.2.5-5.2]
libgegl-0.4-0/testing 0.4.22-3 amd64 [upgradable from: 0.4.12-2]
libgexiv2-2/testing 0.12.1-1 amd64 [upgradable from: 0.10.9-1]
libgfortran5/testing 10.1.0-3 amd64 [upgradable from: 8.3.0-6]
libgimp2.0/testing 2.10.18-1 amd64 [upgradable from: 2.10.8-2]
libgirepository-1.0-1/testing 1.64.1-1 amd64 [upgradable from: 1.58.3-2]
libgl1-mesa-dri/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libglapi-mesa/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libglib-perl/testing 3:1.329.3-1 amd64 [upgradable from: 3:1.329-1]
libglib2.0-0/testing 2.64.3-1 amd64 [upgradable from: 2.58.3-2+deb10u2]
libglib2.0-bin/testing 2.64.3-1 amd64 [upgradable from: 2.58.3-2+deb10u2]
libglibmm-2.4-1v5/testing 2.64.2-1 amd64 [upgradable from: 2.58.0-2]
libglx-mesa0/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libgme0/testing 0.6.3-2 amd64 [upgradable from: 0.6.2-1]
libgnutls-dane0/testing 3.6.14-2 amd64 [upgradable from: 3.6.14-1]
libgnutls30/testing 3.6.14-2 amd64 [upgradable from: 3.6.14-1]
libgpg-error-l10n/testing 1.38-1 all [upgradable from: 1.37-1]
libgpg-error0/testing 1.38-1 amd64 [upgradable from: 1.37-1]
libgphoto2-6/testing 2.5.24-1 amd64 [upgradable from: 2.5.22-3]
libgs9-common/testing 9.52~dfsg-1 all [upgradable from: 9.27~dfsg-2+deb10u3]
libgs9/testing 9.52~dfsg-1 amd64 [upgradable from: 9.27~dfsg-2+deb10u3]
libgstreamer-gl1.0-0/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
libgstreamer-plugins-bad1.0-0/testing 1.16.2-2.1+b1 amd64 [upgradable from: 1.14.4-1+b1]
libgstreamer-plugins-base1.0-0/testing 1.16.2-4 amd64 [upgradable from: 1.14.4-2]
libgstreamer1.0-0/testing 1.16.2-2 amd64 [upgradable from: 1.14.4-1]
libgtk-3-0/testing 3.24.20-1 amd64 [upgradable from: 3.24.5-1]
libgtk-3-bin/testing 3.24.20-1 amd64 [upgradable from: 3.24.5-1]
libgtk2.0-0/testing 2.24.32-4 amd64 [upgradable from: 2.24.32-3]
libgtk2.0-bin/testing 2.24.32-4 amd64 [upgradable from: 2.24.32-3]
libgutenprint-common/testing 5.3.3-4 all [upgradable from: 5.3.1-7]
libgutenprint9/testing 5.3.3-4 amd64 [upgradable from: 5.3.1-7]
libharfbuzz-icu0/testing 2.6.4-1+b1 amd64 [upgradable from: 2.6.4-1]
libheif1/testing 1.6.1-1 amd64 [upgradable from: 1.3.2-2~deb10u1]
libhpmud0/testing 3.20.5+dfsg0-3 amd64 [upgradable from: 3.18.12+dfsg0-2]
libhtml-parser-perl/testing 3.72-5 amd64 [upgradable from: 3.72-3+b3]
libhttp-message-perl/testing 6.24-1 all [upgradable from: 6.18-1]
libib-util/testing 3.0.5.33220.ds4-1+b1 amd64 [upgradable from: 3.0.5.33100.ds4-2]
libicu63/testing 63.2-3 amd64 [upgradable from: 63.1-6+deb10u1]
libinput10/testing 1.15.5-1 amd64 [upgradable from: 1.12.6-2]
libio-pty-perl/testing 1:1.12-1 amd64 [upgradable from: 1:1.08-1.1+b5]
libiptc0/testing 1.8.4-3 amd64 [upgradable from: 1.8.2-4]
libiw30/testing 30~pre9-13.1 amd64 [upgradable from: 30~pre9-13]
libjavascriptcoregtk-4.0-18/testing 2.28.2-2+b1 amd64 [upgradable from: 2.28.2-2~deb10u1]
liblapack3/testing 3.9.0-2 amd64 [upgradable from: 3.8.0-2]
liblcms2-2/testing 2.9-4+b1 amd64 [upgradable from: 2.9-3]
liblilv-0-0/testing 0.24.8~dfsg0-1 amd64 [upgradable from: 0.24.2~dfsg0-2]
liblist-moreutils-perl/testing 0.416-1+b5 amd64 [upgradable from: 0.416-1+b4]
liblocale-gettext-perl/testing 1.07-4 amd64 [upgradable from: 1.07-3+b4]
libmagickcore-6.q16-6/testing 8:6.9.10.23+dfsg-2.1+b2 amd64 [upgradable from: 8:6.9.10.23+dfsg-2.1]
libmaven-resolver-java/testing 1.4.2-1 all [upgradable from: 1.4.1-1]
libmetis5/testing 5.1.0.dfsg-7 amd64 [upgradable from: 5.1.0.dfsg-5+b2]
libmp3lame0/testing 3.100-3 amd64 [upgradable from: 3.100-2+b1]
libmpcdec6/testing 2:0.1~r495-2 amd64 [upgradable from: 2:0.1~r495-1+b2]
libmpx2/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
libmspub-0.1-1/testing 0.1.4-3+b1 amd64 [upgradable from: 0.1.4-1+b2]
libmwaw-0.3-3/testing 0.3.16-1 amd64 [upgradable from: 0.3.14-1]
libnet-dbus-perl/testing 1.2.0-1 amd64 [upgradable from: 1.1.0-5+b1]
libnet-dns-sec-perl/testing 1.16-1 amd64 [upgradable from: 1.11-1]
libnet-libidn-perl/testing 0.12.ds-3+b2 amd64 [upgradable from: 0.12.ds-3+b1]
libnet-ssleay-perl/testing 1.88-3 amd64 [upgradable from: 1.85-2+b1]
libnftables1/testing 0.9.5-1 amd64 [upgradable from: 0.9.4-1]
libnftnl11/testing 1.1.7-1 amd64 [upgradable from: 1.1.6-1]
libnss-systemd/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
libofa0/testing 0.9.3-21 amd64 [upgradable from: 0.9.3-19]
libopenjp2-7/testing 2.3.1-1 amd64 [upgradable from: 2.3.0-2+deb10u1]
libopenmpt0/testing 0.4.11-1 amd64 [upgradable from: 0.4.3-1]
libpam-systemd/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
libpango-1.0-0/testing 1.44.7-4 amd64 [upgradable from: 1.42.4-8~deb10u1]
libpango-perl/testing 1.227-3+b2 amd64 [upgradable from: 1.227-3+b1]
libpangocairo-1.0-0/testing 1.44.7-4 amd64 [upgradable from: 1.42.4-8~deb10u1]
libpangoft2-1.0-0/testing 1.44.7-4 amd64 [upgradable from: 1.42.4-8~deb10u1]
libpangoxft-1.0-0/testing 1.44.7-4 amd64 [upgradable from: 1.42.4-8~deb10u1]
libperlio-gzip-perl/testing 0.19-1+b6 amd64 [upgradable from: 0.19-1+b5]
libpng16-16/testing 1.6.37-2 amd64 [upgradable from: 1.6.36-6]
libpolkit-agent-1-0/testing 0.105-26 amd64 [upgradable from: 0.105-25]
libpolkit-gobject-1-0/testing 0.105-26 amd64 [upgradable from: 0.105-25]
libpoppler-glib8/testing 0.71.0-6 amd64 [upgradable from: 0.71.0-5]
libpoppler82/testing 0.71.0-6 amd64 [upgradable from: 0.71.0-5]
libpostproc55/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libpulse-mainloop-glib0/testing 13.0-5 amd64 [upgradable from: 12.2-4+deb10u1]
libpulse0/testing 13.0-5 amd64 [upgradable from: 12.2-4+deb10u1]
libpulsedsp/testing 13.0-5 amd64 [upgradable from: 12.2-4+deb10u1]
libpython-stdlib/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
libpython2-stdlib/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
libpython2.7-minimal/testing 2.7.18-1 amd64 [upgradable from: 2.7.16-2+deb10u1]
libpython2.7-stdlib/testing 2.7.18-1 amd64 [upgradable from: 2.7.16-2+deb10u1]
libpython2.7/testing 2.7.18-1 amd64 [upgradable from: 2.7.16-2+deb10u1]
libpython3-stdlib/testing 3.8.2-3 amd64 [upgradable from: 3.7.3-1]
libqxp-0.0-0/testing 0.0.2-1+b1 amd64 [upgradable from: 0.0.2-1]
libreoffice-avmedia-backend-gstreamer/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-base-core/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-base-drivers/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-base/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-calc/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-common/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-core/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-draw/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-help-common/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-help-en-gb/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-help-en-us/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-impress/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-java-common/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-l10n-en-gb/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-math/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-report-builder-bin/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-report-builder/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-sdbc-firebird/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-sdbc-hsqldb/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-sdbc-postgresql/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-style-tango/testing 1:6.4.4-1 all [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice-writer/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
libreoffice/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
librsvg2-2/testing 2.48.4+dfsg-1 amd64 [upgradable from: 2.44.10-2.1]
librsvg2-common/testing 2.48.4+dfsg-1 amd64 [upgradable from: 2.44.10-2.1]
librubberband2/testing 1.8.2-1 amd64 [upgradable from: 1.8.1-7]
libsane-hpaio/testing 3.20.5+dfsg0-3 amd64 [upgradable from: 3.18.12+dfsg0-2]
libsane/testing 1.0.27-3.2+b1 amd64 [upgradable from: 1.0.27-3.2]
libsdl1.2debian/testing 1.2.15+dfsg2-5 amd64 [upgradable from: 1.2.15+dfsg2-4]
libselinux1/testing 3.0-1+b3 amd64 [upgradable from: 2.8-1+b1]
libsemanage-common/testing 3.0-1 all [upgradable from: 2.8-2]
libsemanage1/testing 3.0-1+b3 amd64 [upgradable from: 2.8-2]
libsensors5/testing 1:3.6.0-2 amd64 [upgradable from: 1:3.5.0-3]
libserd-0-0/testing 0.30.2-1 amd64 [upgradable from: 0.28.0~dfsg0-1]
libsereal-decoder-perl/testing 4.014+ds-1 amd64 [upgradable from: 4.005+ds-1+b1]
libsereal-encoder-perl/testing 4.014+ds-1 amd64 [upgradable from: 4.005+ds-1+b1]
libsereal-perl/testing 4.014-1 all [upgradable from: 4.005-1]
libslang2/testing 2.3.2-5 amd64 [upgradable from: 2.3.2-2]
libsmbclient/testing 2:4.11.5+dfsg-1+b1 amd64 [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
libsndfile1/testing 1.0.28-8 amd64 [upgradable from: 1.0.28-6]
libsocket6-perl/testing 0.29-1+b2 amd64 [upgradable from: 0.29-1+b1]
libsoup2.4-1/testing 2.70.0-1 amd64 [upgradable from: 2.64.2-2]
libsoxr0/testing 0.1.3-4 amd64 [upgradable from: 0.1.2-3]
libspeex1/testing 1.2~rc1.2-1.1 amd64 [upgradable from: 1.2~rc1.2-1+b2]
libspeexdsp1/testing 1.2~rc1.2-1.1 amd64 [upgradable from: 1.2~rc1.2-1+b2]
libsqlite3-0/testing 3.31.1-5 amd64 [upgradable from: 3.27.2-3]
libsratom-0-0/testing 0.6.4-1 amd64 [upgradable from: 0.6.0~dfsg0-1]
libstdc++-8-dev/testing 8.4.0-4 amd64 [upgradable from: 8.3.0-6]
libsub-name-perl/testing 0.26-1 amd64 [upgradable from: 0.21-1+b3]
libswresample3/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libswscale5/testing 7:4.2.2-1+b1 amd64 [upgradable from: 7:4.1.4-1~deb10u1]
libsystemd0/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
libtag1v5-vanilla/testing 1.11.1+dfsg.1-2+b1 amd64 [upgradable from: 1.11.1+dfsg.1-2]
libtag1v5/testing 1.11.1+dfsg.1-2+b1 amd64 [upgradable from: 1.11.1+dfsg.1-2]
libtcl8.6/testing 8.6.10+dfsg-1 amd64 [upgradable from: 8.6.9+dfsg-2]
libtext-charwidth-perl/testing 0.04-10 amd64 [upgradable from: 0.04-7.1+b1]
libtext-iconv-perl/testing 1.7-7 amd64 [upgradable from: 1.7-5+b7]
libtiff5/testing 4.1.0+git191117-2 amd64 [upgradable from: 4.1.0+git191117-2~deb10u1]
libtk8.6/testing 8.6.10-1 amd64 [upgradable from: 8.6.9-2]
libtwolame0/testing 0.4.0-2 amd64 [upgradable from: 0.3.13-4]
libudev1/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
libumfpack5/testing 1:5.7.2+dfsg-1 amd64 [upgradable from: 1:5.4.0+dfsg-1]
libunicode-utf8-perl/testing 0.62-1+b1 amd64 [upgradable from: 0.62-1]
libvisio-0.1-1/testing 0.1.7-1+b1 amd64 [upgradable from: 0.1.7-1]
libvisual-0.4-0/testing 0.4.0-17 amd64 [upgradable from: 0.4.0-15]
libvte-2.91-0/testing 0.60.2-1+b1 amd64 [upgradable from: 0.60.2-1]
libvte-2.91-common/testing 0.60.2-1+b1 amd64 [upgradable from: 0.60.2-1]
libvulkan1/testing 1.2.135.0-3 amd64 [upgradable from: 1.1.97-2]
libwbclient0/testing 2:4.11.5+dfsg-1+b1 amd64 [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
libwebkit2gtk-4.0-37/testing 2.28.2-2+b1 amd64 [upgradable from: 2.28.2-2~deb10u1]
libwps-0.4-4/testing 0.4.11-1 amd64 [upgradable from: 0.4.10-1]
libxapian30/testing 1.4.15-1 amd64 [upgradable from: 1.4.11-1]
libxatracker2/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
libxml-libxml-perl/testing 2.0134+dfsg-2 amd64 [upgradable from: 2.0134+dfsg-1]
libxml-parser-perl/testing 2.46-1+b1 amd64 [upgradable from: 2.44-4]
libxml2/testing 2.9.10+dfsg-5+b1 amd64 [upgradable from: 2.9.4+dfsg1-7+b3]
libxslt1.1/testing 1.1.34-4 amd64 [upgradable from: 1.1.32-2.2~deb10u1]
libxtables12/testing 1.8.4-3 amd64 [upgradable from: 1.8.2-4]
libxvidcore4/testing 2:1.3.7-1 amd64 [upgradable from: 2:1.3.5-1]
libyaml-libyaml-perl/testing 0.82+repack-1 amd64 [upgradable from: 0.76+repack-1]
libzmf-0.0-0/testing 0.0.2-1+b3 amd64 [upgradable from: 0.0.2-1+b2]
libzvbi-common/testing 0.2.35-18 all [upgradable from: 0.2.35-16]
libzvbi0/testing 0.2.35-18 amd64 [upgradable from: 0.2.35-16]
lintian/testing 2.80.0 all [upgradable from: 2.15.0]
locales/testing 2.30-8 all [upgradable from: 2.28-10]
login/testing 1:4.8.1-1 amd64 [upgradable from: 1:4.5-1.1]
mailutils-common/testing 1:3.7-2.1 all [upgradable from: 1:3.5-3]
mailutils/testing 1:3.7-2.1 amd64 [upgradable from: 1:3.5-3]
mawk/testing 1.3.4.20200120-2 amd64 [upgradable from: 1.3.3-17+b3]
mesa-va-drivers/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
mesa-vdpau-drivers/testing 20.0.7-1 amd64 [upgradable from: 18.3.6-2+deb10u1]
nftables/testing 0.9.5-1 amd64 [upgradable from: 0.9.4-1]
openssh-client/testing 1:8.3p1-1 amd64 [upgradable from: 1:7.9p1-10+deb10u2]
openssh-server/testing 1:8.3p1-1 amd64 [upgradable from: 1:7.9p1-10+deb10u2]
openssh-sftp-server/testing 1:8.3p1-1 amd64 [upgradable from: 1:7.9p1-10+deb10u2]
passwd/testing 1:4.8.1-1 amd64 [upgradable from: 1:4.5-1.1]
perl-base/testing 5.30.3-4 amd64 [upgradable from: 5.28.1-6]
perl/testing 5.30.3-4 amd64 [upgradable from: 5.28.1-6]
plymouth-label/testing 0.9.4-3 amd64 [upgradable from: 0.9.4-1.1]
plymouth/testing 0.9.4-3 amd64 [upgradable from: 0.9.4-1.1]
policykit-1/testing 0.105-26 amd64 [upgradable from: 0.105-25]
poppler-utils/testing 0.71.0-6 amd64 [upgradable from: 0.71.0-5]
powertop/testing 2.11-1 amd64 [upgradable from: 2.8-1+b2]
printer-driver-gutenprint/testing 5.3.3-4 amd64 [upgradable from: 5.3.1-7]
printer-driver-hpcups/testing 3.20.5+dfsg0-3 amd64 [upgradable from: 3.18.12+dfsg0-2]
printer-driver-hpijs/testing 3.20.5+dfsg0-3 amd64 [upgradable from: 3.18.12+dfsg0-2]
pulseaudio-utils/testing 13.0-5 amd64 [upgradable from: 12.2-4+deb10u1]
pulseaudio/testing 13.0-5 amd64 [upgradable from: 12.2-4+deb10u1]
python-minimal/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
python2-minimal/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
python2.7-minimal/testing 2.7.18-1 amd64 [upgradable from: 2.7.16-2+deb10u1]
python2.7/testing 2.7.18-1 amd64 [upgradable from: 2.7.16-2+deb10u1]
python2/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
python3-apt/testing 2.1.3 amd64 [upgradable from: 1.8.4.1]
python3-brlapi/testing 6.0+dfsg-5+b2 amd64 [upgradable from: 5.6-10+deb10u1]
python3-cairo/testing 1.16.2-3 amd64 [upgradable from: 1.16.2-1+b1]
python3-cups/testing 1.9.73-3+b1 amd64 [upgradable from: 1.9.73-2+b1]
python3-dbus/testing 1.2.16-2 amd64 [upgradable from: 1.2.8-3]
python3-gi-cairo/testing 3.36.0-3 amd64 [upgradable from: 3.30.4-1]
python3-gi/testing 3.36.0-3 amd64 [upgradable from: 3.30.4-1]
python3-gst-1.0/testing 1.16.2-2+b1 amd64 [upgradable from: 1.14.4-1+b1]
python3-minimal/testing 3.8.2-3 amd64 [upgradable from: 3.7.3-1]
python3-pil/testing 7.0.0-4+b1 amd64 [upgradable from: 5.4.1-2+deb10u1]
python3-pycurl/testing 7.43.0.2-3+b1 amd64 [upgradable from: 7.43.0.2-0.1]
python3-renderpm/testing 3.5.34-1+b1 amd64 [upgradable from: 3.5.13-1+deb10u1]
python3-reportlab-accel/testing 3.5.34-1+b1 amd64 [upgradable from: 3.5.13-1+deb10u1]
python3-reportlab/testing 3.5.34-1 all [upgradable from: 3.5.13-1+deb10u1]
python3-smbc/testing 1.0.22-1 amd64 [upgradable from: 1.0.15.6-1+b2]
python3-uno/testing 1:6.4.4-1+b1 amd64 [upgradable from: 1:6.1.5-3+deb10u6]
python3/testing 3.8.2-3 amd64 [upgradable from: 3.7.3-1]
python/testing 2.7.17-2 amd64 [upgradable from: 2.7.16-1]
samba-libs/testing 2:4.11.5+dfsg-1+b1 amd64 [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
sane-utils/testing 1.0.27-3.2+b1 amd64 [upgradable from: 1.0.27-3.2]
synaptic/testing 0.90+nmu1 amd64 [upgradable from: 0.84.6]
systemd/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
task-british-desktop/testing 3.59 all [upgradable from: 3.53]
task-desktop/testing 3.59 all [upgradable from: 3.53]
task-english/testing 3.59 all [upgradable from: 3.53]
task-laptop/testing 3.59 all [upgradable from: 3.53]
task-ssh-server/testing 3.59 all [upgradable from: 3.53]
task-xfce-desktop/testing 3.59 all [upgradable from: 3.53]
tasksel-data/testing 3.59 all [upgradable from: 3.53]
tasksel/testing 3.59 all [upgradable from: 3.53]
thunar-data/testing 1.8.14-1 all [upgradable from: 1.8.4-1]
thunar/testing 1.8.14-1 amd64 [upgradable from: 1.8.4-1]
udev/testing 245.6-1 amd64 [upgradable from: 241-7~deb10u4]
ure/testing 1:6.4.4-1+b1 amd64 [upgradable from: 6.1.5-3+deb10u6]
util-linux-locales/testing 2.35.2-2 all [upgradable from: 2.33.1-0.1]
util-linux/testing 2.35.2-2 amd64 [upgradable from: 2.33.1-0.1]
wpasupplicant/testing 2:2.9.0-13 amd64 [upgradable from: 2:2.7+git20190128+0c1e29f-6+deb10u2]
x11-apps/testing 7.7+8 amd64 [upgradable from: 7.7+7]
xarchiver/testing 1:0.5.4.15-2 amd64 [upgradable from: 1:0.5.4.15-1]
xbrlapi/testing 6.0+dfsg-5+b2 amd64 [upgradable from: 6.0+dfsg-5+b1]
xfce4-mailwatch-plugin/testing 1.2.0-3+b1 amd64 [upgradable from: 1.2.0-3]
xfce4-panel/testing 4.14.4-1 amd64 [upgradable from: 4.12.2-1]
xfce4-settings/testing 4.14.2-1 amd64 [upgradable from: 4.12.4-1]
xfce4-weather-plugin/testing 0.10.1-1+b1 amd64 [upgradable from: 0.8.10-1]
xfce4/testing 4.14 all [upgradable from: 4.12.5]
xfwm4/testing 4.14.2-1 amd64 [upgradable from: 4.12.5-1]
xsane-common/testing 0.999-8 all [upgradable from: 0.999-6]
xsane/testing 0.999-8 amd64 [upgradable from: 0.999-6+b1]
xserver-xorg-core/testing 2:1.20.8-2 amd64 [upgradable from: 2:1.20.4-1]
xserver-xorg-video-intel/testing 2:2.99.917+git20200226-1 amd64 [upgradable from: 2:2.99.917+git20180925-2]
hugh@DELL-DEBIAN:~$




Code: Select all
hugh@DELL-DEBIAN:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  fonts-roboto-slab g++-8 geoip-database libayatana-ido3-0.4-0 libbind9-161 libboost-atomic1.67.0
  libboost-chrono1.67.0 libdns-export1104 libdns1104 libdns1110 libgeoip1 libgssdp-1.0-3 libgtkmm-2.4-1v5
  libgupnp-1.0-4 libisc-export1100 libisc1100 libisc1105 libisccc161 libisccfg163 libjim0.77 libjte1
  liblouis17 liblouisutdml8 liblwres161 libnftables0 libprocps7 libstdc++-8-dev libusbmuxd4 python3-gst-1.0
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  alsa-utils aspell atril chromium chromium-common chromium-sandbox coinor-libcbc3 coinor-libcgl1
  coinor-libclp1 coinor-libcoinutils3v5 colord cpp-8 cups-browsed cups-filters cups-filters-core-drivers
  espeak-ng-data evince evince-common exim4-base exim4-config exim4-daemon-light exo-utils firebird3.0-common
  firebird3.0-common-doc firebird3.0-server-core firebird3.0-utils firefox-esr firefox-esr-l10n-en-gb g++-8
  gcc-8 gcc-8-base gdisk ghostscript gimp gimp-data gir1.2-freedesktop gir1.2-glib-2.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-pango-1.0 gir1.2-polkit-1.0
  gir1.2-soup-2.4 glib-networking glib-networking-services gnome-desktop3-data groff-base gstreamer1.0-alsa
  gstreamer1.0-gl gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x guile-2.2-libs
  gvfs gvfs-common gvfs-daemons gvfs-libs hplip hplip-data i965-va-driver intel-media-va-driver iproute2
  iptables keepassx libalgorithm-diff-xs-perl libaom0 libappstream4 libapt-pkg-perl libasound2
  libasound2-data libasound2-plugins libaspell15 libatrildocument3 libatrilview3 libavcodec58 libavfilter7
  libavformat58 libavresample4 libavutil56 libayatana-ido3-0.4-0 libbabl-0.1-0 libblockdev-part2 libbrotli1
  libc-bin libc-dev-bin libc6 libc6-dev libcairo-perl libcdr-0.1-1 libchromaprint1 libclone-perl libcolord2
  libcupsfilters1 libdc1394-22 libde265-0 libdjvulibre21 libdrm-amdgpu1 libdrm2 libe-book-0.1-1 libegl-mesa0
  libenchant1c2a libespeak-ng1 libevdocument3-4 libevview3-3 libexif12 libexo-1-0 libexo-2-0 libfaad2
  libfbclient2 libfcgi-perl libfile-fcntllock-perl libflite1 libgail-3-0 libgail-common libgail18 libgbm1
  libgcc-8-dev libgd3 libgegl-0.4-0 libgexiv2-2 libgfortran5 libgimp2.0 libgirepository-1.0-1 libgl1-mesa-dri
  libglapi-mesa libglib-perl libglib2.0-0 libglib2.0-bin libglibmm-2.4-1v5 libglx-mesa0 libgme0 libgphoto2-6
  libgs9 libgs9-common libgstreamer-gl1.0-0 libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk2.0-0 libgtk2.0-bin libgutenprint-common libgutenprint9
  libharfbuzz-icu0 libheif1 libhpmud0 libhtml-parser-perl libhttp-message-perl libib-util libicu63 libinput10
  libio-pty-perl libiptc0 libiw30 libjavascriptcoregtk-4.0-18 liblapack3 liblcms2-2 liblilv-0-0
  liblist-moreutils-perl liblocale-gettext-perl libmagickcore-6.q16-6 libmetis5 libmp3lame0 libmpcdec6
  libmpx2 libmspub-0.1-1 libmwaw-0.3-3 libnet-dbus-perl libnet-dns-sec-perl libnet-libidn-perl
  libnet-ssleay-perl libnss-systemd libofa0 libopenjp2-7 libopenmpt0 libpam-systemd libpango-1.0-0
  libpango-perl libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libperlio-gzip-perl libpng16-16
  libpolkit-agent-1-0 libpolkit-gobject-1-0 libpoppler-glib8 libpoppler82 libpostproc55
  libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython-stdlib libpython2-stdlib libpython2.7
  libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqxp-0.0-0 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-common
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-impress libreoffice-java-common
  libreoffice-l10n-en-gb libreoffice-math libreoffice-report-builder libreoffice-report-builder-bin
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-tango
  libreoffice-writer librsvg2-2 librsvg2-common librubberband2 libsane libsane-hpaio libsdl1.2debian
  libselinux1 libsemanage-common libsemanage1 libsensors5 libserd-0-0 libsereal-decoder-perl
  libsereal-encoder-perl libsereal-perl libslang2 libsmbclient libsndfile1 libsocket6-perl libsoup2.4-1
  libsoxr0 libspeex1 libspeexdsp1 libsqlite3-0 libsratom-0-0 libstdc++-8-dev libsub-name-perl libswresample3
  libswscale5 libsystemd0 libtag1v5 libtag1v5-vanilla libtcl8.6 libtext-charwidth-perl libtext-iconv-perl
  libtiff5 libtk8.6 libtwolame0 libudev1 libumfpack5 libunicode-utf8-perl libvisio-0.1-1 libvisual-0.4-0
  libvte-2.91-0 libvte-2.91-common libvulkan1 libwbclient0 libwebkit2gtk-4.0-37 libwps-0.4-4 libxapian30
  libxatracker2 libxml-libxml-perl libxml-parser-perl libxml2 libxslt1.1 libxtables12 libxvidcore4
  libyaml-libyaml-perl libzmf-0.0-0 libzvbi-common libzvbi0 lintian locales login mailutils mailutils-common
  mawk mesa-va-drivers mesa-vdpau-drivers openssh-client openssh-server openssh-sftp-server passwd perl
  perl-base plymouth plymouth-label policykit-1 poppler-utils powertop printer-driver-gutenprint
  printer-driver-hpcups printer-driver-hpijs pulseaudio pulseaudio-utils python python-minimal python2
  python2-minimal python2.7 python2.7-minimal python3 python3-apt python3-brlapi python3-cairo python3-cups
  python3-dbus python3-gi python3-gi-cairo python3-gst-1.0 python3-minimal python3-pil python3-pycurl
  python3-renderpm python3-reportlab python3-reportlab-accel python3-smbc python3-uno samba-libs sane-utils
  synaptic systemd task-british-desktop task-desktop task-english task-laptop task-ssh-server
  task-xfce-desktop tasksel tasksel-data thunar thunar-data udev ure util-linux util-linux-locales
  wpasupplicant x11-apps xbrlapi xfce4 xfce4-mailwatch-plugin xfce4-panel xfce4-settings xfce4-weather-plugin
  xfwm4 xsane xsane-common xserver-xorg-core xserver-xorg-video-intel
The following packages will be upgraded:
  apparmor grub-efi-amd64-signed libapparmor1 libasm-java libgnutls-dane0 libgnutls30 libgpg-error-l10n
  libgpg-error0 libmaven-resolver-java libnftables1 libnftnl11 nftables xarchiver
13 upgraded, 0 newly installed, 0 to remove and 364 not upgraded.
Need to get 4,690 kB of archives.
After this operation, 65.5 kB of additional disk space will be used.
Do you want to continue? [Y/n] n



Code: Select all
hugh@DELL-DEBIAN:~$ sudo apt-get --with-new-pkgs upgrade
[sudo] password for hugh:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  fonts-roboto-slab g++-8 geoip-database libayatana-ido3-0.4-0 libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libdns-export1104 libdns1104
  libdns1110 libgeoip1 libgssdp-1.0-3 libgtkmm-2.4-1v5 libgupnp-1.0-4
  libisc-export1100 libisc1100 libisc1105 libisccc161 libisccfg163 libjim0.77
  libjte1 liblouis17 liblouisutdml8 liblwres161 libnftables0 libprocps7
  libstdc++-8-dev libusbmuxd4 python3-gst-1.0
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  alsa-utils aspell atril chromium chromium-common chromium-sandbox
  coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinutils3v5 colord
  cpp-8 cups-browsed cups-filters cups-filters-core-drivers espeak-ng-data
  evince evince-common exim4-base exim4-config exim4-daemon-light exo-utils
  firebird3.0-common firebird3.0-common-doc firebird3.0-server-core
  firebird3.0-utils firefox-esr firefox-esr-l10n-en-gb g++-8 gcc-8 gcc-8-base
  gdisk ghostscript gimp gimp-data gir1.2-freedesktop gir1.2-glib-2.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0
  gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-soup-2.4 glib-networking
  glib-networking-services gnome-desktop3-data groff-base gstreamer1.0-alsa
  gstreamer1.0-gl gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
  guile-2.2-libs gvfs gvfs-common gvfs-daemons gvfs-libs hplip hplip-data
  i965-va-driver intel-media-va-driver iproute2 iptables keepassx
  libalgorithm-diff-xs-perl libaom0 libappstream4 libapt-pkg-perl libasound2
  libasound2-data libasound2-plugins libaspell15 libatrildocument3
  libatrilview3 libavcodec58 libavfilter7 libavformat58 libavresample4
  libavutil56 libayatana-ido3-0.4-0 libbabl-0.1-0 libblockdev-part2 libbrotli1
  libc-bin libc-dev-bin libc6 libc6-dev libcairo-perl libcdr-0.1-1
  libchromaprint1 libclone-perl libcolord2 libcupsfilters1 libdc1394-22
  libde265-0 libdjvulibre21 libdrm-amdgpu1 libdrm2 libe-book-0.1-1
  libegl-mesa0 libenchant1c2a libespeak-ng1 libevdocument3-4 libevview3-3
  libexif12 libexo-1-0 libexo-2-0 libfaad2 libfbclient2 libfcgi-perl
  libfile-fcntllock-perl libflite1 libgail-3-0 libgail-common libgail18
  libgbm1 libgcc-8-dev libgd3 libgegl-0.4-0 libgexiv2-2 libgfortran5
  libgimp2.0 libgirepository-1.0-1 libgl1-mesa-dri libglapi-mesa libglib-perl
  libglib2.0-0 libglib2.0-bin libglibmm-2.4-1v5 libglx-mesa0 libgme0
  libgphoto2-6 libgs9 libgs9-common libgstreamer-gl1.0-0
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk2.0-0 libgtk2.0-bin
  libgutenprint-common libgutenprint9 libharfbuzz-icu0 libheif1 libhpmud0
  libhtml-parser-perl libhttp-message-perl libib-util libicu63 libinput10
  libio-pty-perl libiptc0 libiw30 libjavascriptcoregtk-4.0-18 liblapack3
  liblcms2-2 liblilv-0-0 liblist-moreutils-perl liblocale-gettext-perl
  libmagickcore-6.q16-6 libmetis5 libmp3lame0 libmpcdec6 libmpx2
  libmspub-0.1-1 libmwaw-0.3-3 libnet-dbus-perl libnet-dns-sec-perl
  libnet-libidn-perl libnet-ssleay-perl libnss-systemd libofa0 libopenjp2-7
  libopenmpt0 libpam-systemd libpango-1.0-0 libpango-perl libpangocairo-1.0-0
  libpangoft2-1.0-0 libpangoxft-1.0-0 libperlio-gzip-perl libpng16-16
  libpolkit-agent-1-0 libpolkit-gobject-1-0 libpoppler-glib8 libpoppler82
  libpostproc55 libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython-stdlib
  libpython2-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib
  libpython3-stdlib libqxp-0.0-0 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-help-common
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-l10n-en-gb libreoffice-math
  libreoffice-report-builder libreoffice-report-builder-bin
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb
  libreoffice-sdbc-postgresql libreoffice-style-tango libreoffice-writer
  librsvg2-2 librsvg2-common librubberband2 libsane libsane-hpaio
  libsdl1.2debian libselinux1 libsemanage-common libsemanage1 libsensors5
  libserd-0-0 libsereal-decoder-perl libsereal-encoder-perl libsereal-perl
  libslang2 libsmbclient libsndfile1 libsocket6-perl libsoup2.4-1 libsoxr0
  libspeex1 libspeexdsp1 libsqlite3-0 libsratom-0-0 libstdc++-8-dev
  libsub-name-perl libswresample3 libswscale5 libsystemd0 libtag1v5
  libtag1v5-vanilla libtcl8.6 libtext-charwidth-perl libtext-iconv-perl
  libtiff5 libtk8.6 libtwolame0 libudev1 libumfpack5 libunicode-utf8-perl
  libvisio-0.1-1 libvisual-0.4-0 libvte-2.91-0 libvte-2.91-common libvulkan1
  libwbclient0 libwebkit2gtk-4.0-37 libwps-0.4-4 libxapian30 libxatracker2
  libxml-libxml-perl libxml-parser-perl libxml2 libxslt1.1 libxtables12
  libxvidcore4 libyaml-libyaml-perl libzmf-0.0-0 libzvbi-common libzvbi0
  lintian locales login mailutils mailutils-common mawk mesa-va-drivers
  mesa-vdpau-drivers openssh-client openssh-server openssh-sftp-server passwd
  perl perl-base plymouth plymouth-label policykit-1 poppler-utils powertop
  printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs
  pulseaudio pulseaudio-utils python python-minimal python2 python2-minimal
  python2.7 python2.7-minimal python3 python3-apt python3-brlapi python3-cairo
  python3-cups python3-dbus python3-gi python3-gi-cairo python3-gst-1.0
  python3-minimal python3-pil python3-pycurl python3-renderpm
  python3-reportlab python3-reportlab-accel python3-smbc python3-uno
  samba-libs sane-utils synaptic systemd task-british-desktop task-desktop
  task-english task-laptop task-ssh-server task-xfce-desktop tasksel
  tasksel-data thunar thunar-data udev ure util-linux util-linux-locales
  wpasupplicant x11-apps xbrlapi xfce4 xfce4-mailwatch-plugin xfce4-panel
  xfce4-settings xfce4-weather-plugin xfwm4 xsane xsane-common
  xserver-xorg-core xserver-xorg-video-intel
The following packages will be upgraded:
  apparmor grub-efi-amd64-signed libapparmor1 libasm-java libgnutls-dane0
  libgnutls30 libgpg-error-l10n libgpg-error0 libmaven-resolver-java
  libnftables1 libnftnl11 nftables xarchiver
13 upgraded, 0 newly installed, 0 to remove and 364 not upgraded.
Need to get 4,690 kB of archives.
After this operation, 65.5 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
hughparker1
 
Posts: 177
Joined: 2014-10-09 21:53
Location: Paisley, United Kingdom

Re: update show 377 packages upgrade, upgrade = 364 not upgr

Postby arid » 2020-06-15 01:42

Holy quacamole!

How is it your puny "old" version is trying to update to my "new" sid?

I see you have synaptic installed, so what does it have to say about all this?
There's no drama in my sid......
arid
 
Posts: 85
Joined: 2014-05-08 18:40
Location: Aridzona

Re: update show 377 packages upgrade, upgrade = 364 not upgr

Postby stevepusser » 2020-06-15 03:25

Synaptic curls up in a corner weeping over jobs that aptitude handles easily. Just sayin'...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.7, Strawberry 0.6.12, Pale Moon 28.10.0, Xscreensaver 5.44, Krita 4.3.0, Foliate 2.4.0
User avatar
stevepusser
 
Posts: 11792
Joined: 2009-10-06 05:53

Re: update show 377 packages upgrade, upgrade = 364 not upgr

Postby Head_on_a_Stick » 2020-06-15 14:52

hughparker1 wrote:is 'sudo apt-get dist-upgrade' advisable?

It's not just advisable, it's entirely necessary for testing/unstable (but it can break things). The fact that you even have to ask that question strongly suggests that you shouldn't be running a development branch.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12159
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable