Debian 10 unable to start, Oh No ! message

New to Debian (Or Linux in general)? Ask your questions here!

Debian 10 unable to start, Oh No ! message

Postby jubarbie » 2020-07-03 12:15

Hi everybody,

First time I'm writing to this forum so please excuse me if I'm doing something wrong the way I'm asking for help.
I already checked and tried a lot to solve the issue but I need help from more expert people.

When I start my computer I select Debian on Grub I get a grey screen saying "Oh no! Something has gone wrong".
I tried many things but couldn't make it work.
My computer starts well in recovery mode.

This happened after I tried installing AMD GPU drivers because my video editor (Natron) was very slow so I think it could be related with it. But I don't know how to know, I'm not an expert with Linux.
I have an AMD Radeon RX 580.
I tried uninstalling the drivers and install them back (following this https://linuxconfig.org/how-to-install-the-latest-amd-drivers-on-debian-10-buster) but with no results.

I'm a bit hopeless and about to reinstall everything, but I wanted to ask first to the community if anyone could help me and also better understand Linux.

I'm on Debian 10 (buster)
I boot via Grub even though I haven't any other system installed yet.

I don't see any error logs on /var/log/boot.logs

Code: Select all
journalctl -p err

-- Logs begin at Fri 2020-07-03 12:55:46 CEST, end at Fri 2020-07-03 12:56:17 CEST. --
juil. 03 12:55:46 BlackSapphire kernel: iTCO_wdt iTCO_wdt: can't request region for resource [mem 0x00c5fffc-0x00c5ffff]
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire bluetoothd[679]: Sap driver initialization failed.
juil. 03 12:55:47 BlackSapphire bluetoothd[679]: sap-server: Operation not permitted (1)
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:47 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:48 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:48 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:48 BlackSapphire kernel: kvm: disabled by bios
juil. 03 12:55:48 BlackSapphire kernel: kvm: disabled by bios


Code: Select all
lspci

0:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake PCH SATA AHCI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #17 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #1 (rev f0)
00:1c.7 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #8 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Z390 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
04:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
jubarbie
 
Posts: 4
Joined: 2020-07-03 10:12

Re: Debian 10 unable to start, Oh No ! message

Postby jubarbie » 2020-07-06 20:03

No one ?
Maybe I haven't shared enough informations?
Tell me what you need. As I said I'm new to Debian and willing to learn but I'm stuck.
jubarbie
 
Posts: 4
Joined: 2020-07-03 10:12

Re: Debian 10 unable to start, Oh No ! message

Postby eriefisher » 2020-07-06 21:20

____________________________________________
There's a manual?
Siduction
Debian Sid
Xfce4 4.14
User avatar
eriefisher
 
Posts: 129
Joined: 2008-06-04 03:49
Location: Ontario's South Coast

Re: Debian 10 unable to start, Oh No ! message

Postby stevepusser » 2020-07-07 02:31

It's been answered here many many many times here before, but the AMD drivers are already shipped with Debian. What's not included by default is the non-free firmware. You should have gone to the Debian wiki first instead of some random blog that calls firmware "drivers" (how many times have I typed that before, too?)

https://wiki.debian.org/AtiHowTo

You said you had a GUI before but it performed poorly. I'm really not sure what the blog had you do to break your GNOME GUI, but maybe you can log into the command line and install xfce to at least get a less demanding GUI, if you work better from that instead of the terminal, then you can fix GNOME from xfce.

Code: Select all
sudo apt install xfce4

I'm not really sure how old your AMD 580 is, but the rest of your hardware is circa 2018, and should be supported by the standard Buster free and non-free packages. Debian currently lacks firmware for hardware less than a year old. :(

After it's fixed one way or another, you should start backing up your system regularly. Timeshift is an easy way to make system restore points.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Debian 10 unable to start, Oh No ! message

Postby jubarbie » 2020-07-08 07:37

Thanks stevepusser for your answer.

I followed the installation at this page
https://wiki.debian.org/AtiHowTo

But it still doesn't work

This is what I get with the command:

Code: Select all
dmesg | grep -E 'drm|radeon' | grep -iE 'firmware|microcode'

[    1.653425] [drm] Found UVD firmware Version: 1.130 Family ID: 16
[    1.654005] [drm] Found VCE firmware Version: 53.26 Binary ID: 3


And I still get the same screen on boot (Oh no! ...) :(
jubarbie
 
Posts: 4
Joined: 2020-07-03 10:12

Re: Debian 10 unable to start, Oh No ! message

Postby jubarbie » 2020-07-08 17:14

I also installed xfce and it still doesn't work. I'm going to reinstall everything from scratch since I need my computer to work. Thanks anyway.
jubarbie
 
Posts: 4
Joined: 2020-07-03 10:12

Re: Debian 10 unable to start, Oh No ! message

Postby Head_on_a_Stick » 2020-07-08 18:59

jubarbie wrote:This happened after I tried installing AMD GPU drivers

Yeah, the AMDGPU-PRO drivers don't work with Debian. And anyway AMD do not recommend them for your card.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian 10 unable to start, Oh No ! message

Postby stevepusser » 2020-07-09 04:53

Head_on_a_Stick wrote:
jubarbie wrote:This happened after I tried installing AMD GPU drivers

Yeah, the AMDGPU-PRO drivers don't work with Debian. And anyway AMD do not recommend them for your card.


The link for the blog post in the OP basically just duplicates the Debian wiki...nothing about the PRO drivers there. Basically, you just need to install Debian, enable the non-free section of the repos, and install firmware-amd-graphics, assuming your GPU is not too recent.

Perhaps after the reinstall, you can install inxi and report the output of "inxi -G" so we can get a look at what's up with the hardware and driver situation before messing with it again.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable