Installing Keepassxc with snap package

New to Debian (Or Linux in general)? Ask your questions here!

Installing Keepassxc with snap package

Postby Budgie » 2020-07-10 12:16

I couldn't find keepassxc using synaptic package manager. I was only offered keepassx so I am trying to install the keepassxc snap package.
This is my first attempt at installing and using snap so I may have made a mistake but all appeared to be OK until the last message:-

Code: Select all
alastair@x3400debian:~$ sudo snap install keepassxc
error: cannot perform the following tasks:
- Mount snap "keepassxc" (978) (cannot find required base "core18")
alastair@x3400debian:~$



Seems I have something missing. Please could somebody help, either to get snap package to work or give me the repo I must go to for an installation using synaptic.
Many thanks,
Budgie
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50

Re: Installing Keepassxc with snap package

Postby arochester » 2020-07-10 13:23

It does appear in Synaptic

Try the search function at the top left.
arochester
 
Posts: 1701
Joined: 2010-12-07 19:55

Re: Installing Keepassxc with snap package

Postby Budgie » 2020-07-10 13:33

arochester wrote:It does appear in Synaptic

Try the search function at the top left.


I searched for keepassxc but am only offered keepassx 2.0.3-1
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50

Re: Installing Keepassxc with snap package

Postby arochester » 2020-07-10 13:41

I see 2.3.4+dfsg1-1

Have you recently done, AS ROOT
Code: Select all
apt update && apt full upgrade
?
arochester
 
Posts: 1701
Joined: 2010-12-07 19:55

Re: Installing Keepassxc with snap package

Postby stevepusser » 2020-07-11 02:12

That of course begs the question of which Debian release you're using, and your sources.list if you should be able to see it:

https://packages.debian.org/search?keyw ... ection=all

I'm going to try and build the final 2.6.0 release tonight for MX Linux repos. :D
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Installing Keepassxc with snap package

Postby Budgie » 2020-07-11 07:47

arochester wrote:I see 2.3.4+dfsg1-1

Have you recently done, AS ROOT
Code: Select all
apt update && apt full upgrade
?


That is a good point. I am currently running Debian 9 and have only used:
Code: Select all
sudo apt update

and
Code: Select all
sudo apt upgrade

Just tried your full command and this is what I received:-
Code: Select all
[sudo] password for alastair:
Ign:1 http://ftp.uk.debian.org/debian stretch InRelease
Hit:2 http://ftp.uk.debian.org/debian stretch-updates InRelease
Hit:3 http://security.debian.org/debian-security stretch/updates InRelease
Hit:4 http://ftp.uk.debian.org/debian stretch Release
Reading package lists... Done                     
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
E: Invalid operation full

No idea why I get the invalid operation. Will need to read more!
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50


Re: Installing Keepassxc with snap package

Postby Budgie » 2020-07-11 08:42

OK, on further reading I have found the command given was slightly in error but I think my problem is that I now need to change to Debian 10 as it appears the package I was looking for is not in Debian 9. I am therefore upgrading to Buster. Will report results in due course. Meanwhile many thanks for the replies.
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50

Re: Installing Keepassxc with snap package

Postby Budgie » 2020-07-11 11:40

OK so now I have Debian 10 installed and KeePassXC from repo so all is good.
The upgrade was fun too!
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50

Re: Installing Keepassxc with snap package

Postby stevepusser » 2020-07-12 06:16



It's already been backported, that's why it's already in stretch-backports. Backporting does not mean to install a package that has already been built!

OP, I see that you ignored the link in my post that showed that it was not available in the main Stretch repos. That's not a good habit to get. BTW, I also have newer versions than stretch-backports in my own repo, too, so I know what I'm talking about: https://build.opensuse.org/package/show ... /keepassxc

I was successful in backporting 2.6.0 for the Stretch-based MX 17/18 repository, so I'll try to get that into this OBS repo tomorrow.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Installing Keepassxc with snap package

Postby Budgie » 2020-07-12 12:35

Hi and many thanks for the help. I had no intention of snubbing your advice on backports, it is just that I intended to upgrade anyhow and the absence of the application from the main repo site was just a further incentive.
I see you work on MX. I still use Antix on my old laptop so may need some help there is due course.
Thanks again for your help.
Regards,
Budgie
Budgie
 
Posts: 24
Joined: 2007-06-17 14:50

Re: Installing Keepassxc with snap package

Postby stevepusser » 2020-07-13 03:07

Anyway, KeepassXC 2.6.0 is now available in my OBS repos and the MX test repos.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 16 guests

fashionable