KDE network blank [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

KDE network blank [SOLVED]

Postby Rob-H » 2021-01-16 18:11

Hi All
On a fresh install of testing the networks screen is blank. Does anyone know of a fix or are able to help troubleshot this issue?
Last edited by Rob-H on 2021-01-17 00:35, edited 1 time in total.
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Head_on_a_Stick » 2021-01-16 18:47

Please read the Frequently Asked Questions thread in the HowTo section.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: KDE network blank

Postby Rob-H » 2021-01-16 19:24

Thanks. I have read through that, but haven't found something to help fix my problem, but I'll keep looking
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Head_on_a_Stick » 2021-01-16 19:27

Rob-H wrote:haven't found something to help fix my problem

What about the [FAQ] specifically devoted to wireless cards?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: KDE network blank

Postby Rob-H » 2021-01-16 19:31

I'm on a ethernet connection, so I haven't looked at wireless solutions. I would like to have the gui to tweak settings.
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Head_on_a_Stick » 2021-01-16 19:34

Rob-H wrote:I'm on a ethernet connection

That's a bit vague. Have you tried entering the NIC type followed by "Debian" into a search engine?

EDIT: check for your active interfaces with
Code: Select all
ip link
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: KDE network blank

Postby Rob-H » 2021-01-16 19:53

I'm sorry. I wasn't very clear. I have full connection and the network card just fine. It's only the network screen that is blank. I would like to to the gui to tweak the connection setting
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Head_on_a_Stick » 2021-01-16 19:58

If the "network screen" is for NetworkManager then that will ignore any interfaces that are configured in /etc/network/interfaces so check that file and comment out any lines that refer to you ethernet interface (use 'ip link' to check the name).
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: KDE network blank

Postby stevepusser » 2021-01-16 20:50

Are you talking about the Network Connections thingy in System Settings, like this one here for me in Buster's?

Image
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12233
Joined: 2009-10-06 05:53

Re: KDE network blank

Postby Rob-H » 2021-01-16 21:20

Thankyou! That solved the problem.
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Rob-H » 2021-01-16 21:21

stevepusser wrote:Are you talking about the Network Connections thingy in System Settings, like this one here for me in Buster's?

Image

Thats what it was
Rob-H
 
Posts: 7
Joined: 2020-10-18 16:49

Re: KDE network blank

Postby Head_on_a_Stick » 2021-01-16 22:49

Rob-H wrote:That solved the problem

Fantastic, please edit the title of the thread and prepend [SOLVED] to help others who encounter this problem.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable