sound works for root account but not for user account

New to Debian (Or Linux in general)? Ask your questions here!

Re: sound works for root account but not for user account

Postby sixpiece45000 » 2021-01-19 06:50

You have a module conflict, here: es1371 (kernel-oss) and snd_ens1371(alsa)
try to use the same hardware.
Make sure to not load es1371 but use the alsa module instead, especially since
alsa is default for linux-2.6.x.

However, this has absolutely nothing to do with KDE.

HS

Hendrik Says all this but I don't know how to do what he is saying...
sixpiece45000
 
Posts: 15
Joined: 2021-01-17 18:40

Re: sound works for root account but not for user account

Postby sixpiece45000 » 2021-01-19 15:47

Code: Select all
sixpiece@Kagan:/etc/pulse$ pactl list short sinks
0   alsa_output.default   module-alsa-sink.c   s16le 2ch 48000Hz   IDLE
1   null   module-null-sink.c   s16le 2ch 44100Hz   SUSPENDED
2   fifo_output   module-pipe-sink.c   s16le 2ch 44100Hz   SUSPENDED
3   rtp   module-null-sink.c   s16be 2ch 44100Hz   SUSPENDED


still not sucessful but found out that pulse audio does not work like it won't start , it's not found. tried to edit the client.conf /etc/pulse files as well as the others default.pa and the other . going to leave it for now..
sixpiece45000
 
Posts: 15
Joined: 2021-01-17 18:40

Re: sound works for root account but not for user account

Postby Head_on_a_Stick » 2021-01-19 15:55

This is nothing to do with conflicting kernel modules because if that was the case then sound wouldn't work for root either.

Please post the output of this command as your normal user:
Code: Select all
amixer

Be sure to use code tags for the output (as you have for your last post).
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13262
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: sound works for root account but not for user account

Postby sixpiece45000 » 2021-01-19 23:13

Code: Select all
sixpiece@Kagan:/$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
sixpiece@Kagan:/$

sixpiece45000
 
Posts: 15
Joined: 2021-01-17 18:40

Re: sound works for root account but not for user account

Postby sixpiece45000 » 2021-01-19 23:14

it's working I don't know why ... thank you.
sixpiece45000
 
Posts: 15
Joined: 2021-01-17 18:40

Previous

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable