wifi disconnects after minutes

New to Debian (Or Linux in general)? Ask your questions here!

wifi disconnects after minutes

Postby sexypenguin » 2021-02-19 08:51

Buster
Code: Select all
lspci: Network controller: Intel Corporation Wireless 3165

Code: Select all
ip addr: wlp1s0

I think wlp1s0 is the proper driver, and I tried updating it, but the problem persists..
Wifi connects and works just fine, but after a few minutes cannot connect to any website yet it says it is still connected to the wifi..
( ͠° ͟ʖ ͡°)=ε/̵͇̿̿/'̿̿ ̿ ̿̿ ̿ ̿ Soros's life doesn't matter. ╾━╤デ╦︻( ͡° ͜ʖ ͡°)
sexypenguin
 
Posts: 2
Joined: 2021-02-19 08:19

Re: wifi disconnects after minutes

Postby arochester » 2021-02-19 09:45

I think wlp1s0 is the proper driver, and I tried updating it, but the problem persists..


wlp1s0 refers to your wireless LAN. It used to be wlan0 but is now more changeable.

In Linux the drivers are built into in the Kernel. What you add is the firmware. The firmware for your wifi is firmware-iwlwifi

How much RAM have you got?

What wifi interface are you using? https://wiki.debian.org/WiFi/HowToUse
arochester
 
Posts: 1871
Joined: 2010-12-07 19:55

Re: wifi disconnects after minutes

Postby sexypenguin » 2021-02-20 05:57

Thanks for the correction. As from the guide you sent me...
I did
Code: Select all
ip link show
got the same wlp1s0, im sure this is the interface.
As for RAM, it says im using around 700mb out of 8gb.
After testing a failed ping command, I also ran a wireshark capture on previous mentioned interface and observed mainly ARP broadcasts from my device to the router 192.168.1.127.
This same situation happens on multiple different wifis, while my phone will have no problems...

I want to note again, this happens after a few minutes of good connection, then suddenly it stops, all pings fail, but kde plasma wifi gui still interface is connected to the wifi (and wireshark shows ARP broadcasts).
( ͠° ͟ʖ ͡°)=ε/̵͇̿̿/'̿̿ ̿ ̿̿ ̿ ̿ Soros's life doesn't matter. ╾━╤デ╦︻( ͡° ͜ʖ ͡°)
sexypenguin
 
Posts: 2
Joined: 2021-02-19 08:19

Re: wifi disconnects after minutes

Postby Head_on_a_Stick » 2021-02-20 08:15

There is a thread in the HowTo section devoted to tweaking the iwlwifi driver to overcome problems like this, I suggest that you find it and read it.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13280
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable