Refused the Connection

New to Debian (Or Linux in general)? Ask your questions here!

Refused the Connection

Postby triscele » 2009-12-08 16:04

I'm making baby steps. I used this site http://www.aboutdebian.com/lan.htm and the help of this forum to get multiple host files set up.

I stopped before the includes section because I wanted to make sure it worked before proceeding further.

I can’t connect at all on the Server
I can’t use localhost or 127.0.0.1

I can connect to my dynDNS alias and 10.0.1.66(the local address) to the It Works default html page.

I'm using an Airport Extremeand set up portForwarding on the Extreme and set all public and private ports to 80

On the Mac, I edited the hosts.sbs file with TextEdit and added the internal address three times with the three domains www.”myDomain1”.com, www.”myDomain2”.com, www.”myDomain3”.com

Keep getting Safari Can’t connect to the Server when I hit the domains and refused the connection to LocalHost and 127.0.0.1.

I assume the server is up and running or I wouldn't get the default html page. Sorry, I am so confused. It appears that the Linux Bible I bought was written for Ubuntu so the syntax and installed files are wrong.
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Postby llivv » 2009-12-08 20:44

'
Last edited by llivv on 2019-02-17 22:56, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: Refused the Connection

Postby triscele » 2009-12-08 22:39

First of all thanks so much for the reply

To clarify - I started at the part that said Setting up an Apache WebServer - Did all the thing under Multiple Web Sites and ended before doing anything in SSI - I have the Linux Bible 2009 Edition from Christopher Negus. Debian is Lenny 5.03 now. I have multiple other machines, Macs and PCs on the network. I am also on Uverse behind a 2Wire router using my Apple Extreme for all of the DHCP tasks and Port Forwarding.

Not sure what you mean by "HosName" on the network. It does not show in the Shared machines which usually indicate the other machines my network sees if that is what you mean.

The Debian machine was wired to the Extreme. I moved it and wired direct to the Uverse 2Wire router and opened up the web ports for it there and there was no change so I am guessing somehow that my Apache install has issues. Not sure what you were suggesting with the port forwarding/mapping.

If I could, I'd blow the whole thing away and start from scratch if that would make it any easier.

Any suggestions greatly appreciated.

Kevin
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Postby llivv » 2009-12-08 23:32

'
Last edited by llivv on 2019-02-17 22:56, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: Refused the Connection

Postby triscele » 2009-12-09 13:45

I thought I should clarify where I am. I do see the ipAddress in the list of addresses set up by the Extreme. I have it hard coded to that address for port forwarding. Other than that, I don't see it. I believe the hostName is set to debian. It's what echoes back if I enter the hostName command. I am able to see the page from my Mac with the hard coded ipAddress and also from the alias that I have from DynDNS. (which points to my external IP) but I can't hit any of the virtual host addresses and I can't use http://localhost/ or http://127.0.0.1 which to me makes no sense.

Any ideas? Any places you'd suggest looking?
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Postby llivv » 2009-12-09 16:05

'
Last edited by llivv on 2019-02-17 22:57, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Postby llivv » 2009-12-09 16:13

'
Last edited by llivv on 2019-02-17 22:57, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: Refused the Connection

Postby triscele » 2009-12-10 17:49

What a fun week. In the meantime, we had a blizzard here and my internet has been down for two days. Since the last post I am one step forward and two steps back.

Since you have been kind enough to try to help thus far, I will try to answer your questions. To save some space I will answer them in order.
1 and 2) On the Airport Extreme, I set a DHCP reservation for a 10.0.1.66 address on the local Debian machine so that it always gets the same address and then set the reservation to the MAC address of that machine. I then used that address to set all of the port forwarding for that address.
3) While I was able to hit the address from other machines on my network with http://10.0.1.66 and the aliased address at DynDNS, I no longer can connect to the It Works! page from anywhere. I have never been able to hit it from 127.0.01 or localhost. I tried to hit the local address on the Debian machine from the Epiphany Browser

Further update: My mac sees the Debian machine in the shared area but says I have the wrong name and password when I attempt to log into it. Not sure how that can be since I can log into it on that machine.

At this point, I would love to pull the plug and start clean and wipe the HD and start from scratch ...or start drinking... a lot.

Any ideas or suggestions? Shouldn't I be able to hit the localhost address from the machine without this much effort? I get that without that I cna't get to step 2 but previously I was able to get to step 2 without step 1 working if you read the previous threads.
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Postby llivv » 2009-12-10 22:07

'
Last edited by llivv on 2019-02-17 22:57, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: Refused the Connection

Postby triscele » 2009-12-10 22:25

I'll give the setting it outside the range option a go and report back in case it might help someone else. Thanks again for all of your attempts as helping. I do appreciate it.
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Postby llivv » 2009-12-11 14:19

'
Last edited by llivv on 2019-02-17 22:58, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: Refused the Connection

Postby triscele » 2009-12-12 02:26

You said
can I recommend resetting the airport to it's defaults it's safer and much more secure.

How can I have a web server if it can't be accessed from the web? Or are you suggesting a retreat until I get the server to let me in?

then
I'd also recommend that you scrap the apache config for it's default settings as well.

I set up the Extreme so that the port is outside the normal DHCP range. I can now ping the address from Windows and Mac machines. Still not getting to the default http page. Plan at the moment is to call it quits on the individual LAMP pieces and install Xampp instead. I figure getting it up and running is the first job to tackle and then I can go back and address any security issues when it is accessible.
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Re: Refused the Connection

Postby triscele » 2009-12-12 21:28

Update on the joys of Debian. I trashed the initial setup and put on Xampp and had it all running in 5 minutes. I have secured it and am now getting to the next step for the first time. One still vexing issue and I haven't bumped into it anywere yet is...

FileManager lets me get to files but I can not enter a root password to do anything and so far the only way I have been able to do anything is to run Nautilus from a terminal window (it throws an error message but seems to get the job done anyway.)

Thanks for all of the attempts at guding the blind. I am sure I will have future questions...
triscele
 
Posts: 10
Joined: 2009-12-07 13:58

Re: Refused the Connection

Postby bluesdog » 2009-12-13 08:05

triscele wrote:FileManager lets me get to files but I can not enter a root password to do anything and so far the only way I have been able to do anything is to run Nautilus from a terminal window (it throws an error message but seems to get the job done anyway.)


Default security settings in Debian assume a new user can cause a great deal of damage by doing stuff to the file system as root user.

A user owns everything in their 'home' folder, but requires special privileges elsewhere.

The preferred method is to temporarily become root, to gain access, and root is discouraged from gui applications because of the ease with which mistakes can happen in gui mode -- it's easier to mis-click than it is to mis-type!

You may, however, wish to use sudo in order to temporarily acquire root privileges, even in a gui application.

Unlike Ubuntu, which uses 'sudo' by default, Debian doesn't even install sudo during a typical install. To install sudo:

Code: Select all
aptitude update
aptitude install sudo


Then, as root, you may edit the sudoers file, as follows:

Code: Select all
visudo


nano, (not vi), will open /etc/sudoers.tmp, which you may edit and save as sudoers (<ctrl><o> and backspace to remove the '.tmp')

You'll add a line for your regular user, for example 'bob' -- so the file will look something like this:

Code: Select all
# /etc/sudoers                   
#                                 
# This file MUST be edited with the 'visudo' command as root.
#                                                           
# See the man page for details on how to write a sudoers file.
#                                                             

Defaults        env_reset

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root    ALL=(ALL) ALL

# Uncomment to allow members of group sudo to not need a password
# (Note that later entries override this, so you might need to move
# it further down)
# %sudo ALL=NOPASSWD: ALL
bob ALL=(ALL) ALL


For most graphical applications you want to run with root privileges, preface the name of the app with gksudo, (gnome) or kdesudo, (kde), installation of which will probably be necessary via aptitude.
When prompted, enter your user password, not the root password.

Be extremely careful, and realize you may break things...
Tips & Tricks

Something more to read while waiting

If you obviously have not read THIS, don't expect too much...




*winter bluesdog....*
User avatar
bluesdog
 
Posts: 2082
Joined: 2006-02-01 09:02
Location: Similkameen, British Columbia, Canada


Return to Beginners Questions

Who is online

Users browsing this forum: sunrat and 11 guests

fashionable