Wireless problem

New to Debian (Or Linux in general)? Ask your questions here!

Wireless problem

Postby aduplat » 2009-12-12 19:50

My laptop is a Dell Inspiron 4000 and just have wireless not a cable connection.
I already know that my Ethernet controller is: Realtek RTL8180L 802.11b MA. I also know that it is supported.

The problem is this: when I see "Connection Properties" I can't see any Network Connections.

How can I configured my wireless?

thanks,
aduplat
 
Posts: 29
Joined: 2009-12-09 16:47
Location: Iowa City, IA, USA

Re: Wireless problem

Postby Polaris96 » 2009-12-13 01:36

The first thing you should do is go here:

http://wiki.debian.org/rtl818x

Try to follow the directions and you should be just fine. Let us know the outcome. If it doesn't work, try to give as much info (error messages, etc) as you can.

Welcome aboard and Best of Luck :)

EDIT: you will need a an ethernet (hard wired) connection to follow the directions. Take your PC to an internet cafe if you must.
for as long as the world remains. for as long as time remains. so, too, will I remain. To serve. To help. And to make my contribution. Also, never forget our family at debianuserforums.org If we can't solve your problem, they probably can.
Polaris96
 
Posts: 555
Joined: 2009-06-17 18:37

Re: Wireless problem

Postby aduplat » 2009-12-13 06:13

Thanks:

I follow all the instructions... but I couldn't make it.

I have a question. When I have to specified the IP Addres, Netmask and Gateway... what is the correct choice?

This is my local network:

MAC Address: 00:1D:7E:D3:74:61
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0
DHCP Server: Enable
Start IP Address: 192.168.1.100
End IP Address: 192.168.1.149

This is my router:

IP Address: 173.30.24.249
Subnet Mask: 255.255.248.0
Default Gateway: 173.30.24.1
DNS 1: 74.84.119.150
DNS 2: 97.64.180.153

This is the result of> ifconfig

ebian:~# modprobe rtl8180
debian:~# ifconfig wlan0 up
debian:~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:56 errors:0 dropped:0 overruns:0 frame:0
TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4814 (4.7 KiB) TX bytes:4814 (4.7 KiB)

wlan0 Link encap:Ethernet HWaddr 00:0f:66:06:43:ac
inet addr:173.30.24.249 Bcast:173.30.31.255 Mask:255.255.248.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-0F-66-06-43-AC-6C-6F-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


I always have this message: No network devices have been found.

Thanks
aduplat
 
Posts: 29
Joined: 2009-12-09 16:47
Location: Iowa City, IA, USA

Re: Wireless problem

Postby Polaris96 » 2009-12-13 19:35

ok, the first thing we need to do is get you on dhcp. Become root and do this:
Code: Select all
~#dhclient wlan0
~#route


If the gods are kind, that will put you online.

You'll lose service on reboot, but we can deal with that, later. First, let's get you on the web. I need you to post the contents of your /etc/network/interfaces file.

If the advice above doesn't work I also need to generate a log file like this:
Code: Select all
~#dhclient wlan0 > dhclient.out

That will place a text file called dhclient.out in you home directory. Post that file here, as well, so I can see whats going on.
for as long as the world remains. for as long as time remains. so, too, will I remain. To serve. To help. And to make my contribution. Also, never forget our family at debianuserforums.org If we can't solve your problem, they probably can.
Polaris96
 
Posts: 555
Joined: 2009-06-17 18:37

Re: Wireless problem

Postby cnoyes » 2009-12-25 16:47

MAC Address: 00:1D:7E:D3:74:61
IP Address: 192.168.1.1
Subnet Mask: 255.255.255.0
DHCP Server: Enable
Start IP Address: 192.168.1.100
End IP Address: 192.168.1.149

This is my router:

IP Address: 173.30.24.249
Subnet Mask: 255.255.248.0
Default Gateway: 173.30.24.1
DNS 1: 74.84.119.150
DNS 2: 97.64.180.153


Off the top I can tell you that 192.168.1.1 is a gateway address, not a computer IP address. 173.xx.xx.xx is your external IP address, in other words, it's the IP you get from your service provider. You should be concerned with your local IP addresses. To simplify things, you should configure your router to be 192.168.1.1 and start IP addresses closer to 1, like say...1.10-1.25 or however many clients you have on your network. I'd guess that you only have a couple though. Also, if you're using DHCP(router handles your IP address) then there is no need to manually configure your IP address, or netmask. The first response to your question should have been something like this, your issue isn't linux related at the moment, it's network knowledge related.
=================
chris@suxbox.org
Debian Sid
=================
User avatar
cnoyes
 
Posts: 114
Joined: 2009-12-06 18:13
Location: North Carolina

Re: Wireless problem

Postby Polaris96 » 2009-12-26 15:58

that wasn't the file I need to see. Do it like this:
Code: Select all
cat /etc/network/interfaces > interface
route > routing


then open the "interface" and "routing" textfiles in an editor and paste the contents here
for as long as the world remains. for as long as time remains. so, too, will I remain. To serve. To help. And to make my contribution. Also, never forget our family at debianuserforums.org If we can't solve your problem, they probably can.
Polaris96
 
Posts: 555
Joined: 2009-06-17 18:37


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable