Tight VNC Server and keyboard mapping

New to Debian (Or Linux in general)? Ask your questions here!

Tight VNC Server and keyboard mapping

Postby Figgy » 2010-02-05 10:03

Hi,
First I'd like to mention that I'm very new to linux and have about 2 months worth of experience operating the systems.

I've set up our default environment wich is basically orientet by LAMP, with a few tweaks and additional libraries. This part works fine and everything seems to be in order. But I've also tried to set up a VNC server for remote control using Tight VNC Server (package: tightvncserver). This server did not start at all when rebooting the system and I had to create a startup script:
Code: Select all
#! /bin/sh
# /etc/init.d/tightvncs

echo "Starting Tight VNC Server"
su --command="tightvncserver :1" - root

No problems so far, and I know I shouldn't use the root user for this - but I'm just experimenting.

I had to uncomment 2 rows in the xstartup file (~/.vnc/xstartup) to get the environment to function when remote controlling. Before I did this there was no terminal and the menus appeard but was not interactive. The xstartup file currently looks like this:
Code: Select all
#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &
/etc/X11/Xsession


Now everything seems to work when using any VNC client (I've tried using RealVNC and TightVNC) but when I try to type using my remote keyboard the charecter map is way off. I've searched google and this bug is called the "abfh" bug. There seem to be workarounds but either I'm doing something wrong or the solutions are not working for me. To mention a specific "solution" to this was to open the gconf-editor and browse to: Desktop -> Gnome -> Peripherals -> Keyboard -> KBD and change the layout key value to any 2 letters (a-z), I choose "se". After restarting the tightvncserver the keyboard mapping was correct, but after rebooting the system the problem was back - and now the "layouts" key in gconf-editor is not writeable - so no changes can be made (and the value is empty).

Any help or tips is very much appriciated. Thanks // Daniel
Figgy
 
Posts: 2
Joined: 2010-02-05 09:27

Re: Tight VNC Server and keyboard mapping

Postby kce » 2010-02-07 02:44

I've had the same problem with TighVNC and Lenny and successfully resolved it with what appears to be the same hack. You do realize that gconf-settings are user-specific so if you have multiple users that are permitted VNC access you'll have to repeat the hack for each one.

What's the output of running the command: 'gconftool-2 --get desktop/gnome/peripherals/keyboard/kbd'

More information here if you haven't already found that bug report.
More paranoid than AMLJ!
User avatar
kce
 
Posts: 265
Joined: 2008-10-31 16:48


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable