Yet another Bluetooth Topic .. Squeeze

New to Debian (Or Linux in general)? Ask your questions here!

Yet another Bluetooth Topic .. Squeeze

Postby 9812713 » 2010-02-06 19:20

Afternoon gents,

It seems that one of the most anoying things I have encountered with Linux, is setting up bluetooth. No matter how many forums, wiki's or blogs out there posting information, nothing seems to work. I am running the amd64 bit version of squeeze, and I managed to have everything configure just the way I like it. I am running 2.6.32-trunk-amd64 as my kernel, and attempting to get bluetooth enable globally (at GDM, and during my desktop session. Here is a list of packages that I currently have installed for bluetooth support.

bluetooth 4.60-1
bluez 4.60-1
bluez-alsa 4.60-1
bluez-compat 4.60-1
bluez-firmware 1.2-2
bluez-cups 4.60-1
bluez-gstreamer 4.60-1
blueman 1.21-2

When I run lsusb I can see my dongle configured as:

Bus 005 Device 006: ID: 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Running hciconfig -a , I get
hci0: Type: USB
BD Address: 00:1F:81:00:02:50 ACL MTU: 1021:4 SCO MTU: 180:1
RX bytes:342 acl:0 sco:0 events:10 errors:0
TX bytes:33 acl:0 sco:0 commands:14 errors:4
Features: 0xff 0x3e 0x0d 0x76 0x80 0x01 0x00 0x80
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy:
Can't init device hci0: connection timeout (110)

Running the commands: hciconfig hci0 reset, followed by hciconfig hci0 inqmode 0, followed by a reboot worked once for a session, then in didn't.

I have tested this dongle on a WinXP box, and there are no issuse. It seems it is the linux + bluetooth hacks in place that are the issue.

At this point, running linux (debian) and owning a bluetooth mouse and keyboard are almost forcing me to once again adopt Window as my primary OS.. I have rebooted linux so many times, I've code named this project as "Windows 95"

Does anyone have any suggestions.?

Thank you.
Posts: 1
Joined: 2010-02-06 18:53

Re: Yet another Bluetooth Topic .. Squeeze

Postby gradinaruvasile » 2010-02-08 08:18

I use a Dell D630 with squeeze (32-bit). But the kernels from .32 up (i also tried the .32 kernel in Ubuntu, same results) have some problem with the bluetooth stack (might be just some specific models).
The problem i encountered is the following:
I can use bluetooth just fine after reboot. But if i turn it off from the bluetooth managers button, i cant get it back. I installed blueman because i like that better, but the same issue.
Workaround (it worked for me, try it, maybe it will work for you too):

- Use ONLY rfkill to turn on/off the bluetooth device: you have to install the rfkill package and use it from command line - needs sudo when turning on/off the device - syntax:

rfkill block/unblock bluetooth

for further info see

rfkill --help

Also there is a bluetooth conf file :/etc/bluetooth/main.conf . in that file change RememberPowered to false.
User avatar
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 9 guests