C complier? [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

C complier? [SOLVED]

Postby Temporary Saint » 2010-03-25 15:21

Hi,

Brand new Debian user here, but I've been testing out various Linux distros for a little while now. I installed Lenny yesterday on an old Dell Latitude D600 with no problems. I want to use Conky 1.7.2 which I downloaded from the Conky web site (only v1.6 is in the Debian repos). When I ran ./configure I got an error "no acceptable C compiler found in $PATH". Is there no complier installed by default??? If not which do you suggest I install?

Thanks,
Steve

Here is the full config.log for the install:
----------------------------------------------------------------------------------------------------
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Conky configure 1.7.2, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = debian
uname -m = i686
uname -r = 2.6.26-2-686
uname -s = Linux
uname -v = #1 SMP Tue Mar 9 17:35:51 UTC 2010

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2338: checking for a BSD-compatible install
configure:2406: result: /usr/bin/install -c
configure:2417: checking whether build environment is sane
configure:2460: result: yes
configure:2485: checking for a thread-safe mkdir -p
configure:2524: result: /bin/mkdir -p
configure:2537: checking for gawk
configure:2567: result: no
configure:2537: checking for mawk
configure:2553: found /usr/bin/mawk
configure:2564: result: mawk
configure:2575: checking whether make sets $(MAKE)
configure:2601: result: no
configure:2844: checking for gcc
configure:2874: result: no
configure:2937: checking for cc
configure:2984: result: no
configure:3040: checking for cl.exe
configure:3070: result: no
configure:3094: error: in `/home/steve/conky/conky-1.7.2':
configure:3097: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_Audacious_CFLAGS_set=
ac_cv_env_Audacious_CFLAGS_value=
ac_cv_env_Audacious_LIBS_set=
ac_cv_env_Audacious_LIBS_value=
ac_cv_env_BMPx_CFLAGS_set=
ac_cv_env_BMPx_CFLAGS_value=
ac_cv_env_BMPx_LIBS_set=
ac_cv_env_BMPx_LIBS_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_GLib2_CFLAGS_set=
ac_cv_env_GLib2_CFLAGS_value=
ac_cv_env_GLib2_LIBS_set=
ac_cv_env_GLib2_LIBS_value=
ac_cv_env_Imlib2_CFLAGS_set=
ac_cv_env_Imlib2_CFLAGS_value=
ac_cv_env_Imlib2_LIBS_set=
ac_cv_env_Imlib2_LIBS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_LUA51_CFLAGS_set=
ac_cv_env_LUA51_CFLAGS_value=
ac_cv_env_LUA51_LIBS_set=
ac_cv_env_LUA51_LIBS_value=
ac_cv_env_LUA_CFLAGS_set=
ac_cv_env_LUA_CFLAGS_value=
ac_cv_env_LUA_LIBS_set=
ac_cv_env_LUA_LIBS_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_X11_CFLAGS_set=
ac_cv_env_X11_CFLAGS_value=
ac_cv_env_X11_LIBS_set=
ac_cv_env_X11_LIBS_value=
ac_cv_env_XDamage_CFLAGS_set=
ac_cv_env_XDamage_CFLAGS_value=
ac_cv_env_XDamage_LIBS_set=
ac_cv_env_XDamage_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_XMMS2_CFLAGS_set=
ac_cv_env_XMMS2_CFLAGS_value=
ac_cv_env_XMMS2_LIBS_set=
ac_cv_env_XMMS2_LIBS_value=
ac_cv_env_Xext_CFLAGS_set=
ac_cv_env_Xext_CFLAGS_value=
ac_cv_env_Xext_LIBS_set=
ac_cv_env_Xext_LIBS_value=
ac_cv_env_Xft_CFLAGS_set=
ac_cv_env_Xft_CFLAGS_value=
ac_cv_env_Xft_LIBS_set=
ac_cv_env_Xft_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_cairo_CFLAGS_set=
ac_cv_env_cairo_CFLAGS_value=
ac_cv_env_cairo_LIBS_set=
ac_cv_env_cairo_LIBS_value=
ac_cv_env_cairo_xlib_CFLAGS_set=
ac_cv_env_cairo_xlib_CFLAGS_value=
ac_cv_env_cairo_xlib_LIBS_set=
ac_cv_env_cairo_xlib_LIBS_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_libcurl_CFLAGS_set=
ac_cv_env_libcurl_CFLAGS_value=
ac_cv_env_libcurl_LIBS_set=
ac_cv_env_libcurl_LIBS_value=
ac_cv_env_libxml2_CFLAGS_set=
ac_cv_env_libxml2_CFLAGS_value=
ac_cv_env_libxml2_LIBS_set=
ac_cv_env_libxml2_LIBS_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=mawk
ac_cv_prog_make_make_set=no

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/steve/conky/conky-1.7.2/missing --run aclocal-1.10'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /home/steve/conky/conky-1.7.2/missing --run tar'
AR=''
AUTOCONF='${SHELL} /home/steve/conky/conky-1.7.2/missing --run autoconf'
AUTOHEADER='${SHELL} /home/steve/conky/conky-1.7.2/missing --run autoheader'
AUTOMAKE='${SHELL} /home/steve/conky/conky-1.7.2/missing --run automake-1.10'
AWK='mawk'
Audacious_CFLAGS=''
Audacious_LIBS=''
BMPx_CFLAGS=''
BMPx_LIBS=''
BUILD_APCUPSD_FALSE=''
BUILD_APCUPSD_TRUE=''
BUILD_ARCH=''
BUILD_AUDACIOUS_FALSE=''
BUILD_AUDACIOUS_TRUE=''
BUILD_BMPX_FALSE=''
BUILD_BMPX_TRUE=''
BUILD_CONFIG_OUTPUT_FALSE=''
BUILD_CONFIG_OUTPUT_TRUE=''
BUILD_CURL_FALSE=''
BUILD_CURL_TRUE=''
BUILD_DATE=''
BUILD_EVE_FALSE=''
BUILD_EVE_TRUE=''
BUILD_FREEBSD_FALSE=''
BUILD_FREEBSD_TRUE=''
BUILD_HDDTEMP_FALSE=''
BUILD_HDDTEMP_TRUE=''
BUILD_IBM_FALSE=''
BUILD_IBM_TRUE=''
BUILD_IMLIB2_FALSE=''
BUILD_IMLIB2_TRUE=''
BUILD_LINUX_FALSE=''
BUILD_LINUX_TRUE=''
BUILD_LUA_CAIRO_FALSE=''
BUILD_LUA_CAIRO_TRUE=''
BUILD_LUA_FALSE=''
BUILD_LUA_IMLIB2_FALSE=''
BUILD_LUA_IMLIB2_TRUE=''
BUILD_LUA_TRUE=''
BUILD_MATH_FALSE=''
BUILD_MATH_TRUE=''
BUILD_MOC_FALSE=''
BUILD_MOC_TRUE=''
BUILD_MPD_FALSE=''
BUILD_MPD_TRUE=''
BUILD_NVIDIA_FALSE=''
BUILD_NVIDIA_TRUE=''
BUILD_OPENBSD_FALSE=''
BUILD_OPENBSD_TRUE=''
BUILD_PORT_MONITORS_FALSE=''
BUILD_PORT_MONITORS_TRUE=''
BUILD_RSS_FALSE=''
BUILD_RSS_TRUE=''
BUILD_WEATHER_FALSE=''
BUILD_WEATHER_TRUE=''
BUILD_WLAN_FALSE=''
BUILD_WLAN_TRUE=''
BUILD_X11_FALSE=''
BUILD_X11_TRUE=''
BUILD_XMMS2_FALSE=''
BUILD_XMMS2_TRUE=''
BUILD_XOAP_FALSE=''
BUILD_XOAP_TRUE=''
CC=''
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FGREP=''
GLib2_CFLAGS=''
GLib2_LIBS=''
GREP=''
HAVE_DOCSTUFF_FALSE=''
HAVE_DOCSTUFF_TRUE=''
HAVE_PKGCONFIG=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
Imlib2_CFLAGS=''
Imlib2_LIBS=''
LD=''
LDFLAGS=''
LIBICONV=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LIPO=''
LN_S=''
LTLIBICONV=''
LTLIBOBJS=''
LUA51_CFLAGS=''
LUA51_LIBS=''
LUA_CFLAGS=''
LUA_LIBS=''
MAKEINFO='${SHELL} /home/steve/conky/conky-1.7.2/missing --run makeinfo'
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE='conky'
PACKAGE_BUGREPORT='brenden1@users.sourceforge.net'
PACKAGE_NAME='Conky'
PACKAGE_STRING='Conky 1.7.2'
PACKAGE_TARNAME='conky'
PACKAGE_VERSION='1.7.2'
PATH_SEPARATOR=':'
PKG_CONFIG=''
RANLIB=''
SED=''
SET_MAKE='MAKE=make'
SHELL='/bin/sh'
STRIP=''
VERSION='1.7.2'
X11_CFLAGS=''
X11_LIBS=''
XDamage_CFLAGS=''
XDamage_LIBS=''
XMKMF=''
XMMS2_CFLAGS=''
XMMS2_LIBS=''
X_CFLAGS=''
X_EXTRA_LIBS=''
X_LIBS=''
X_PRE_LIBS=''
Xext_CFLAGS=''
Xext_LIBS=''
Xft_CFLAGS=''
Xft_LIBS=''
ac_ct_CC=''
ac_ct_DUMPBIN=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build=''
build_alias=''
build_cpu=''
build_os=''
build_vendor=''
cairo_CFLAGS=''
cairo_LIBS=''
cairo_xlib_CFLAGS=''
cairo_xlib_LIBS=''
conky_CFLAGS=''
conky_LIBS=''
datadir='${datarootdir}'
datarootdir='${prefix}/share'
db2x_manxml_cmd=''
db2x_xsltproc_cmd=''
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host=''
host_alias=''
host_cpu=''
host_os=''
host_vendor=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='$(SHELL) /home/steve/conky/conky-1.7.2/install-sh'
libcurl_CFLAGS=''
libcurl_LIBS=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
libxml2_CFLAGS=''
libxml2_LIBS=''
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''
tolua_CFLAGS=''
tolua_LIBS=''
toluapp=''
xsltproc_cmd=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "Conky"
#define PACKAGE_TARNAME "conky"
#define PACKAGE_VERSION "1.7.2"
#define PACKAGE_STRING "Conky 1.7.2"
#define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
#define PACKAGE "conky"
#define VERSION "1.7.2"
#define _GNU_SOURCE /**/

configure: exit 1
Last edited by Temporary Saint on 2010-04-13 13:56, edited 1 time in total.
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby bugsbunny » 2010-03-25 16:00

install build-essential
That should pull in what you need to start. You'll probably still need some package specific -dev files.

Looks like squeeze will release with 1.8 see #536320 - ITA: conky -- highly configurable system monitor for X based on torsmo - Debian Bug report logs
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby Temporary Saint » 2010-03-25 16:41

Thanks, Bugs!
Installed the build_essentials package and re-ran the ./configure. Got a lot further with the install, but still got an error msg:

"Can't locate your X11 installation"

Again, here is the config.log:

----------------------------------------------------------------------------------------
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Conky configure 1.7.2, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = debian
uname -m = i686
uname -r = 2.6.26-2-686
uname -s = Linux
uname -v = #1 SMP Tue Mar 9 17:35:51 UTC 2010

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2338: checking for a BSD-compatible install
configure:2406: result: /usr/bin/install -c
configure:2417: checking whether build environment is sane
configure:2460: result: yes
configure:2485: checking for a thread-safe mkdir -p
configure:2524: result: /bin/mkdir -p
configure:2537: checking for gawk
configure:2567: result: no
configure:2537: checking for mawk
configure:2553: found /usr/bin/mawk
configure:2564: result: mawk
configure:2575: checking whether make sets $(MAKE)
configure:2597: result: yes
configure:2844: checking for gcc
configure:2860: found /usr/bin/gcc
configure:2871: result: gcc
configure:3103: checking for C compiler version
configure:3111: gcc --version >&5
gcc (Debian 4.3.2-1.1) 4.3.2
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3115: $? = 0
configure:3122: gcc -v >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.3.2-1.1' --with-bugurl=file:///usr/share/doc/gcc-4.3/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.3 --program-suffix=-4.3 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-cld --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.3.2 (Debian 4.3.2-1.1)
configure:3126: $? = 0
configure:3133: gcc -V >&5
gcc: '-V' option must have argument
configure:3137: $? = 1
configure:3160: checking for C compiler default output file name
configure:3182: gcc conftest.c >&5
configure:3186: $? = 0
configure:3224: result: a.out
configure:3243: checking whether the C compiler works
configure:3253: ./a.out
configure:3257: $? = 0
configure:3276: result: yes
configure:3283: checking whether we are cross compiling
configure:3285: result: no
configure:3288: checking for suffix of executables
configure:3295: gcc -o conftest conftest.c >&5
configure:3299: $? = 0
configure:3325: result:
configure:3331: checking for suffix of object files
configure:3357: gcc -c conftest.c >&5
configure:3361: $? = 0
configure:3386: result: o
configure:3390: checking whether we are using the GNU C compiler
configure:3419: gcc -c conftest.c >&5
configure:3426: $? = 0
configure:3443: result: yes
configure:3452: checking whether gcc accepts -g
configure:3482: gcc -c -g conftest.c >&5
configure:3489: $? = 0
configure:3590: result: yes
configure:3607: checking for gcc option to accept ISO C89
configure:3681: gcc -c conftest.c >&5
configure:3688: $? = 0
configure:3711: result: none needed
configure:3740: checking for style of include used by make
configure:3768: result: GNU
configure:3793: checking dependency style of gcc
configure:3884: result: gcc3
configure:3905: checking build system type
configure:3923: result: i686-pc-linux-gnu
configure:3945: checking host system type
configure:3960: result: i686-pc-linux-gnu
configure:3982: checking for a sed that does not truncate output
configure:4048: result: /bin/sed
configure:4066: checking for grep that handles long lines and -e
configure:4126: result: /bin/grep
configure:4131: checking for egrep
configure:4195: result: /bin/grep -E
configure:4200: checking for fgrep
configure:4264: result: /bin/grep -F
configure:4299: checking for ld used by gcc
configure:4366: result: /usr/bin/ld
configure:4375: checking if the linker (/usr/bin/ld) is GNU ld
configure:4390: result: yes
configure:4416: checking for a BSD-compatible install
configure:4484: result: /usr/bin/install -c
configure:4520: checking for BSD- or MS-compatible name lister (nm)
configure:4569: result: /usr/bin/nm -B
configure:4687: checking the name lister (/usr/bin/nm -B) interface
configure:4694: gcc -c conftest.c >&5
configure:4697: /usr/bin/nm -B "conftest.o"
configure:4700: output
00000000 B some_variable
configure:4707: result: BSD nm
configure:4710: checking whether ln -s works
configure:4714: result: yes
configure:4722: checking the maximum length of command line arguments
configure:4842: result: 98304
configure:4859: checking whether the shell understands some XSI constructs
configure:4869: result: yes
configure:4873: checking whether the shell understands "+="
configure:4879: result: yes
configure:4914: checking for /usr/bin/ld option to reload object files
configure:4921: result: -r
configure:4990: checking for objdump
configure:5006: found /usr/bin/objdump
configure:5017: result: objdump
configure:5049: checking how to recognize dependent libraries
configure:5245: result: pass_all
configure:5305: checking for ar
configure:5321: found /usr/bin/ar
configure:5332: result: ar
configure:5410: checking for strip
configure:5426: found /usr/bin/strip
configure:5437: result: strip
configure:5509: checking for ranlib
configure:5525: found /usr/bin/ranlib
configure:5536: result: ranlib
configure:5626: checking command to parse /usr/bin/nm -B output from gcc object
configure:5744: gcc -c conftest.c >&5
configure:5747: $? = 0
configure:5751: /usr/bin/nm -B conftest.o \| sed -n -e 's/^.*[ ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[ ][ ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2 \2/p' \> conftest.nm
configure:5754: $? = 0
configure:5808: gcc -o conftest conftest.c conftstm.o >&5
configure:5811: $? = 0
configure:5849: result: ok
configure:6716: checking how to run the C preprocessor
configure:6756: gcc -E conftest.c
configure:6763: $? = 0
configure:6794: gcc -E conftest.c
conftest.c:11:28: error: ac_nonexistent.h: No such file or directory
configure:6801: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Conky"
| #define PACKAGE_TARNAME "conky"
| #define PACKAGE_VERSION "1.7.2"
| #define PACKAGE_STRING "Conky 1.7.2"
| #define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
| #define PACKAGE "conky"
| #define VERSION "1.7.2"
| #define _GNU_SOURCE /**/
| /* end confdefs.h. */
| #include <ac_nonexistent.h>
configure:6834: result: gcc -E
configure:6863: gcc -E conftest.c
configure:6870: $? = 0
configure:6901: gcc -E conftest.c
conftest.c:11:28: error: ac_nonexistent.h: No such file or directory
configure:6908: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Conky"
| #define PACKAGE_TARNAME "conky"
| #define PACKAGE_VERSION "1.7.2"
| #define PACKAGE_STRING "Conky 1.7.2"
| #define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
| #define PACKAGE "conky"
| #define VERSION "1.7.2"
| #define _GNU_SOURCE /**/
| /* end confdefs.h. */
| #include <ac_nonexistent.h>
configure:6948: checking for ANSI C header files
configure:6978: gcc -c conftest.c >&5
configure:6985: $? = 0
configure:7084: gcc -o conftest conftest.c >&5
configure:7088: $? = 0
configure:7094: ./conftest
configure:7098: $? = 0
configure:7116: result: yes
configure:7140: checking for sys/types.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for sys/stat.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for stdlib.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for string.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for memory.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for strings.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for inttypes.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for stdint.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7140: checking for unistd.h
configure:7161: gcc -c conftest.c >&5
configure:7168: $? = 0
configure:7185: result: yes
configure:7203: checking for dlfcn.h
configure:7224: gcc -c conftest.c >&5
configure:7231: $? = 0
configure:7248: result: yes
configure:7434: checking for objdir
configure:7449: result: .libs
configure:7745: checking if gcc supports -fno-rtti -fno-exceptions
configure:7763: gcc -c -fno-rtti -fno-exceptions conftest.c >&5
cc1: warning: command line option "-fno-rtti" is valid for C++/ObjC++ but not for C
configure:7767: $? = 0
configure:7780: result: no
configure:7800: checking for gcc option to produce PIC
configure:8072: result: -fPIC -DPIC
configure:8084: checking if gcc PIC flag -fPIC -DPIC works
configure:8102: gcc -c -fPIC -DPIC -DPIC conftest.c >&5
configure:8106: $? = 0
configure:8119: result: yes
configure:8143: checking if gcc static flag -static works
configure:8171: result: yes
configure:8186: checking if gcc supports -c -o file.o
configure:8207: gcc -c -o out/conftest2.o conftest.c >&5
configure:8211: $? = 0
configure:8233: result: yes
configure:8241: checking if gcc supports -c -o file.o
configure:8288: result: yes
configure:8321: checking whether the gcc linker (/usr/bin/ld) supports shared libraries
configure:9395: result: yes
configure:9432: checking whether -lc should be explicitly linked in
configure:9437: gcc -c conftest.c >&5
configure:9440: $? = 0
configure:9455: gcc -shared conftest.o -v -Wl,-soname -Wl,conftest -o conftest 2\>\&1 \| /bin/grep -lc \>/dev/null 2\>\&1
configure:9458: $? = 0
configure:9470: result: no
configure:9634: checking dynamic linker characteristics
configure:10090: gcc -o conftest -Wl,-rpath -Wl,/foo conftest.c >&5
configure:10097: $? = 0
configure:10330: result: GNU/Linux ld.so
configure:10432: checking how to hardcode library paths into programs
configure:10457: result: immediate
configure:11290: checking whether stripping libraries is possible
configure:11295: result: yes
configure:11330: checking if libtool supports shared libraries
configure:11332: result: yes
configure:11335: checking whether to build shared libraries
configure:11356: result: yes
configure:11359: checking whether to build static libraries
configure:11363: result: yes
configure:11400: checking whether gcc and cc understand -c and -o together
configure:11435: gcc -c conftest.c -o conftest2.o >&5
configure:11439: $? = 0
configure:11445: gcc -c conftest.c -o conftest2.o >&5
configure:11449: $? = 0
configure:11460: cc -c conftest.c >&5
configure:11464: $? = 0
configure:11472: cc -c conftest.c -o conftest2.o >&5
configure:11476: $? = 0
configure:11482: cc -c conftest.c -o conftest2.o >&5
configure:11486: $? = 0
configure:11504: result: yes
configure:11534: checking for pkg-config
configure:11550: found /usr/bin/pkg-config
configure:11562: result: yes
configure:11624: checking for pkg-config
configure:11642: found /usr/bin/pkg-config
configure:11654: result: /usr/bin/pkg-config
configure:11679: checking pkg-config is at least version 0.19
configure:11682: result: yes
configure:11787: checking for fopencookie
configure:11843: gcc -o conftest conftest.c >&5
configure:11850: $? = 0
configure:11872: result: yes
configure:11888: checking for funopen
configure:11944: gcc -o conftest conftest.c >&5
/tmp/ccM8LTa0.o: In function `main':
conftest.c:(.text+0x12): undefined reference to `funopen'
collect2: ld returned 1 exit status
configure:11951: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Conky"
| #define PACKAGE_TARNAME "conky"
| #define PACKAGE_VERSION "1.7.2"
| #define PACKAGE_STRING "Conky 1.7.2"
| #define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
| #define PACKAGE "conky"
| #define VERSION "1.7.2"
| #define _GNU_SOURCE /**/
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define LT_OBJDIR ".libs/"
| #define CONFIG_OUTPUT 1
| #define HAVE_FOPENCOOKIE 1
| /* end confdefs.h. */
| /* Define funopen to an innocuous variant, in case <limits.h> declares funopen.
| For example, HP-UX 11i <limits.h> declares gettimeofday. */
| #define funopen innocuous_funopen
|
| /* System header to define __stub macros and hopefully few prototypes,
| which can conflict with char funopen (); below.
| Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
| <limits.h> exists even on freestanding compilers. */
|
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
|
| #undef funopen
|
| /* Override any GCC internal prototype to avoid an error.
| Use char because int might match the return type of a GCC
| builtin and then its argument prototype would still apply. */
| #ifdef __cplusplus
| extern "C"
| #endif
| char funopen ();
| /* The GNU C library defines this for functions which it implements
| to always fail with ENOSYS. Some functions are actually named
| something starting with __ and the normal name is an alias. */
| #if defined __stub_funopen || defined __stub___funopen
| choke me
| #endif
|
| int
| main ()
| {
| return funopen ();
| ;
| return 0;
| }
configure:11973: result: no
configure:13347: checking for X
configure:13462: gcc -E conftest.c
conftest.c:32:22: error: X11/Xlib.h: No such file or directory
configure:13469: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Conky"
| #define PACKAGE_TARNAME "conky"
| #define PACKAGE_VERSION "1.7.2"
| #define PACKAGE_STRING "Conky 1.7.2"
| #define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
| #define PACKAGE "conky"
| #define VERSION "1.7.2"
| #define _GNU_SOURCE /**/
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define LT_OBJDIR ".libs/"
| #define CONFIG_OUTPUT 1
| #define HAVE_FOPENCOOKIE 1
| #define OWN_WINDOW 1
| #define HDDTEMP 1
| #define APCUPSD 1
| #define IOSTATS 1
| #define MATH 1
| #define MPD 1
| #define MOC 1
| /* end confdefs.h. */
| #include <X11/Xlib.h>
configure:13518: gcc -o conftest conftest.c -lX11 >&5
conftest.c:32:22: error: X11/Xlib.h: No such file or directory
configure:13525: $? = 1
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Conky"
| #define PACKAGE_TARNAME "conky"
| #define PACKAGE_VERSION "1.7.2"
| #define PACKAGE_STRING "Conky 1.7.2"
| #define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
| #define PACKAGE "conky"
| #define VERSION "1.7.2"
| #define _GNU_SOURCE /**/
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DLFCN_H 1
| #define LT_OBJDIR ".libs/"
| #define CONFIG_OUTPUT 1
| #define HAVE_FOPENCOOKIE 1
| #define OWN_WINDOW 1
| #define HDDTEMP 1
| #define APCUPSD 1
| #define IOSTATS 1
| #define MATH 1
| #define MPD 1
| #define MOC 1
| /* end confdefs.h. */
| #include <X11/Xlib.h>
| int
| main ()
| {
| XrmInitialize ()
| ;
| return 0;
| }
configure:13576: result: no
configure:14730: error: Can't locate your X11 installation

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnu
ac_cv_c_compiler_gnu=yes
ac_cv_env_Audacious_CFLAGS_set=
ac_cv_env_Audacious_CFLAGS_value=
ac_cv_env_Audacious_LIBS_set=
ac_cv_env_Audacious_LIBS_value=
ac_cv_env_BMPx_CFLAGS_set=
ac_cv_env_BMPx_CFLAGS_value=
ac_cv_env_BMPx_LIBS_set=
ac_cv_env_BMPx_LIBS_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_GLib2_CFLAGS_set=
ac_cv_env_GLib2_CFLAGS_value=
ac_cv_env_GLib2_LIBS_set=
ac_cv_env_GLib2_LIBS_value=
ac_cv_env_Imlib2_CFLAGS_set=
ac_cv_env_Imlib2_CFLAGS_value=
ac_cv_env_Imlib2_LIBS_set=
ac_cv_env_Imlib2_LIBS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_LUA51_CFLAGS_set=
ac_cv_env_LUA51_CFLAGS_value=
ac_cv_env_LUA51_LIBS_set=
ac_cv_env_LUA51_LIBS_value=
ac_cv_env_LUA_CFLAGS_set=
ac_cv_env_LUA_CFLAGS_value=
ac_cv_env_LUA_LIBS_set=
ac_cv_env_LUA_LIBS_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_X11_CFLAGS_set=
ac_cv_env_X11_CFLAGS_value=
ac_cv_env_X11_LIBS_set=
ac_cv_env_X11_LIBS_value=
ac_cv_env_XDamage_CFLAGS_set=
ac_cv_env_XDamage_CFLAGS_value=
ac_cv_env_XDamage_LIBS_set=
ac_cv_env_XDamage_LIBS_value=
ac_cv_env_XMKMF_set=
ac_cv_env_XMKMF_value=
ac_cv_env_XMMS2_CFLAGS_set=
ac_cv_env_XMMS2_CFLAGS_value=
ac_cv_env_XMMS2_LIBS_set=
ac_cv_env_XMMS2_LIBS_value=
ac_cv_env_Xext_CFLAGS_set=
ac_cv_env_Xext_CFLAGS_value=
ac_cv_env_Xext_LIBS_set=
ac_cv_env_Xext_LIBS_value=
ac_cv_env_Xft_CFLAGS_set=
ac_cv_env_Xft_CFLAGS_value=
ac_cv_env_Xft_LIBS_set=
ac_cv_env_Xft_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_cairo_CFLAGS_set=
ac_cv_env_cairo_CFLAGS_value=
ac_cv_env_cairo_LIBS_set=
ac_cv_env_cairo_LIBS_value=
ac_cv_env_cairo_xlib_CFLAGS_set=
ac_cv_env_cairo_xlib_CFLAGS_value=
ac_cv_env_cairo_xlib_LIBS_set=
ac_cv_env_cairo_xlib_LIBS_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_libcurl_CFLAGS_set=
ac_cv_env_libcurl_CFLAGS_value=
ac_cv_env_libcurl_LIBS_set=
ac_cv_env_libcurl_LIBS_value=
ac_cv_env_libxml2_CFLAGS_set=
ac_cv_env_libxml2_CFLAGS_value=
ac_cv_env_libxml2_LIBS_set=
ac_cv_env_libxml2_LIBS_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_func_fopencookie=yes
ac_cv_func_funopen=no
ac_cv_have_x=have_x=no
ac_cv_header_dlfcn_h=yes
ac_cv_header_inttypes_h=yes
ac_cv_header_memory_h=yes
ac_cv_header_stdc=yes
ac_cv_header_stdint_h=yes
ac_cv_header_stdlib_h=yes
ac_cv_header_string_h=yes
ac_cv_header_strings_h=yes
ac_cv_header_sys_stat_h=yes
ac_cv_header_sys_types_h=yes
ac_cv_header_unistd_h=yes
ac_cv_host=i686-pc-linux-gnu
ac_cv_objext=o
ac_cv_path_EGREP='/bin/grep -E'
ac_cv_path_FGREP='/bin/grep -F'
ac_cv_path_GREP=/bin/grep
ac_cv_path_SED=/bin/sed
ac_cv_path_ac_pt_PKG_CONFIG=/usr/bin/pkg-config
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=mawk
ac_cv_prog_CPP='gcc -E'
ac_cv_prog_HAVE_PKGCONFIG=yes
ac_cv_prog_ac_ct_AR=ar
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_ac_ct_OBJDUMP=objdump
ac_cv_prog_ac_ct_RANLIB=ranlib
ac_cv_prog_ac_ct_STRIP=strip
ac_cv_prog_cc_c89=
ac_cv_prog_cc_g=yes
ac_cv_prog_cc_gcc_c_o=yes
ac_cv_prog_make_make_set=yes
am_cv_CC_dependencies_compiler_type=gcc3
lt_cv_deplibs_check_method=pass_all
lt_cv_file_magic_cmd='$MAGIC_CMD'
lt_cv_file_magic_test_file=
lt_cv_ld_reload_flag=-r
lt_cv_nm_interface='BSD nm'
lt_cv_objdir=.libs
lt_cv_path_LD=/usr/bin/ld
lt_cv_path_NM='/usr/bin/nm -B'
lt_cv_prog_compiler_c_o=yes
lt_cv_prog_compiler_pic_works=yes
lt_cv_prog_compiler_rtti_exceptions=no
lt_cv_prog_compiler_static_works=yes
lt_cv_prog_gnu_ld=yes
lt_cv_sys_global_symbol_pipe='sed -n -e '\''s/^.*[ ]\([ABCDGIRSTW][ABCDGIRSTW]*\)[ ][ ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2 \2/p'\'''
lt_cv_sys_global_symbol_to_c_name_address='sed -n -e '\''s/^: \([^ ]*\) $/ {\"\1\", (void *) 0},/p'\'' -e '\''s/^[ABCDGIRSTW]* \([^ ]*\) \([^ ]*\)$/ {"\2", (void *) \&\2},/p'\'''
lt_cv_sys_global_symbol_to_c_name_address_lib_prefix='sed -n -e '\''s/^: \([^ ]*\) $/ {\"\1\", (void *) 0},/p'\'' -e '\''s/^[ABCDGIRSTW]* \([^ ]*\) \(lib[^ ]*\)$/ {"\2", (void *) \&\2},/p'\'' -e '\''s/^[ABCDGIRSTW]* \([^ ]*\) \([^ ]*\)$/ {"lib\2", (void *) \&\2},/p'\'''
lt_cv_sys_global_symbol_to_cdecl='sed -n -e '\''s/^T .* \(.*\)$/extern int \1();/p'\'' -e '\''s/^[ABCDGIRSTW]* .* \(.*\)$/extern char \1;/p'\'''
lt_cv_sys_max_cmd_len=98304

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/steve/conky/conky-1.7.2/missing --run aclocal-1.10'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL} /home/steve/conky/conky-1.7.2/missing --run tar'
AR='ar'
AUTOCONF='${SHELL} /home/steve/conky/conky-1.7.2/missing --run autoconf'
AUTOHEADER='${SHELL} /home/steve/conky/conky-1.7.2/missing --run autoheader'
AUTOMAKE='${SHELL} /home/steve/conky/conky-1.7.2/missing --run automake-1.10'
AWK='mawk'
Audacious_CFLAGS=''
Audacious_LIBS=''
BMPx_CFLAGS=''
BMPx_LIBS=''
BUILD_APCUPSD_FALSE='#'
BUILD_APCUPSD_TRUE=''
BUILD_ARCH='Linux 2.6.26-2-686 (i686)'
BUILD_AUDACIOUS_FALSE=''
BUILD_AUDACIOUS_TRUE='#'
BUILD_BMPX_FALSE=''
BUILD_BMPX_TRUE='#'
BUILD_CONFIG_OUTPUT_FALSE='#'
BUILD_CONFIG_OUTPUT_TRUE=''
BUILD_CURL_FALSE=''
BUILD_CURL_TRUE=''
BUILD_DATE='Thu Mar 25 12:32:26 EDT 2010'
BUILD_EVE_FALSE=''
BUILD_EVE_TRUE='#'
BUILD_FREEBSD_FALSE=''
BUILD_FREEBSD_TRUE='#'
BUILD_HDDTEMP_FALSE='#'
BUILD_HDDTEMP_TRUE=''
BUILD_IBM_FALSE=''
BUILD_IBM_TRUE='#'
BUILD_IMLIB2_FALSE=''
BUILD_IMLIB2_TRUE=''
BUILD_LINUX_FALSE='#'
BUILD_LINUX_TRUE=''
BUILD_LUA_CAIRO_FALSE=''
BUILD_LUA_CAIRO_TRUE=''
BUILD_LUA_FALSE=''
BUILD_LUA_IMLIB2_FALSE=''
BUILD_LUA_IMLIB2_TRUE=''
BUILD_LUA_TRUE=''
BUILD_MATH_FALSE='#'
BUILD_MATH_TRUE=''
BUILD_MOC_FALSE='#'
BUILD_MOC_TRUE=''
BUILD_MPD_FALSE='#'
BUILD_MPD_TRUE=''
BUILD_NVIDIA_FALSE=''
BUILD_NVIDIA_TRUE=''
BUILD_OPENBSD_FALSE=''
BUILD_OPENBSD_TRUE='#'
BUILD_PORT_MONITORS_FALSE=''
BUILD_PORT_MONITORS_TRUE=''
BUILD_RSS_FALSE=''
BUILD_RSS_TRUE='#'
BUILD_WEATHER_FALSE=''
BUILD_WEATHER_TRUE='#'
BUILD_WLAN_FALSE=''
BUILD_WLAN_TRUE=''
BUILD_X11_FALSE='#'
BUILD_X11_TRUE=''
BUILD_XMMS2_FALSE=''
BUILD_XMMS2_TRUE='#'
BUILD_XOAP_FALSE=''
BUILD_XOAP_TRUE='#'
CC='gcc'
CCDEPMODE='depmode=gcc3'
CFLAGS=''
CPP='gcc -E'
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR='.deps'
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='/bin/grep -E'
EXEEXT=''
FGREP='/bin/grep -F'
GLib2_CFLAGS=''
GLib2_LIBS=''
GREP='/bin/grep'
HAVE_DOCSTUFF_FALSE=''
HAVE_DOCSTUFF_TRUE=''
HAVE_PKGCONFIG='yes'
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
Imlib2_CFLAGS=''
Imlib2_LIBS=''
LD='/usr/bin/ld'
LDFLAGS=''
LIBICONV=''
LIBOBJS=''
LIBS=''
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
LIPO=''
LN_S='ln -s'
LTLIBICONV=''
LTLIBOBJS=''
LUA51_CFLAGS=''
LUA51_LIBS=''
LUA_CFLAGS=''
LUA_LIBS=''
MAKEINFO='${SHELL} /home/steve/conky/conky-1.7.2/missing --run makeinfo'
MKDIR_P='/bin/mkdir -p'
NM='/usr/bin/nm -B'
NMEDIT=''
OBJDUMP='objdump'
OBJEXT='o'
OTOOL64=''
OTOOL=''
PACKAGE='conky'
PACKAGE_BUGREPORT='brenden1@users.sourceforge.net'
PACKAGE_NAME='Conky'
PACKAGE_STRING='Conky 1.7.2'
PACKAGE_TARNAME='conky'
PACKAGE_VERSION='1.7.2'
PATH_SEPARATOR=':'
PKG_CONFIG='/usr/bin/pkg-config'
RANLIB='ranlib'
SED='/bin/sed'
SET_MAKE=''
SHELL='/bin/sh'
STRIP='strip'
VERSION='1.7.2'
X11_CFLAGS=''
X11_LIBS=''
XDamage_CFLAGS=''
XDamage_LIBS=''
XMKMF=''
XMMS2_CFLAGS=''
XMMS2_LIBS=''
X_CFLAGS=''
X_EXTRA_LIBS=''
X_LIBS=''
X_PRE_LIBS=''
Xext_CFLAGS=''
Xext_LIBS=''
Xft_CFLAGS=''
Xft_LIBS=''
ac_ct_CC='gcc'
ac_ct_DUMPBIN=''
am__fastdepCC_FALSE='#'
am__fastdepCC_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias=''
build_cpu='i686'
build_os='linux-gnu'
build_vendor='pc'
cairo_CFLAGS=''
cairo_LIBS=''
cairo_xlib_CFLAGS=''
cairo_xlib_LIBS=''
conky_CFLAGS=' '
conky_LIBS=' -lm '
datadir='${datarootdir}'
datarootdir='${prefix}/share'
db2x_manxml_cmd=''
db2x_xsltproc_cmd=''
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='i686-pc-linux-gnu'
host_alias=''
host_cpu='i686'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='$(SHELL) /home/steve/conky/conky-1.7.2/install-sh'
libcurl_CFLAGS=''
libcurl_LIBS=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
libxml2_CFLAGS=''
libxml2_LIBS=''
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''
tolua_CFLAGS=''
tolua_LIBS=''
toluapp=''
xsltproc_cmd=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "Conky"
#define PACKAGE_TARNAME "conky"
#define PACKAGE_VERSION "1.7.2"
#define PACKAGE_STRING "Conky 1.7.2"
#define PACKAGE_BUGREPORT "brenden1@users.sourceforge.net"
#define PACKAGE "conky"
#define VERSION "1.7.2"
#define _GNU_SOURCE /**/
#define STDC_HEADERS 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRING_H 1
#define HAVE_MEMORY_H 1
#define HAVE_STRINGS_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_STDINT_H 1
#define HAVE_UNISTD_H 1
#define HAVE_DLFCN_H 1
#define LT_OBJDIR ".libs/"
#define CONFIG_OUTPUT 1
#define HAVE_FOPENCOOKIE 1
#define OWN_WINDOW 1
#define HDDTEMP 1
#define APCUPSD 1
#define IOSTATS 1
#define MATH 1
#define MPD 1
#define MOC 1
#define X_DISPLAY_MISSING 1

configure: exit 1
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby roseway » 2010-03-25 18:57

aptitude install build-essential

or

apt-get install build-essential
Eric
User avatar
roseway
 
Posts: 1510
Joined: 2007-12-31 22:50
Location: Kent, UK

Re: C complier?

Postby Temporary Saint » 2010-03-25 20:21

Hi Eric,

I already installed the build-essentials package. You probably missed that fact in the thousands of lines of log files I've posted so far. :oops: I have two posts. The second one lists the error I'm getting now. Please take a look and see if you can help!

Thanks,
Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby aspnair » 2010-03-26 15:46

apt-get install libx11-dev
try again.
Compressed Air Energy Storage, Entropy and Efficiency
http://saurorja.org/2012/06/18/compress ... fficiency/
User avatar
aspnair
 
Posts: 1247
Joined: 2009-06-18 12:27
Location: Twitter: @anand_sivaram

Re: C complier?

Postby Temporary Saint » 2010-03-26 18:31

One more time.

I installed libx11-dev and re-ran ./configure. Got this error at the end of the output:
-----------------------------------------------------------------------------------------------------------
checking for LUA51... configure: error: Package requirements (lua5.1 >= 5.1) were not met:

No package 'lua5.1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables LUA51_CFLAGS and LUA51_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.
------------------------------------------------------------------------------------------------------------
I verified that lua5.1 was installed, even uninstalling and reinstalling it, and got the same error. A far as adjusting the environment variables, that's a bit above my head right now.

Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby saulgoode » 2010-03-26 19:21

Could you post the output from running the following command:

pkg-config --modversion lua
Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it. -- Brian Kernighan
User avatar
saulgoode
 
Posts: 1545
Joined: 2007-10-22 11:34

Re: C complier?

Postby Temporary Saint » 2010-03-26 20:04

steve@debian:~$ pkg-config --modversion lua
Package lua was not found in the pkg-config search path.
Perhaps you should add the directory containing `lua.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lua' found
---------------------------------------------------------------------

Well THAT looks like a problem. I did a file search in Nautilus for lua.pc and came up empty. The lua5.1 executable is located in /user/bin though.

Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby saulgoode » 2010-03-26 20:19

You might try searching (the repositories?) for a 'lua-dev.deb' package. If you can't find one then you should be able to find a 'lua.pc' file in the source code package.
Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it. -- Brian Kernighan
User avatar
saulgoode
 
Posts: 1545
Joined: 2007-10-22 11:34

Re: C complier?

Postby stevepusser » 2010-03-26 22:50

Oh dear. This string of problems is exactly why Soul Singin' wrote his guide to building programs the smart way.

viewtopic.php?f=16&t=38976

Seriously, when I first started to compile programs, I did it the hard way, too. Then found out that using the already debianized source files from upstream Debian will auto-install all the build-dependencies, apply Debian patches, and create .deb files automagically, taking almost all the work out of it. Even a big complex package like XBMC or VLC (1.0.5) becomes rather easy. The only knowledge I have to keep now is what to tweak in rules files if I get a build failure with Lenny's Python, for example.

Taking a look at the build-deps of Squeeze's 1.7.1 conky, I can see it needs (for deb packaging)

debhelper (>= 5.0.0), quilt, libx11-dev, libxft-dev,
libxdamage-dev, libxext-dev, pkg-config (>= 0.19), libglib2.0-dev,
libxml2-dev, libcurl4-gnutls-dev, libasound2-dev,
libtool, automake1.10

Quilt is a Debian patching tool, automake and libtool rebuild the configure script for your particular system...but you really don't need to know any of that to rebuild the debs for Lenny. It looks like all those build-deps are available in Lenny, also.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11097
Joined: 2009-10-06 05:53

Re: C complier?

Postby stevepusser » 2010-03-27 00:57

OK, took a look at backporting it to see if any pitfalls---you will need to upgrade libtool to the lenny-backports version, otherwise you'll get a build failure. Debian also disables the lua functionality, maybe because it's too buggy. Of course, if you are packaging it yourself, you can add that back in if you want. As a proof of concept, here's the 32 bit .deb:

https://docs.google.com/leaf?id=0B1UMhs ... Yjg5&hl=en
Last edited by stevepusser on 2010-03-31 03:47, edited 1 time in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11097
Joined: 2009-10-06 05:53

Re: C complier?

Postby bugsbunny » 2010-03-27 03:21

He wants a version that's newer than the one even (currently) in testing/unstable. Now the bug report I linked to does contain links to some newer packages, and he can probably pull the debianized source from the lucid lynx ubuntu repos. Ubuntu -- Details of source package conky in lucid The lua stuff is pretty new and may just not be available in the current Debian versions.

In any case the lua package that's needed is liblua5.1-0-dev. For the 1.8 version you would also need libtolua++5.1-dev, which has just recently made it into sid and squeeze (not available in lenny). This package was brought in in order to enable conky 1.8 to come in (again read the bug report I linked)
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby bugsbunny » 2010-03-27 03:31

OK, the lua support was first available in 1.7.1, which is the version in sid/squeeze. However the libtolua++5.1-dev package wasn't available and I suspect that's why lua support was turned off. So, no matter where you get the source from, you'll either need to turn off lua, backport Debian -- Details of source package tolua++ in squeeze, or just upgrade to squeeze :)
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby stevepusser » 2010-03-27 05:14

A lot faster just to backport libtolua++ to Lenny than update to Squeeze!

Link to 32 bit deb plus source files: https://docs.google.com/leaf?id=0B1UMhs ... YjEz&hl=en

I took a look at Ubuntu's 1.7.2 conky and may give building it a try. It actually builds two version of conky: a "-std" version, much like Debian's, and a "-all" that enables every possible option. Lucid's 1.8 is still a pull from git and may not be very stable...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11097
Joined: 2009-10-06 05:53

Next

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable