C complier? [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

Re: C complier?

Postby bugsbunny » 2010-03-27 13:33

Just as an FYI 1.8 has already released 2 RC versions. Next release will either be final or RC3, so I suspect that it's likely to be pretty stable, even as a git pull (and git is likely in even better shape than RC2, which was released 2010-01-24)
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby Temporary Saint » 2010-03-29 13:30

Wow, folks, lots of great replies! Thanks.

First, I got Conky 1.7.2 working under Linux Mint 7 with no problems by accessing the Ubuntu Karmic repositories. I tried that with Lenny and it wouldn't work. Based on your posts I could try the Lucid repositories instead? Any 1.7.x version is fine for me right now. I want the weather functionality that isn't available in 1.6.x.

Upgrading to Squeeze is also an option since my Lenny build is only for testing anyway.

Lastly...Build my own package? This newb would love to try it. Someday. But not yet. I think. I'll read that post with the build instructions to see what I'm in for.

Again, thanks for your replies. I'll update this post with what I finally do.

Steve

PS - Oh and that Google Docs link wouldn't work for me.
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby stevepusser » 2010-03-31 03:46

Oops, forgot to enable global sharing on that file.

Link: https://docs.google.com/leaf?id=0B1UMhs ... Yjg5&hl=en
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby Temporary Saint » 2010-03-31 15:23

Thank you for the Google Docs access! Your .deb file installed without any errors. I was trying to do the 1.8.0 install using the Lucid repos, but I kept getting an error trying to update a libc6 library.

One more question - Conky 1.7.1 should support imlib2 which enables the display of weather icons in conkyForecast, yet they are not displaying on my system. All other conkyForecast info is. Any ideas why?

Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby stevepusser » 2010-04-01 04:17

Well, I just recompiled the upstream Debian version without any changes for the 1.7.1 Conky. There is a configuration option to turn on the imlib2 support, which the Debian version, and I, did not enable. I tried the 1.7.2 Ubuntu source with that enabled, but got a build failure related to imlib2...which maybe is why it was disabled. I will see if rebuilding a newer imlib2 for Lenny will fix that bug.

And the libc6 problems...many times you can't use a program compiled against a newer libc6, yet if you take the same source code and compile it against your version, it will work fine...That's about the major reason for backporting.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby bugsbunny » 2010-04-01 04:33

Did you have libimlib2-dev installed?
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby stevepusser » 2010-04-01 06:07

Yes, that's one of the nice things about reusing the upstream Debianized sources, there's a control file that lists all the build depends and a single command to automatically install them all. I think the Lenny version is missing a symbol that conky calls out. If I can get it to build with a newer version of the library, then I'll let the package maintainer know to update the build-depend to add a minimum version.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby Temporary Saint » 2010-04-01 15:31

This is what is so great about FOSS. I'd never get this help with closed source.

I'll keep my eyes on this post to see how the build goes.

Thank you!
Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby stevepusser » 2010-04-03 05:16

Thought I'd let you know that a backport of libimlib2 let me successfully also backport the Ubuntu 1.7.2 version, though I have not tested the lua and cairo functionality; they are enabled in the conky-all package. I'm currently really busy helping with the new Mepis 8.5 volunteer community repository (where I have picked up what backporting skills I possess), but will redo the backports for Lenny in my 32-bit virtual machine.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby stevepusser » 2010-04-03 07:01

OK, also found out that you need to upgrade libcairo2 and -dev to the Lenny-Backports version 1.8.8 to get it to build, which may have been the root of the problem of your first build failure. Anyway, that's just for the fancy conky-all version, not the conky-std--also included.

So, if you want that, upgrade libcairo2, install libimlib2 from the following tarball first, then your selected version of conky, also in the file: (32 bit only)

https://docs.google.com/leaf?id=0B1UMhs ... ODRl&hl=en
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby Temporary Saint » 2010-04-05 20:11

I think you might have forgotten to enable global sharing again?

Steve
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby stevepusser » 2010-04-07 07:44

Yeah...it was really late (for me)

Sharing is now enabled. Thanks.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11096
Joined: 2009-10-06 05:53

Re: C complier?

Postby bugsbunny » 2010-04-07 12:22

Just a note. Conky 1.8 has now been released as stable, and is also now available in sid (showed up today)Debian -- Package Search Results -- conky
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: C complier?

Postby Temporary Saint » 2010-04-07 19:59

Steve,
Thanks for opening the access to the file. The only problem I'm running into (so far) is installing the upgrades for libcairo2. I've got a dependency issue with libpixman, and I'm wondering if that library is going to have another. Maybe more issues than I'm ready to take on.

Bugs,
When I tried to install the conky package from Sid, apt displayed over a hundred packages that would need to be upgraded, which looked like it amounted to an actual upgrade to Sid. I don't think I want that. Also if I download the lastest stable release 1.8.0, won't I just run into the same dependency issues I'm having with 1.7.2?
Temporary Saint
 
Posts: 11
Joined: 2010-03-25 15:09

Re: C complier?

Postby bugsbunny » 2010-04-07 20:21

I wasn't suggesting you directly install the package from sid (unless you want to upgrade to squeeze). I just mentioned it because of what Steve had said about a git pull. You now have Debianized sources for 1.8 available in sid, which can be used as the basis of a backport if someone is so inclined.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

PreviousNext

Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable