Backports issue

New to Debian (Or Linux in general)? Ask your questions here!

Backports issue

Postby hencethus » 2010-04-10 00:05

I'm new to Debian, but have used Ubuntu so I'm relatively familiar with APT. Ubuntu doesn't have backports, though, and I can't figure this out. I've checked the documentation for the answer, and I'm hoping that I'm just overlooking something simple.

I'm running lenny, and I want to install the Empathy instant messenger that's in lenny-backports (v. 2.26.2-1). I already have the stable package installed, and here's what happens when I try to upgrade:

Code: Select all
michael@archimedes:~$ sudo apt-get -t lenny-backports install empathy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
empathy is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 118 not upgraded.


I don't have the lenny-backports package, though:
Code: Select all
michael@archimedes:~$ dpkg -l empathy
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name            Version         Description
+++-===============-===============-==============================================
ii  empathy         0.23.3-3        High-level library and user-interface for Tele


Here's my /etc/apt/sources.list:
Code: Select all
# deb http://ftp.us.debian.org/debian/ lenny main

deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny main contrib non-free

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

deb http://www.backports.org/debian lenny-backports main contrib non-free


And here's my etc/apt/preferences:
Code: Select all
Package: *
Pin: release a=lenny-backports
Pin-Priority: 200


Thanks in advance! :)
hencethus
 
Posts: 4
Joined: 2010-04-09 23:41

Re: Backports issue

Postby Absent Minded » 2010-04-10 00:23

okay, try this instead:

Code: Select all
apt-get -t http://www.backports.org/ install empathy
Serving the community the best way I can.
Spreading the tradition of Community Spirit.
Please read some Basic Forum Philosophy
Give a man a fish, he eats for a day. Teach him how to fish, he eats for life.
Updated Nov. 19, 2012
User avatar
Absent Minded
 
Posts: 3757
Joined: 2006-07-09 08:50
Location: Washington State U.S.A.

Re: Backports issue

Postby hencethus » 2010-04-10 00:29

Absent Minded wrote:okay, try this instead:

Code: Select all
apt-get -t http://www.backports.org/ install empathy

Code: Select all
michael@archimedes:/etc/apt$ sudo apt-get -t http://www.backports.org/ install empathy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
empathy is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Same.

EDIT: Oh, geez. I think I figured it out. I didn't notice that there's no AMD64 build in lenny-backports. Sorry. :(
hencethus
 
Posts: 4
Joined: 2010-04-09 23:41


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable