[Solved?] Not really broken packages

New to Debian (Or Linux in general)? Ask your questions here!

[Solved?] Not really broken packages

Postby sjukfan » 2010-04-10 05:31

I installed the 64 bit version of VLC from here and it works fine after I installed the backport libasound2. But... now I get
Code: Select all
$ sudo aptitude safe-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information     
Initializing package states... Done
Reading task descriptions... Done 
The following packages have unmet dependencies:
  lib32asound2: Depends: libasound2 (= 1.0.16-2) but 1.0.22-2~bpo50+2 is installed.

and if I run aptitude -f install it wants to remove vlc, or flashplayer-mozilla and wine. What are you supposed to do in a situation like that?
Last edited by sjukfan on 2010-04-11 20:25, edited 2 times in total.
Buster amd64, Core 2 Quad Q9550
Buster amd64, Intel Xeon E3-1240 v3
Sid ppc, PowerPC 7447a
Sid ppc64, PowerPC 970FX
User avatar
sjukfan
 
Posts: 385
Joined: 2010-03-01 19:39

Re: Not really broken packages

Postby nadir » 2010-04-10 06:21

search for a higher version of that package, in that case in backports
http://packages.debian.org/lenny-backports/lib32asound2
if that doesn't work i let it remove whatever it wants to remove and re-install it. If re-installing doesn't work i search for a replacement.
That's the way which is rather amateur-like, but i seldom got problems with package-management.
"I am not fine with it, so there is nothing for me to do but stand aside." M.D.
User avatar
nadir
 
Posts: 5964
Joined: 2009-10-05 22:06
Location: away

Re: Not really broken packages

Postby barriehie » 2010-04-10 08:23

nadir wrote:...muted...
if that doesn't work i let it remove whatever it wants to remove and re-install it. If re-installing doesn't work i search for a replacement.
That's the way which is rather amateur-like, but i seldom got problems with package-management.


And when you get a really long list of what it wants to uninstall I copy the screen into vim so I can make a script to install it all back... Plus have a record to restore if it doesn't work.
barriehie
 

Re: Not really broken packages

Postby Soul Singin' » 2010-04-10 17:29

Try this:
Code: Select all
apt-get install -t lenny-backports lib32asound2
.
User avatar
Soul Singin'
 
Posts: 1542
Joined: 2008-12-21 07:02

Re: Not really broken packages

Postby sjukfan » 2010-04-10 17:44

Then I get a
Code: Select all
The following packages have unmet dependencies:
    lib32asound2: PreDepends: libc6-i386 (>= 2.9-18) but 2.7-18lenny2 is to be installed
    Conflicts: libc6-i386 (<= 2.9-18) but 2.7-18lenny2 is to be installed

Haven't found a later libc6-i386. Or well... there's one in unstable but I feel I'm way too much of a noob to experiment with that
Buster amd64, Core 2 Quad Q9550
Buster amd64, Intel Xeon E3-1240 v3
Sid ppc, PowerPC 7447a
Sid ppc64, PowerPC 970FX
User avatar
sjukfan
 
Posts: 385
Joined: 2010-03-01 19:39

Re: Not really broken packages

Postby stevepusser » 2010-04-11 04:42

Something is wrong there--Lenny Backports does not build against a newer libc6. It appears the the backporter forgot to change the Pre-Depends line in /debian/control when backporting the package from upstream...it's just a text setting, the package building tools don't automatically determine that like most of the Depends. You could file a bug against it...or backport the package yourself, or I could get around to it, but am extremely busy with the new Mepis 8.5 community repo...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.48.0, QMPlay2 19.09.03, wine-staging 4.16, Telegram-desktop 1.8.8, Pale Moon 28.7.1, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11097
Joined: 2009-10-06 05:53

Re: Not really broken packages

Postby sjukfan » 2010-04-11 10:16

There, now I've bugreported it.
Buster amd64, Core 2 Quad Q9550
Buster amd64, Intel Xeon E3-1240 v3
Sid ppc, PowerPC 7447a
Sid ppc64, PowerPC 970FX
User avatar
sjukfan
 
Posts: 385
Joined: 2010-03-01 19:39

Re: [Solved?] Not really broken packages

Postby sjukfan » 2010-04-11 20:26

And I got this reply

This is hard-coded into the control file; see the following bug for the
reasoning:

http://bugs.debian.org/533005

> > According to a user on the forum "Something is wrong there--Lenny
> > Backports does not build against a newer libc6."
> >
> > I'm using Lenny with backports
> >
I've built a bpo that removes the pre-depends/conflicts; however, a)
it's for i386 (and I'm assuming you're using amd64?), and b) I have no
idea if it'll explode w/ lenny's glibc. Feel free to test it and
report back, though. If it works and the change is safe, I'll go ahead
and upload to bpo. If it doesn't work or is somehow unsafe (and I've
hopefully cc'd the relevant alsa-lib folks), we'll have to
either live without multiarch support for the bpo or get a proper fix
together for it.

http://dev.queued.net/~dilinger/alsa-lib-bpo/

Buster amd64, Core 2 Quad Q9550
Buster amd64, Intel Xeon E3-1240 v3
Sid ppc, PowerPC 7447a
Sid ppc64, PowerPC 970FX
User avatar
sjukfan
 
Posts: 385
Joined: 2010-03-01 19:39


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable