python 2.6.4 on etch 4

New to Debian (Or Linux in general)? Ask your questions here!

python 2.6.4 on etch 4

Postby tank junior » 2010-04-15 06:49

Hi,

I was able to compile python 2.6.5 on debian 4 etch successfully. The contents of /usr/share/python/python_defaults are now like this:
Code: Select all
[DEFAULT]
# the default python version
default-version = python2.6
# all supported python versions
supported-versions = python2.4 python2.6
# formerly supported python versions
old-versions = python2.3
# unsupported versions, including older versions
unsupported-versions = python2.3, python2.5


Typing "python" on terminal now starts the correct version which is 2.6.5.
The next thing I installed wxPython from wxWidgets repository. I followed the instruction explained here:

http://wiki.wxpython.org/InstallingOnUbuntuOrDebian

When installation was about to finish, I got this error:
Code: Select all
Setting up python-wxgtk2.8 (2.8.10.1-0) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1373, in ?
    main()
  File "/usr/bin/pycentral", line 1367, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 870, in run
    requested = pyversions.requested_versions_for_runtime(pkg.version_field, version_only=Tru         e)
  File "/usr/share/pycentral-data/pyversions.py", line 186, in requested_versions_for_runtime
    raise ValueError, 'empty set of versions'
ValueError: empty set of versions
dpkg: error processing python-wxgtk2.8 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-wxtools:
 python-wxtools depends on python-wxgtk2.8; however:
  Package python-wxgtk2.8 is not configured yet.
dpkg: error processing python-wxtools (--configure):
 dependency problems - leaving unconfigured
Setting up wx2.8-i18n (2.8.10.1-0) ...
Errors were encountered while processing:
 python-wxgtk2.8
 python-wxtools


I am sure something I have missed something before installing wxPython. It seems it's related to "python_defaults", but I am not sure.


Cheers

prashant
tank junior
 
Posts: 4
Joined: 2010-04-14 17:31

Re: python 2.6.4 on etch 4

Postby nadir » 2010-04-15 08:19

I had a similar problem here:
viewtopic.php?f=19&t=48911#p281075
This bug:
http://bugs.debian.org/cgi-bin/bugrepor ... =%23566961
But it is a different version. Just check.
"I am not fine with it, so there is nothing for me to do but stand aside." M.D.
User avatar
nadir
 
Posts: 5964
Joined: 2009-10-05 22:06
Location: away

Re: python 2.6.4 on etch 4

Postby tank junior » 2010-04-15 12:53

Is this solved or still broken? I need to solve this issues ASAP.

Prashant
tank junior
 
Posts: 4
Joined: 2010-04-14 17:31

Re: python 2.6.4 on etch 4

Postby bugsbunny » 2010-04-15 13:16

You're going to have to solve this one on your own. See what the code is doing based on the error messages. It may have something to do with the fact that you're running a version of python that etch isn't expecting to see and has no knowledge of (total guess on my part). See what pycentral is actually doing.

You're not going to get any patches for etch, ever. And IF the error is in the python-wxgtk2.8 then you'll have to fix it yourself as well. You may well have to build wxwidgets since the page at InstallingOnUbuntuOrDebian - wxPyWiki specifically states that the only Python version supported on etch is 2.4

If you want to run unsupported configurations then you have to be willing/able to deal with such issues. You may be able to get some help to guide you at wxWidgets Discussion Forum :: Index or Mailing Lists/IRC chat - wxWidgets
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable