nfs-common and dpkg errors

New to Debian (Or Linux in general)? Ask your questions here!

nfs-common and dpkg errors

Postby Kim » 2011-06-28 21:21

Hello,

Could you help me?

I am a newbie

I have Debian 6.0.2 / 64 bits installed on a VPS.

I cannot install any package because of this error:


Code: Select all

Setting up nfs-common (1:1.2.2-4) ...
insserv: Service portmap has to be enabled to start service nfs-common
insserv: exiting now!
update-rc.d: error: insserv rejected the script header

dpkg: error processing nfs-common (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 nfs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)


How can I fix the dpkg and insserv problem?

Thanks for your help
Kim
 
Posts: 2
Joined: 2011-06-28 21:15

Re: nfs-common and dpkg errors

Postby nilssn » 2011-06-28 21:29

I think rpcbind is preferred over portmap lately.
You could try to purge portmap and install rpcbind.
nilssn
 
Posts: 54
Joined: 2010-04-26 17:28

Re: nfs-common and dpkg errors

Postby mynis » 2011-11-28 15:03

Here's what I did to resolve this conflict in squeeze with backports kernel:
Code: Select all
sudo apt-get install nfs-common
sudo apt-get install portmap
sudo apt-get install nfs-common


My guess is that by default a config file for the nfs client still points to portmap even though apt uninstalls portmap when you install nfs-common. Somehow doing this cleared up the problem, at least for me.
mynis
 
Posts: 2
Joined: 2010-05-19 01:49

Re: nfs-common and dpkg errors

Postby thibdevan » 2012-01-29 09:47

Hi,
I've solved this "nfs-common error(1) by doing this :
apt-get remove nfs-common
apt-get remove portmap
apt-get install portmap
apt-get install nfs-common

Hope that help.

Thibault
thibdevan
 
Posts: 1
Joined: 2012-01-29 09:44

Re: nfs-common and dpkg errors

Postby smfi » 2012-08-29 17:34

hi there,

i am hyper noob and have the same error. what do i have to do to be able to run apt-get?

my problem is: the console is locked. strg+c doesnt helpt and does not give me a console, therefore, i guess i need a debian cd and then do changeroot, or is my guess totally wrong?

edit: i am not sure whether i am right at this thread: http://i.imgur.com/LmOhc.jpg
smfi
 
Posts: 1
Joined: 2012-08-29 17:33


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable