HP Inkjet driver dependency issue

Kernels & Hardware, configuring network, installing services

HP Inkjet driver dependency issue

Postby Ramius » 2017-11-09 17:53

Running Deb 9.2 latest Gnome 3 and HP driver hpcups 3.16.11 +repack0-3.

I'm trying to update to hplip 3.17.6 ( I have issues with photo banding )

I get dependency errors --> pyqt4-dbus , pyqt4 , pyqt5-dbus and pyqt5

I have tried in vain to find the packages these files belong to.

Any help would be appreciated , Thanks Bob
The manual said to install Windows Vista or better...
So I installed Debian.
Ramius
 
Posts: 89
Joined: 2006-11-17 23:47
Location: Kelowna BC Canada

Re: HP Inkjet driver dependency issue

Postby srq2625 » 2017-11-09 20:39

Go here for the dependencies

https://developers.hp.com/hp-linux-imag ... ros/debian

Also, install python-dev (needed but not listed on that page).

Now, execute the install script.
srq2625
 
Posts: 41
Joined: 2016-02-26 11:01

Re: HP Inkjet driver dependency issue

Postby Ramius » 2017-11-09 21:30

Thanks for the reply.

python-dev is already installed

The site you pointed to I've already looked at, it only indicates Dedian 5 and 6.

Is there something I'm missing on that site ?? Bob
The manual said to install Windows Vista or better...
So I installed Debian.
Ramius
 
Posts: 89
Joined: 2006-11-17 23:47
Location: Kelowna BC Canada

Re: HP Inkjet driver dependency issue

Postby srq2625 » 2017-11-10 12:54

My bad - I was working from my phone and I thought that was the page. Looking now, I can't find the page I used for instructions. But, my terminal history has the answer (of course, there's a chance some of these are already installed in which case - no harm, no foul):
Code: Select all
su -c "apt-get install --force-yes -y avahi-utils cups libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev libdbus-1-dev g++ ghostscript ghostscript-cups ghostscript-x libssl-dev libjpeg62-turbo-dev libsnmp-dev snmp libc6 libtool libtool-bin libusb-1.0.0-dev make wget policykit-1 policykit-1-gnome python3-dbus python3-gi python3-dev python3-notify2 python3-pil python3-pyqt4 gtk2-engines-pixbuf python3-dbus.mainloop.qt python3-reportlab python3-lxml sane libsane-dev sane-utils xsane"

This wasn't on my computer after a fresh install
Code: Select all
sudo apt-get install python-dev

Un-compress the download and cd to the result
Code: Select all
tar xf ./hplip-3.17.10.tar.gz
cd hplip-3.17.10/ 

Do the configure, make and make-install
Code: Select all
./configure --prefix=/usr --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib/x86_64-linux-gnu --enable-qt4 --enable-hpcups-install --enable-cups-drv-install --disable-cups-ppd-install --disable-hpijs-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-foomatic-rip-hplip-install --enable-fax-build --enable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --disable-libusb01_build --disable-udev_sysfs_rules --enable-doc-build
make
su -c "make install"

If you have a scanner, you might need to do this
Code: Select all
su hp-plugin

On another machine, I installed the dependencies and simply ran the "automated script" - turns out they do exactly the same thing.
srq2625
 
Posts: 41
Joined: 2016-02-26 11:01

Re: HP Inkjet driver dependency issue

Postby Ramius » 2017-11-11 16:32

I appreciate all your help but it is still a "no go" . I tried manual and auto build.

This is the error the auto build gives me:

error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: A required dependency 'pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)' is still missing.
error: A required dependency 'pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

I see that 3.17.11 is in the works, so I will try it.

Thanks again Bob
The manual said to install Windows Vista or better...
So I installed Debian.
Ramius
 
Posts: 89
Joined: 2006-11-17 23:47
Location: Kelowna BC Canada

Re: HP Inkjet driver dependency issue

Postby Ramius » 2017-11-13 16:26

It seems that Debian 9.2 is not supported by hplip.

What are the ramifications of installing hplip (3.17.10+repack0-1) from buster repository ??

Bob.
The manual said to install Windows Vista or better...
So I installed Debian.
Ramius
 
Posts: 89
Joined: 2006-11-17 23:47
Location: Kelowna BC Canada


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable