Disable search for swap

Kernels & Hardware, configuring network, installing services

Disable search for swap

Postby djevil » 2017-12-05 19:41

Hello,
I have cloned my OS from HD to SSD and I did not create a swap partition.
I have 8gb Ram and a 60gb SSD, so i probably need no swap. I would like to have more space for OS and apps.

However, on boot it searches 30 secs for swap.

How can I disable this?

There is no entry for swap in fstab and I disabled the only service concerning swap: swap.target or something similar.

Regards d
djevil
 
Posts: 7
Joined: 2017-09-18 13:36

Re: Disable search for swap

Postby pylkko » 2017-12-05 21:26

can you provide output from
Code: Select all
 systemctl --type swap
User avatar
pylkko
 
Posts: 1213
Joined: 2014-11-06 19:02

Re: Disable search for swap

Postby p.H » 2017-12-05 22:34

Maybe the initramfs searches the swap for a resume image. By the way note that no swap = no hibernation.
Check in /etc/initramfs-tools/conf.d/resume. If it contains an identifier of the original swap device, remove it and rebuild the initramfs with
Code: Select all
update-initramfs -u
p.H
 
Posts: 177
Joined: 2017-09-17 07:12

Re: Disable search for swap

Postby debiman » 2017-12-06 10:03

maybe comment out swap in /etc/fstab?
User avatar
debiman
 
Posts: 1619
Joined: 2013-03-12 07:18

Re: Disable search for swap

Postby p.H » 2017-12-06 11:52

djevil wrote:There is no entry for swap in fstab
p.H
 
Posts: 177
Joined: 2017-09-17 07:12

Re: Disable search for swap

Postby djevil » 2017-12-06 20:29

@p.H.

Easy and perfect solution. Thanks!
djevil
 
Posts: 7
Joined: 2017-09-18 13:36


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable