{SOLVED} kernel error in drm_kms_helper, flip_done timed out

Kernels & Hardware, configuring network, installing services

{SOLVED} kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-08 08:25

There are many different solutions for this in google but nothing works and are not for Debian..
While starting my machine I get 2 problems:

1. Flip done time out
2. Time difference

I have windows 7 in dual boot on different hard disk space. The time and date on my Debian, Windows 7 and BIOS are same.

Error 1: {48.695823} drm:drm_automic_helper_wait_for_dependencies {drm_kms_helper}} *Error* {connector:50:svideo-1} flip_done time out

Error 2: Superblock last mount time is in the future. {by less than a day, probably due to hardware clock being incorrectly set}
clean, 188644/8151040 files, 17958064/32583168 blocks

This error was with Debian 9 Stretch and now I have upgraded to Debian 10 testing but the problem is still there
Please help.
Last edited by intellinux420 on 2019-04-15 13:40, edited 1 time in total.
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23

Re: kernel error in drm_kms_helper, flip_done timed out

Postby Head_on_a_Stick » 2019-02-08 10:15

Either set Debian to use localtime or set Windows to use UTC.
User avatar
Head_on_a_Stick
 
Posts: 10330
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-09 18:05

Head_on_a_Stick wrote:Either set Debian to use localtime or set Windows to use UTC.


I did it but same problem.
I also changed both windows and Debian to UTC but no luck
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23

Re: kernel error in drm_kms_helper, flip_done timed out

Postby Head_on_a_Stick » 2019-02-09 18:15

I would have a go at you for not searching the error message but I didn't bother myself for the last post so...

https://bbs.archlinux.org/viewtopic.php?id=218581&p=3
User avatar
Head_on_a_Stick
 
Posts: 10330
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-10 03:52

Head_on_a_Stick wrote:I would have a go at you for not searching the error message but I didn't bother myself for the last post so...

https://bbs.archlinux.org/viewtopic.php?id=218581&p=3


I should have mentioned before
Things I already tried:

1. Adding
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d
to my grub.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

2. Removed
Code: Select all
xserver-xorg-video-intel


3. Reinstalled the grub

4. xf86-video-intel is not installed on my system.

After every step I updated and rebooted my system.
Nothing is working.

About my system:
Linux debian 4.19.0-2-amd64 #1 SMP Debian 4.19.16-1 (2019-01-17) x86_64 GNU/Linux

Hardware:
H/W path Device Class Description
==========================================================
system Inspiron 1420
/0 bus 0DT492
/0/0 memory 64KiB BIOS
/0/400 processor Intel(R) Core(TM)2 Duo CPU T5550 @ 1.83GHz
/0/400/700 memory 32KiB L1 cache
/0/400/701 memory 2MiB L2 cache
/0/1000 memory 2GiB System Memory
/0/1000/0 memory 1GiB DIMM DDR Synchronous 667 MHz (1.5 ns)
/0/1000/1 memory 1GiB DIMM DDR Synchronous 667 MHz (1.5 ns)
/0/100 bridge Mobile PM965/GM965/GL960 Memory Controller Hub
/0/100/2 display Mobile GM965/GL960 Integrated Graphics Controller (primary)
/0/100/2.1 display Mobile GM965/GL960 Integrated Graphics Controller (secondary)
/0/100/1a bus 82801H (ICH8 Family) USB UHCI Controller #4
/0/100/1a/1 usb1 bus UHCI Host Controller
/0/100/1a/1/2 bus BCM2045B2
/0/100/1a/1/2/1 communication BCM2045
/0/100/1a/1/2/2 input Keyboard (Boot Interface Subclass)
/0/100/1a/1/2/3 input Mouse (Boot Interface Subclass)
/0/100/1a.1 bus 82801H (ICH8 Family) USB UHCI Controller #5
/0/100/1a.1/1 usb2 bus UHCI Host Controller
/0/100/1a.7 bus 82801H (ICH8 Family) USB2 EHCI Controller #2
/0/100/1a.7/1 usb6 bus EHCI Host Controller
/0/100/1b multimedia 82801H (ICH8 Family) HD Audio Controller
/0/100/1c bridge 82801H (ICH8 Family) PCI Express Port 1
/0/100/1c.1 bridge 82801H (ICH8 Family) PCI Express Port 2
/0/100/1c.1/0 wlp12s0 network PRO/Wireless 3945ABG [Golan] Network Connection
/0/100/1c.3 bridge 82801H (ICH8 Family) PCI Express Port 4
/0/100/1c.5 bridge 82801H (ICH8 Family) PCI Express Port 6
/0/100/1c.5/0 enp9s0 network NetLink BCM5906M Fast Ethernet PCI Express
/0/100/1d bus 82801H (ICH8 Family) USB UHCI Controller #1
/0/100/1d/1 usb3 bus UHCI Host Controller
/0/100/1d.1 bus 82801H (ICH8 Family) USB UHCI Controller #2
/0/100/1d.1/1 usb4 bus UHCI Host Controller
/0/100/1d.2 bus 82801H (ICH8 Family) USB UHCI Controller #3
/0/100/1d.2/1 usb5 bus UHCI Host Controller
/0/100/1d.7 bus 82801H (ICH8 Family) USB2 EHCI Controller #1
/0/100/1d.7/1 usb7 bus EHCI Host Controller
/0/100/1d.7/1/6 multimedia Laptop Integrated Webcam
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/1 bus R5C832 IEEE 1394 Controller
/0/100/1e/1.1 generic R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
/0/100/1e/1.2 generic R5C592 Memory Stick Bus Host Adapter
/0/100/1e/1.3 generic xD-Picture Card Controller
/0/100/1f bridge 82801HM (ICH8M) LPC Interface Controller
/0/100/1f.1 storage 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller
/0/100/1f.2 scsi2 storage 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode]
/0/100/1f.2/0.0.0 /dev/sda disk 500GB ST500LT012-1DG14
/0/100/1f.2/0.0.0/1 /dev/sda1 volume 75GiB Windows NTFS volume
/0/100/1f.2/0.0.0/2 /dev/sda2 volume 124GiB EXT4 volume
/0/100/1f.2/0.0.0/3 /dev/sda3 volume 265GiB Windows NTFS volume
/0/100/1f.3 bus 82801H (ICH8 Family) SMBus Controller
/0/1 input PnP device PNP0f13
/0/2 input PnP device PNP0303
/0/3 system PnP device PNP0b00
/0/4 system PnP device PNP0c01
/0/5 system PnP device PNP0103
/0/6 system PnP device PNP0c01
/0/7 system PnP device PNP0c01
/0/8 system PnP device PNP0c01
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23

Re: kernel error in drm_kms_helper, flip_done timed out

Postby Head_on_a_Stick » 2019-02-10 11:43

intellinux420 wrote:Reinstalled the grub

Was the configuration file updated and is that configuration file being used?

Check with
Code: Select all
cat /proc/cmdline
User avatar
Head_on_a_Stick
 
Posts: 10330
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-11 11:05

Head_on_a_Stick wrote:
intellinux420 wrote:Reinstalled the grub

Was the configuration file updated and is that configuration file being used?

Check with
Code: Select all
cat /proc/cmdline


Thanks for the reply

The result of the code is
Code: Select all
BOOT_IMAGE=/boot/vmlinuz-4.19.0-2-amd64 root=UUID=5abd6e6f-d573-45b5-a51f-4c65166686e8 ro quiet


After making changes to gurb, I did not update it. I used
Code: Select all
update-grub

and got
Code: Select all
bash: update-grub: command not found


Then I found that my system is missing .bash_profile.
Then I used gedit in my home directory to open .bash_profile and a notepad opened but it was totally empty.

Does .bash_profile be empty ?
(My system has GNU bash, version 5.0.2(1)-release (x86_64-pc-linux-gnu). I checked and bash is working).

So basically I am not able to update GRUB because of this .bash_profile and without updating GRUB, the flip done time out error will not go away.

Any suggestion....

Thanks in advance.
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23

Re: kernel error in drm_kms_helper, flip_done timed out

Postby Head_on_a_Stick » 2019-02-11 12:54

Debian uses ~/.profile instead because it applies to all shells and not just bash.

The `update-grub` wrapper script is in /usr/sbin, which is not in your normal user's PATH (and cannot be run without root privileges anyway) so use either
Code: Select all
su -
update-grub

or
Code: Select all
sudo update-grub
User avatar
Head_on_a_Stick
 
Posts: 10330
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-11 15:37

I was using just su and not su -. After using su - and the password I was able to do update-grub but then this problem came:
Code: Select all
unexpected EOF while looking for matching ``'

I removed `` from that particular line and try to update grub again. Same problem came with different line.

I installed grub-coreboot from synaptic package manager and rebooted the system. Flip done time out error was still there and the grub file from /etc/default was missing.
Then I uninstalling grub-coreboot, and installed grub-pc which got the grub file back in etc/default.
Finally I added svideo in grub and updated grub using su - followed by update-grub.
This fixed the long and annoying flip done time out error.

Thanks a lot again :D :D :D

Any suggestions for the super block time error.
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23

Re: kernel error in drm_kms_helper, flip_done timed out

Postby bw123 » 2019-02-11 15:52

intellinux420 wrote:...

Any suggestions for the super block time error.


"last mount in future" errors are a common annoyance when dual booting. Don't set the time from the os, use the bios and set it to UTC, and if windows (still!?) can't handle UTC then allow windows to have the wrong time and (somehow) keep it from setting the clock. On older winn ver I just tell it I am in a UTC timezone.

p.s. once it is setup, I do allow systemd-timesyncd to keep current, it's a very reliable little gadget.
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: kernel error in drm_kms_helper, flip_done timed out

Postby Head_on_a_Stick » 2019-02-11 18:48

intellinux420 wrote:I also changed both windows and Debian to UTC but no luck

Did you remember to disable the "internet update" for the time in Windows?

I think Windows may reset to localtime after updates so you may have to set a batch file to run at every boot and correct this (that's what I do).

To enable systemd-timesyncd in Debian use
Code: Select all
timedatectl set-ntp on

To set the hardware clock from the system time in Debian run
Code: Select all
# hwclock --systohc
User avatar
Head_on_a_Stick
 
Posts: 10330
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kernel error in drm_kms_helper, flip_done timed out

Postby intellinux420 » 2019-02-12 14:58

Thank you all for helping me. These 2 problems were really irritating which are fixed now.

For the time error:
I did put windows, BIOS and Debian on UTC but after restarting the problem was still there.

I removed the battery and the charging cord for 10 hours and the next day I restarted the system and the problem was fixed.

I use Windows 7 Home edition Sp 3. I only use windows for iTunes and bit-locker. I can access the bit-locker locked external hard disk (using unlock.sh) on Debian but can not copy, paste, delete anything.
I never update windows 7 and I have changed all setting also. I do not even connect windows to internet.
intellinux420
 
Posts: 18
Joined: 2018-11-14 09:23


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable