Built and installed a kernel that does not boot.

Kernels & Hardware, configuring network, installing services

Built and installed a kernel that does not boot.

Postby utilityitc » 2020-01-14 15:55

++ KERNEL BOOT PROBLEM

I have managed to build and install a kernel that does not boot.

I am compiling a new kernel to get support for an IOMEGA ZIP drive connected to the parallel port of this system. That is the entire point of the installation: there are archive files on a set of ZIP disks that my organization needs to access. I do believe that compiling a new kernel is the only way to access this drive.

Before a get into the details of my problem, let me ask this question: Can I use the modules that I compiled for the 4.19.94 kernel in the 4.19.0-6-686-pae kernel installed orignally that does boot?

Here are the details:

I installed Debian 10.2 with kernel version 4.19.0-6-686-pae on this system:

Processor: Intel Core 2 Quad CPU Q6600
Memory: 3.7 GB
Hard Drive: 148.8 GB
Graphics Card: Intel Corporation 4 Series Chipset Integrated Graphics Controller

I was able to compile and install the kernel, sources downloaded from kernel.org, which is kernel version 4.19.94. Note the lack of additional modifiers on the kernel version.

Upon rebooting the system, the following happens:

1. GRUB screen is presented. I select the first choice: Debian GNU/Linux

2. I see the following messages in a graphical mode:
Loading Linux 4.19.94...
Loading initial ramdisk..

3. The graphical screen clears to a black character mode screen, with a flashing cursor on the upper left corner.
4. I never see any kernel messages or boot messages. The screen display mode never switches out of character mode and into the customary "graphic text" mode.
5. The 4.19.94 recovery option also fails to boot in the very same way.


I have tried the following:

1. Compiled libata into the kernel statically.

2. Tried to display kernel messages by editing the GRUB2 config during boot by the following:

Reference: https://wiki.archlinux.org/index.php/General_troubleshooting#Debugging_kernel_modules

2.1 Remove the "quiet" parameter from the "linux" line in GRUB config.
2.2 Add "verbose" parameter to the "linux" line in the GRUB config.
2.3 Add "debug" parameter to the "linux" line in the GRUB config.
2.4 Add "ignore_loglevel" to the linux load line in the GRUB config.
2.5 Add "systemd.journald.forward_to_console=1 console=tty1" to the "linux" load line in GRUB.
2.6 Add "oops=panic" to the "linux" load line in GRUB.

I NEVER saw any kernel messages no matter what I tried. That seems to indicate a problem occurring very early in the boot process.

3. Searching Google found amny conditions that seemed similar to mine. I tried to edit parameters during GRUB boot:
3.1 Add the "acpi=off" to the "linux" load line in GRUB config.
3.2 Add the "noapic" parameter to the "linux" load line in the GRUB config.
3.3 Added the parameters "noapic nolapic acpi=off" to the "linux" load line in the GRUB config.

3. Ctrl-Alt-Del does not recover from the hang condition. A hard reset is required.

Since this is happening with a kernel I compiled, the most likely problem was with my build process itself. I followed this method:

https://www.cyberciti.biz/tips/compiling-linux-kernel-26.html

Following the steps for Debian distributions.

So, what incredibly simple step did I overlook in building my kernel?
utilityitc
 
Posts: 1
Joined: 2020-01-10 20:11

Re: Built and installed a kernel that does not boot.

Postby Head_on_a_Stick » 2020-01-14 17:38

Does the kernel in the buster-backports repository support your device?

If not then this may be of use: https://kernel-team.pages.debian.net/kernel-handbook/

FWIW, it sounds like you haven't added support for your video card but I'm no expert at kernel configuration.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12290
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Built and installed a kernel that does not boot.

Postby stevepusser » 2020-01-14 21:29

Did you change anything in the kernel configuration to support that old zip drive? If so, perhaps you could rebuild the current Debian kernel from its source with that config, though that needs about 50 GB of free drive space.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0~rc2, QMPlay2 20.07.04, Pale Moon 28.11.0, KeepassXC 2.6.0, Krita 4.3.0, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11878
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable