ACPI errors on fresh install cause nic failure

Kernels & Hardware, configuring network, installing services

ACPI errors on fresh install cause nic failure

Postby currybadger » 2020-02-16 17:03

Just installed 10.3 on a Dell Latitude E7440. Aiming to redeploy it from an ESXi host to Proxmox. I'm installing Debian first as this gives me more control over partitions (I have an SSD and an MSATA installed).

Installation runs fine, but then I see ACPI errors on the screen.
Here's the relevant section of the dmesg output.


[ 5.880910] ACPI Error: Index value 0x0000000000000083 overflows field width 0x7 (20190703/exfldio-309)
[ 5.880978]
Initialized Local Variables for Method [NEVT]:
[ 5.880979] Local0: 00000000663c1537 <Obj> Integer 0000000000000180
[ 5.880986] Local1: 00000000822e6f8e <Obj> Integer 0000000000000000
[ 5.880991] No Arguments are initialized for method [NEVT]
[ 5.880995] ACPI Error: Aborting method \NEVT due to previous error (AE_AML_REGISTER_LIMIT) (20190703/psparse-531)
[ 5.881144] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_AML_REGISTER_LIMIT) (20190703/psparse-531)
[ 5.895847] audit: type=1400 audit(1581861165.559:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/lxc-start" pid=631 comm="apparmor_parser"
[ 5.922772] audit: type=1400 audit(1581861165.583:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=633 comm="apparmor_parser"
[ 5.923475] audit: type=1400 audit(1581861165.583:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=633 comm="apparmor_parser"
[ 5.957167] audit: type=1400 audit(1581861165.619:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=634 comm="apparmor_parser"
[ 5.957560] audit: type=1400 audit(1581861165.619:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=634 comm="apparmor_parser"
[ 5.958103] audit: type=1400 audit(1581861165.619:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=634 comm="apparmor_parser"
[ 6.142297] audit: type=1400 audit(1581861165.803:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lxc-container-default" pid=632 comm="apparmor_parser"
[ 6.142702] audit: type=1400 audit(1581861165.803:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lxc-container-default-cgns" pid=632 comm="apparmor_parser"
[ 6.143164] audit: type=1400 audit(1581861165.803:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lxc-container-default-with-mounting" pid=632 comm="apparmor_parser"
[ 6.143697] audit: type=1400 audit(1581861165.807:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lxc-container-default-with-nesting" pid=632 comm="apparmor_parser"
[ 6.195772] new mount options do not match the existing superblock, will be ignored
[ 6.207887] softdog: initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout=0)
[ 6.492114] bpfilter: Loaded bpfilter_umh pid 769
[ 12.443117] e1000e: eno1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 12.443150] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
[ 14.339885] ACPI Error: Index value 0x0000000000000083 overflows field width 0x7 (20190703/exfldio-309)
[ 14.339924]
Initialized Local Variables for Method [NEVT]:
[ 14.339925] Local0: 000000002cfa431b <Obj> Integer 0000000000000180
[ 14.339929] Local1: 0000000077131189 <Obj> Integer 0000000000000000
[ 14.339932] No Arguments are initialized for method [NEVT]
[ 14.339935] ACPI Error: Aborting method \NEVT due to previous error (AE_AML_REGISTER_LIMIT) (20190703/psparse-531)
[ 14.340010] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_AML_REGISTER_LIMIT) (20190703/psparse-531)


This error causes periodic failure of the on-board ethernet NIC, thus making this pretty useless as a headless server platform.

I've tried 10.2, 10.3 and 9.0 installers, all with the same result.
I have seen a few results from an Internet search, but most have no documented solution, or
Any ideas on how to fix?
currybadger
 
Posts: 2
Joined: 2020-02-14 22:58

Re: ACPI errors on fresh install cause nic failure

Postby stevepusser » 2020-02-17 02:22

Do the errors show if you upgrade to a 5.4 kernel from backports, or try booting a Live session of some distro with a later kernel?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Strawberry 0.6.11, Muse 3.1.0, Chromium with va-api, Audacity 2.4.1, Kdenlive 20.04
User avatar
stevepusser
 
Posts: 11692
Joined: 2009-10-06 05:53

Re: ACPI errors on fresh install cause nic failure

Postby Chrisdb » 2020-02-17 09:11

You can also try and update your bios if this is possible
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Re: ACPI errors on fresh install cause nic failure

Postby currybadger » 2020-02-17 17:24

Thanks for the input!

Note that the BIOS was updated as one thing to try, so it's already latest.
Seems however, that my diagnosis wasn't correct.
Coming from VMware to Debian/proxmox, I hadn't counted on some 'desktop-like' features being enabled. ESXi assumes you're going to run headless. Debian doesn't.

The issue was sleep mode - remember I'm using a laptop as a server.
1) Install Debian base.
2) SSH into it to check that works,
3) update, add the proxmox repos, and install.
4) go to make coffee, realise you've left the laptop open - close the lid to turn off the screen and when you get back the SSH session is dead.
5) Open it and nothing looks wrong. SSH works now. Assume network issues due to ACPI errors.

I eventually caught it in the act and put cause and effect together, so turned off all sleep triggers.

Thanks for the time, guys, but all seems well now in that the errors show, but do not seem to actually cause an issue in operation.

Note for anyone reading this with the same issues.
See https://wiki.debian.org/Suspend

Command to disable all suspend functions:
> sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
currybadger
 
Posts: 2
Joined: 2020-02-14 22:58


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable