proplems after using jessie respo

Kernels & Hardware, configuring network, installing services

proplems after using jessie respo

Postby A7med-3dly » 2013-12-10 09:29

hi all
i was using debain wheezy with gnome-classic then added jessie respo ""deb http://ftp.de.debian.org/debian jessie main"" to get lastet package update of gnome
after that i can't login normally with login page as it display the "oh no something has gone wrong" sreen
so i tried to update the whole system packges with
"apt-get upgrade"
but the same error

how i can fix this or going back before update

Note 'i can login by startx command in run levl6 but it start gnome-shell'
A7med-3dly
 
Posts: 2
Joined: 2013-12-10 08:59

Re: proplems after using jessie respo

Postby mor » 2013-12-10 10:27

There is a good chance that you have upgraded your whole system and are now running testing, if that is the case, no more stable for you.
Going back to stable from testing is in fact an endeavor not worth of its time and I'm pretty confident is out of your league.

To determine what's the status of your system post the output of the following commands:
Code: Select all
$ lsb_release -a

Code: Select all
$ cat /etc/apt/sources.list
also the content of any file that might be inside /etc/apt/sources.list.d/

And just to be really thorough:
Code: Select all
$ cat /etc/apt/preferences

Code: Select all
$ cat /etc/apt/apt.conf
They can all be run as regular user as the $ sign indicates.

Now, if you have indeed upgraded to testing, you can do two things:
  1. live with testing, roll up your sleeves and start digging through bug reports and manuals' lines
  2. backup everything and reinstall stable
Option b is the one I would personally recommend, running anything but stable is clearly not in your chords and although this means being stuck with Gnome 3.4 for quite a long time, it is better for you to stick to what's manageable.

If you choose option a, you will have to deal with testing from now on. Yes, you'll have the 3.8 version of Gnome and maybe in a not so distant future even the 3.10 version, but you'll also have to deal with all the breakage testing might bring along on a daily basis.
Problems like the one you are experiencing are the bread and butter of development versions, and although this one got you stuck, is really a simple thing to fix once you know which buttons to push.
But when you're running testing/unstable you won't get much hand-holding for issues that you could fix or understand just by reading around a bit, and helping you fix stuff like this won't do you any good in the long run with testing. Much better to help you get back on a stable system.

So, bottom line, post the output of the commands I listed above to see if your stable system can be restored, otherwise consider your options and keep in mind for the future the one thing you can learn from this: never, never, never mix stable with anything but stable (or backports).
User avatar
mor
 
Posts: 970
Joined: 2010-08-28 15:16
Location: mor@debian

Re: proplems after using jessie respo

Postby A7med-3dly » 2013-12-10 11:32

lsb_release -a
No LSB modules are available.
Distribution ID Debian
Description: Debian GNU/linux testing (unknown.new.testing)
Release : Testing
Codename: unknown.new.testing

and the sources.list
i disabled all respo before updating excep jessie one

but i can't find /etc/apt/apt.conf neither cat /etc/apt/preferences

and i thinking if i can downgrade the all system packages and remove jessie respo will fix theses problems or not
A7med-3dly
 
Posts: 2
Joined: 2013-12-10 08:59

Re: proplems after using jessie respo

Postby dasein » 2013-12-10 16:18

This happens a lot: someone decides that Testing is just a place that has newer packages, and blindly decides to mix-and-match.

The Wiki page you should have read before even attempting this operation states in part:
wiki.debian.org/DebianSoftware wrote:Attempting to "mix" releases, especially by updating your sources.list file, is a sure way to break your system.
Recovery in these cases usually involves restore from backup.
(Emphasis added)

And mor already told you that, even if a repair is theoretically possible, it's quite time-consuming and fraught with risk.

As mor suggested, your course is clear. Backup your personal data. Reinstall Stable. And never, ever mix-and-match repos again.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: proplems after using jessie respo

Postby lithopsian » 2013-12-10 17:06

Before going back to square one, you might try a dist-upgrade. That will take you all the way to jessie and may give you something a little more usable. It is called unstable for a reason, but at this point that refers to a relatively small number of not-so-horrible problems and it is perfectly possible to run a jessie system day to day. Whether you can get from here to there is a different matter, but certainly worth a try before throwing everything away.
lithopsian
 
Posts: 241
Joined: 2013-05-28 13:11


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable