my usb 3.0 stick only boots from a usb2 hub

Kernels & Hardware, configuring network, installing services

Re: my usb 3.0 stick only boots from a usb2 hub

Postby ELDebiano » 2015-12-17 14:36

kiyop wrote:Maybe you misunderstand what I asked.
I am confused :?
And tired :(

no no I meant to say it was not connected for module_before, but I realized a made a mistake in typing the commands, here is new information:

Code: Select all
new version of module_before http://paste.debian.net/348969/

Code: Select all
new modules_after http://paste.debian.net/348970/

Code: Select all
diff http://paste.debian.net/348973/

Code: Select all
cat of initramfs modules file http://paste.debian.net/348967/

lsmod of usb3 thumb drive loaded from usb2hub connected to usb3 port (I had to unplug everything from the hub to be able to boot from the hub something I don't need to do when connected to usb2 port.
Code: Select all
http://paste.debian.net/348966/


There it is, I did it right this time.
ELDebiano
 
Posts: 69
Joined: 2015-08-12 05:47

Re: my usb 3.0 stick only boots from a usb2 hub

Postby kiyop » 2015-12-18 14:57

I confirmed that the modules in http://paste.debian.net/348970/ are same as those in http://paste.debian.net/348969/.
By the way, please do not write like
ELDebiano wrote:
Code: Select all
new version of module_before http://paste.debian.net/348969/

I cannot move to the linked page if you write like the above.
Write like:
new version of module_before http://paste.debian.net/348969/
or directly:
Code: Select all
Module                  Size  Used by
cfg80211              405538  0
rfkill                 18867  1 cfg80211
cpufreq_userspace      12525  0
cpufreq_powersave      12454  0
cpufreq_conservative    14184  0
cpufreq_stats          12782  0
nfsd                  263032  2
auth_rpcgss            51211  1 nfsd
oid_registry           12419  1 auth_rpcgss
nfs_acl                12511  1 nfsd
nfs                   188136  0
lockd                  83389  2 nfs,nfsd
fscache                45542  1 nfs
sunrpc                237402  6 nfs,nfsd,auth_rpcgss,lockd,nfs_acl
joydev                 17063  0
k10temp                12618  0
edac_mce_amd           21166  0
edac_core              51465  0
kvm_amd                59131  0
kvm                   388635  1 kvm_amd
pcspkr                 12595  0
emu10k1_gp             12461  0
psmouse                99249  0
snd_emu10k1           148204  4
gameport               13449  2 emu10k1_gp
snd_util_mem           12747  1 snd_emu10k1
serio_raw              12849  0
snd_rawmidi            26806  1 snd_emu10k1
snd_seq_device         13132  2 snd_rawmidi,snd_emu10k1
snd_ac97_codec        118711  1 snd_emu10k1
snd_hda_codec_hdmi     45118  1
snd_hda_intel          26327  4
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  2 snd_hda_codec,snd_emu10k1
snd_pcm                88662  6 snd_ac97_codec,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_emu10k1,snd_hda_controller
sp5100_tco             12864  0
snd_timer              26614  2 snd_pcm,snd_emu10k1
snd                    65244  26 snd_ac97_codec,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_emu10k1,snd_seq_device
ac97_bus               12510  1 snd_ac97_codec
soundcore              13026  2 snd,snd_hda_codec
shpchp                 31121  0
i2c_piix4              20864  0
evdev                  17445  6
nuvoton_cir            17207  0
rc_core                22404  1 nuvoton_cir
acpi_cpufreq           17218  0
processor              28221  1 acpi_cpufreq
thermal_sys            27642  1 processor
vmhgfs                 65266  0
vmw_vmci               55383  1 vmhgfs
fuse                   83350  3
parport_pc             26300  0
ppdev                  16782  0
lp                     17074  0
parport                35749  3 lp,ppdev,parport_pc
autofs4                35529  2
ext4                  473802  1
crc16                  12343  1 ext4
mbcache                17171  1 ext4
jbd2                   82413  1 ext4
usb_storage            56215  2
hid_logitech           25801  0
ff_memless             12675  1 hid_logitech
hid_generic            12393  0
usbhid                 44460  0
hid                   102264  3 hid_generic,hid_logitech,usbhid
sg                     29973  0
sd_mod                 44356  3
crc_t10dif             12431  1 sd_mod
crct10dif_generic      12581  1
crct10dif_common       12356  2 crct10dif_generic,crc_t10dif
ata_generic            12490  0
ohci_pci               12808  0
xhci_hcd              148881  0
ohci_hcd               42982  1 ohci_pci
ehci_pci               12512  0
ehci_hcd               69837  1 ehci_pci
radeon               1345162  3
ahci                   33291  0
i2c_algo_bit           12751  1 radeon
libahci                27158  1 ahci
pata_atiixp            12747  0
ttm                    77862  1 radeon
r8169                  68262  0
mii                    12675  1 r8169
firewire_ohci          39523  0
drm_kms_helper         49210  1 radeon
libata                177457  4 ahci,libahci,ata_generic,pata_atiixp
firewire_core          56665  1 firewire_ohci
crc_itu_t              12347  1 firewire_core
scsi_mod              191405  4 sg,usb_storage,libata,sd_mod
drm                   249955  6 ttm,drm_kms_helper,radeon
usbcore               195340  7 usb_storage,ohci_hcd,ohci_pci,ehci_hcd,ehci_pci,usbhid,xhci_hcd
usb_common             12440  1 usbcore
i2c_core               46012  5 drm,i2c_piix4,drm_kms_helper,i2c_algo_bit,radeon
button                 12944  0

Really, your way irritates me. ;)

If the USB3 flash was not connected when you executed "lsmod > modules_before" while the debian installed in the USB2 flash (which was connected to the USB2 port) were booting, the necessary modules for the USB3 port are loaded before any USB3 media is connected to the USB3 port, and the necessary modules are in http://paste.debian.net/348969/

Add the following lines to /etc/initramfs-tools/modules:
Code: Select all
ohci_pci
xhci_hcd
ohci_hcd
ehci_pci
ehci_hcd
ahci
libahci
firewire_ohci
libata
firewire_core
crc_itu_t
usbcore
usb_common
usb_storage
hid_logitech
ff_memless
hid_generic
usbhid
hid
ata_generic
scsi_mod

and execute
Code: Select all
update-initramfs -u -k all
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: my usb 3.0 stick only boots from a usb2 hub

Postby ELDebiano » 2015-12-19 03:32

@kiyop
well I tried what you asked me, but still no good result, I still get an xhci error message address 2 error -62 and an initramfs prompt.
I updated initramfs and copied those module names:
Code: Select all
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
ohci_pci
xhci_hcd
ohci_hcd
ehci_pci
ehci_hcd
ahci
libahci
firewire_ohci
libata
firewire_core
crc_itu_t
usbcore
usb_common
usb_storage
hid_logitech
ff_memless
hid_generic
usbhid
hid
ata_generic
scsi_mod

Thanks kiyop, I'm learning so much from you.
ELDebiano
 
Posts: 69
Joined: 2015-08-12 05:47

Re: my usb 3.0 stick only boots from a usb2 hub

Postby kiyop » 2015-12-19 09:42

ELDebiano wrote:well I tried what you asked me, but still no good result, I still get an xhci error message address 2 error -62 and an initramfs prompt.

Maybe I cannot help you. I am sorry.

Sometimes, filesystem error and/or bad read/write prevented correct recognition of the partition (which resulted in initramfs prompt) in my cases. I solved such errors by fsck.

ELDebiano wrote:I updated initramfs and copied those module names:

I wonder if you copied those module names into /etc/initramfs-tools/modules and then, you updated initramfs.
If not, update initramfs and try booting.
If it does not boot, I cannot help you.
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: my usb 3.0 stick only boots from a usb2 hub

Postby ELDebiano » 2015-12-19 09:49

@kiyop, yea I did everything.
Thanks for trying to help me. and nice website you have :)
ELDebiano
 
Posts: 69
Joined: 2015-08-12 05:47

Re: my usb 3.0 stick only boots from a usb2 hub

Postby kiyop » 2015-12-19 09:54

ELDebiano wrote:@kiyop, yea I did everything.
Thanks for trying to help me.

You are welcome :)
and
ELDebiano wrote:nice website you have :)

Thank you ;)
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: my usb 3.0 stick only boots from a usb2 hub

Postby ELDebiano » 2018-02-06 12:11

I tried booting the same sandisk usb3 drive from 3 years ag and it now boots from usb3 port but only on the same pc I installed debian 9.3 (cause I think is because how /dev/hda and such is mapped that only works where I originally installed it from) and also boots only usb3 port cause of the uefi formatted installation.

it doesn't boot from usb2 hub now. nor from another laptop on any of their usb3 usb2 ports because of everything I said.

I tried legacy usb boot on the usb3 drive with debian 9.3 and it can't boot.

I tried uefi and it does allow me to boot.

bottom line, in the past it couldn't boot cause in my modest opinion debian now supports uefi probably not in 2015, or maybe cause this drive is only bootable when using uefi. anyway that's all. Hopefuly this helps someone else.
ELDebiano
 
Posts: 69
Joined: 2015-08-12 05:47

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable