Message "Package netfilter-persistent is not configured yet"

Kernels & Hardware, configuring network, installing services

Message "Package netfilter-persistent is not configured yet"

Postby difnet » 2015-09-03 21:32

Hi,

I installed few days ago Debian Jessie (Linux server-1 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) x86_64 GNU/Linux) for some tests.
I tried to install iptables-persistent with the command "apt-get install iptables-persistent".

During the install process, I got the following message :
Code: Select all
Preconfiguring packages ...
Selecting previously unselected package netfilter-persistent.
(Reading database ... 31677 files and directories currently installed.)
Preparing to unpack .../netfilter-persistent_1.0.3_all.deb ...
Unpacking netfilter-persistent (1.0.3) ...
Selecting previously unselected package iptables-persistent.
Preparing to unpack .../iptables-persistent_1.0.3_all.deb ...
Unpacking iptables-persistent (1.0.3) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u1) ...
Setting up netfilter-persistent (1.0.3) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
A dependency job for netfilter-persistent.service failed. See 'journalctl -xn' for details.
invoke-rc.d: initscript netfilter-persistent, action "start" failed.
dpkg: error processing package netfilter-persistent (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of iptables-persistent:
 iptables-persistent depends on netfilter-persistent (= 1.0.3); however:
  Package netfilter-persistent is not configured yet.

dpkg: error processing package iptables-persistent (--configure):
 dependency problems - leaving unconfigured
Processing triggers for systemd (215-17+deb8u1) ...
Errors were encountered while processing:
 netfilter-persistent
 iptables-persistent
E: Sub-process /usr/bin/dpkg returned an error code (1)


Now, every time I try to install something with apt-get, I get messages about netfilter-persistent and iptables-persistent.

Code: Select all
...

Setting up netfilter-persistent (1.0.3) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
A dependency job for netfilter-persistent.service failed. See 'journalctl -xn' for details.
invoke-rc.d: initscript netfilter-persistent, action "start" failed.
dpkg: error processing package netfilter-persistent (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of iptables-persistent:
 iptables-persistent depends on netfilter-persistent (= 1.0.3); however:
  Package netfilter-persistent is not configured yet.

dpkg: error processing package iptables-persistent (--configure):
 dependency problems - leaving unconfigured

...

Errors were encountered while processing:
 netfilter-persistent
 iptables-persistent
E: Sub-process /usr/bin/dpkg returned an error code (1)


I made some searches on google and on this forum, I found topics or bugs (more or less recent) about similar issues but I didn't find explanations about the reason, and solutions to fix this issue.
Some talks about cups, acpid, ipv6 or systemd but nothing has solved the issue in my case.

I used iptables-persistent many times with older debian versions. I've never had this kind of issue.

Does anyone have faced to this issue and have an idea about the reason ?
Is there a compatibility issue with Jessie ?

Just for information, the server used for my test is a VPS from OVH.

Thank you in advance for your help :)
difnet
 
Posts: 3
Joined: 2015-09-01 17:50

Re: Message "Package netfilter-persistent is not configured

Postby Head_on_a_Stick » 2015-09-04 06:47

difnet wrote:
Code: Select all
A dependency job for netfilter-persistent.service failed. See 'journalctl -xn' for details.

Can we see the output from the suggested command (`journalctl -xn`) please.

You will probably have to add your user to the systemd-journal group and attempt to install something again to generate the entries.
Code: Select all
# gpasswd -a user_name systemd-journal
# newgrp systemd-journal

Replace "user_name" with your user name.

Also post the output of:
Code: Select all
systemctl --failed
systemctl status netfilter-persistent.service
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6810
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Message "Package netfilter-persistent is not configured

Postby difnet » 2015-09-04 08:00

Hi,

Thank you for your answer !

Given that it's just a test, everything is made as root so entries seems to be generated since the beginning.

Here you are the journalctl -xn output :

Code: Select all
-- Logs begin at Fri 2015-09-04 07:56:32 UTC, end at Fri 2015-09-04 07:57:37 UTC. --
Sep 04 07:57:37 serveur-1 kernel: ipmi_si: Unable to find any System Interface(s)
Sep 04 07:57:37 serveur-1 systemd-modules-load[934]: Failed to insert 'ipmi_si': No such device
Sep 04 07:57:37 serveur-1 systemd[1]: systemd-modules-load.service: main process exited, code=exited,
Sep 04 07:57:37 serveur-1 systemd[1]: Failed to start Load Kernel Modules.
-- Subject: Unit systemd-modules-load.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit systemd-modules-load.service has failed.
--
-- The result is failed.
Sep 04 07:57:37 serveur-1 systemd[1]: Dependency failed for netfilter persistent configuration.
-- Subject: Unit netfilter-persistent.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit netfilter-persistent.service has failed.
--
-- The result is dependency.
Sep 04 07:57:37 serveur-1 systemd[1]: Unit systemd-modules-load.service entered failed state.
Sep 04 07:57:37 serveur-1 systemd[1]: Reloading.
Sep 04 07:57:37 serveur-1 systemd[1]: Started ACPI event daemon.
-- Subject: Unit acpid.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit acpid.service has finished starting up.
--
-- The start-up result is done.
Sep 04 07:57:37 serveur-1 systemd[1]: Listening on ACPID Listen Socket.
-- Subject: Unit acpid.socket has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit acpid.socket has finished starting up.
--
-- The start-up result is done.


systemctl --failed output :
Code: Select all
  UNIT                         LOAD   ACTIVE SUB    DESCRIPTION
● smartd.service               loaded failed failed Self Monitoring and Reporting Technology (SMART)
● systemd-modules-load.service loaded failed failed Load Kernel Modules

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

2 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.


systemctl status netfilter-persistent.service output :
Code: Select all
● netfilter-persistent.service - netfilter persistent configuration
   Loaded: loaded (/lib/systemd/system/netfilter-persistent.service; enabled)
   Active: inactive (dead)

Sep 04 07:46:44 serveur-1 systemd[1]: Dependency failed for netfilter persistent configuration.


Thank you for your help !
difnet
 
Posts: 3
Joined: 2015-09-01 17:50

Re: Message "Package netfilter-persistent is not configured

Postby Head_on_a_Stick » 2015-09-04 17:45

"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6810
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Message "Package netfilter-persistent is not configured

Postby Literallie » 2015-09-07 22:00

I'm getting a quite similar symptoms on my server with latest Debian Jessie, interestingly also on OVH with their Jessie default image.
difnet: Did you resolve the problem?
(my /etc/modules file is empty)
Literallie
 
Posts: 1
Joined: 2015-09-07 21:35

Re: Message "Package netfilter-persistent is not configured

Postby difnet » 2015-09-08 09:30

Hi,

No I didn't resolve the problem.
My /etc/modules is empty too.

Maybe I missed something in the bug report... :/
difnet
 
Posts: 3
Joined: 2015-09-01 17:50

Re: Message "Package netfilter-persistent is not configured

Postby nux » 2015-12-15 15:04

I was able to fix this by remove ipmitool

More specifically: apt-get purge ipmitool
nux
 
Posts: 6
Joined: 2007-11-01 17:18

Re: Message "Package netfilter-persistent is not configured

Postby _sly_ » 2017-12-02 17:24

nux wrote:I was able to fix this by remove ipmitool

More specifically: apt-get purge ipmitool


I'd like to point out that my server also uses the jessie default OVH installation and exhibit the exact same problem, I can't remember encountering the same behavior on debian stock jessie but in this particular case :
$ apt-get remove --purge ipmitool
$ apt-get install netfilter-persistent
$ apt-get install ipmitool
did the trick.
Thanks man.

Haven't dug too deep to find the root cause
_sly_
 
Posts: 1
Joined: 2017-12-02 17:16


Return to System configuration

Who is online

Users browsing this forum: t&nk and 9 guests

fashionable