[SOLVED]Jessie upgrade broke my NTFS drive

Kernels & Hardware, configuring network, installing services

[SOLVED]Jessie upgrade broke my NTFS drive

Postby nathank1989 » 2015-09-22 19:42

Hello all,
First I am new-ish to Linux, been working with it for about a year now. I learn fast and utilize google a lot, but if possible, ELI5 please (that also helps anyone after me searching, to find an answer to their problem).
I'm new to this forum and, yes, I did search around for this problem but haven't found any working answers.

I had a Linux server with Wheezy, I have 2 internal drive, one for linux OS, the other our Video On Demand drive that must be accessible to Windows and online. (That's why I chose NTFS, with our large video files, FAT will not work, and EXT isn't compatible with windows sharing, and I haven't gotten FTP to work right :/)

So I upgraded to Jessie today, and everything went smoothly until I tried to access my NTFS drive. (Named WowzaStorage)
I used FSTAB to auto-mount the drive (/dev/sdb1) to /media/ntfs/ on boot. All of this worked swimmingly on Wheezy, but since the update, something got mucked up and I cannot figure it out.

When accessing the mounted NTFS folder in /media/ (if it even shows up) gives me a 'Cannot be found' 'Input/Output error'
When in gParted to examine the drive, I can select it and view all the correct info, but I keep getting "error informing the kernel about modifications to partition /dev/sdb1/ --invalid argument"

Now first I thought maybe the NTFS driver was faulty and I removed 'ntfs-3g' and reinstalled it.
Now when I am in Terminal, after i umount and mount sdb1, I can CD to the drive but not the folders on it... Also using the File Browser, I get errors, and missing folders. I get
"Unhandled error message: Error when getting information for file '/media/ntfs': Input/output error"

Any suggestions?
Last edited by nathank1989 on 2015-09-22 23:39, edited 4 times in total.
nathank1989
 
Posts: 5
Joined: 2014-05-04 11:21

Re: Jessie Upgrade, NTFS Drive, and Errors...

Postby nathank1989 » 2015-09-22 19:47

Here's also a funny thing.
When I mount to /media/ntfs the ntfs folder is not visible in /media/ however, I can CD into it. I can also view /media/ in the filebrowser no issue.

If i umount and mount to /mnt/ntfs/ the location /mnt/ cannot be displayed at all, however, terminal can see it just fine.

EDIT: I can CD into /media/ntfs and see the folders on the root of the hard drive, but I CANNOT access any of the folders.

EDIT 2: I tried a DD command.
Code: Select all
dd if=/dev/sdb bs=512 skip=1953571687 of=/dev/null count=1

I got this output:
Code: Select all
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0.0155716 s 32.9 kB/s


EDIT 3: I am currently running
Code: Select all
 DD if=/dev/sdb bs=512 of=/dev/null

I saw thins:
http://ubuntuforums.org/showthread.php?t=1801445&page=4

And apparently running it in full coaxed the kernel into reading the drive again, so maybe this will work.

EDIT 4: (I'm also seeking help via a Reddit thread I started. A user suggested I try NTFSFIX. Below is my posed results)

nathank1989[S] 0 points just now
Tried it ntfsfix /dev/sdb Reads out:
Code: Select all
Mounting volume... NTFS signature is missing.
FAILED
Attempting to correct errors… NTFS signature is missing.
FAILED
Failed to start up volume: Invalid Argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable Error Volume is corrupt. You should run chkdsk.

Then I tried
Code: Select all
 ntfsfix /dev/sdb1
Refusing to operate on read-write mounted device /dev/sdb1.

So I guess the drive is corrupted. Why would that happen with a Jessie upgrade? I'm currently remote from the server so I can't pull the drive and plug it into Windows at the moment

I also realized my dumb self left it mounted while running, here's the unmounted output

Unmounted and received
Code: Select all
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully
checking the alternate boot sector… OK
NTFS volume version 3.1
NTFS partition /dev/sdb1 was processed successfully


I also tried to chown the directory when it was mounted and received
Code: Select all
chown: cannot access '/media/ntfs': Input/output error
nathank1989
 
Posts: 5
Joined: 2014-05-04 11:21

Re: [SOLVED]Jessie upgrade broke my NTFS drive

Postby nathank1989 » 2015-09-22 23:37

I HAVE FOUND THE ISSUE!!!
For whatever reason, my version of Jessie included a broken ntfs-3G package. 1:2014.2.15AR.2-1+deb8u2
This version is out of date but apt-cache policy won't tell you that. As far as the repositories are concerned that's the latest version.

You must do the following
Code: Select all
wget https://tuxera.com/opensource/ntfs-3g_ntfsprogs-2015.3.14.tgz`

tar xzf ntfs-3g_ntfsprogs-2015.3.14.tgz`

Cd /ntfs3g_ntfsprogs-2015.3.14

./configure; make; make install


Wait til it's done. If you get errors you need to install other packages that are dependent.

When done cd to /usr/local/bin and ls to see if ntfs progs were installed correctly.

Now we mount the drive

Code: Select all
mount -t ntfs-3g /dev/sdb1 /media/ntfs


CD into a folder on the drive to make sure you see it (as I did) and voila! It works.

I also updated my fstab and made sure ntfs-3G was file system attribute
nathank1989
 
Posts: 5
Joined: 2014-05-04 11:21


Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable