E: The value 'wheezy' is invalid for APT::Default-Release as

Kernels & Hardware, configuring network, installing services

E: The value 'wheezy' is invalid for APT::Default-Release as

Postby tulsamike3434 » 2015-10-21 23:46

Here is the error I am getting I have done everything I can do to fix this I think I have been on every page of this forum..


E: The value 'wheezy' is invalid for APT::Default-Release as such a release is not available in the sources

Can ANYBODY please help me with this here is my sources.list
Code: Select all
sources.list# Debian/Squeeze is the stable base for this installation
deb http://ftp.de.debian.org/debian stable main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free

# testing/unstable/experimental contain newer versions, but
# packages from there are not being installed by default, unless
# they came from there in the first place.
deb http://ftp.de.debian.org/debian testing main contrib non-free
deb http://security.debian.org testing/updates main contrib non-free
deb http://ftp.de.debian.org/debian unstable main contrib non-free
deb http://ftp.de.debian.org/debian experimental main contrib non-free

# Debian/volatile contains quickly changing data like spam- and virusfilter databases
# Does not exist anymore
deb http://volatile.debian.org/debian-volatile stable/volatile main contrib non-free
deb http://ftp.de.debian.org/debian stable-updates main contrib non-free

# Knoppix repository
deb http://debian-knoppix.alioth.debian.org ./

# x2go
deb http://x2go.obviously-nice.de/deb/ lenny main
deb http://packages.x2go.org/debian squeeze main
# deb http://packages.x2go.org/debian wheezy main
deb http://packages.x2go.org/debian sid main

# Debian Multimedia, contains non-free software like acrobat reader
deb http://www.deb-multimedia.org squeeze main non-free

# eviacam
deb http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu trusty main
deb-src http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu trusty main



Thank you for your time...
I am running Knoppix 7.4
tulsamike3434
 
Posts: 1
Joined: 2015-10-21 23:33

OMG WTF

Postby stevepusser » 2015-10-22 00:11

Nice sources.list!

Image

A god of discord, you know...

No other problems with a witches' brew of mixed repos like that?

http://unix.stackexchange.com/questions ... -in-wheezy
Last edited by stevepusser on 2015-10-22 00:48, edited 1 time in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.7, Strawberry 0.6.12, Pale Moon 28.10.0, Xscreensaver 5.44, Krita 4.3.0, Foliate 2.3.0
User avatar
stevepusser
 
Posts: 11770
Joined: 2009-10-06 05:53

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby GarryRicketson » 2015-10-22 00:18

Here is the error I am getting I have done everything I can do to fix this I think I have been on every page of this forum..

No need to shout, either,Maybe you have been on every page on the forum, but apparently you did not read anything any of them said. There are so many posts here on this forum, where people have mixed in all sorts of different versions, and distros, to the extent that their system no longer works.
Knopix, is NOT Debian, .. then you have all sorts of other stuff mixed in.
Do some searches, for real, and learn a little,

https://wiki.debian.org/DontBreakDebian
But since you are using "knopix", it would be better to ask them on the "knopix" forum,
http://www.knoppix.net/forum/
And finally, we have a entire topic/fourm/thread dedicated to problems just like yours
: Mixed and Matched hit parade:how to fix it
in fact if I remember correctly there are a couple of others that were using knoppix, and
created some kind of deformed , broken monster, due to the fact that they don't know what they are doing, and never look at any manuals nor read the advice given by others or in tutorials.
Last edited by GarryRicketson on 2015-10-22 00:43, edited 1 time in total.
User avatar
GarryRicketson
 
Posts: 5872
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby fireExit » 2015-10-22 00:39

interesting! the same sources.list as here
User avatar
fireExit
 
Posts: 559
Joined: 2014-11-20 11:22

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby GarryRicketson » 2015-10-22 00:50

fireExit wrote:interesting! the same sources.list as here

Good Job, or good catch,... makes me wonder, but they are not exactly the same, pretty close though,
Anyway @OP, if your system is still working, Don't do anything until you learn how to fix your sources.list file, that is why you are getting the error,
E: The value 'wheezy' is invalid for APT::Default-Release as such a release is not available in the sources

Maybe you got lucky and it was not able to install anything,.. the message is clear enough, "the value "wheezy" is invalid for APT, you need to find a source that is valid, and put in the correct line, but your system is such a mix and mismatch, I can not even come close to guessing what a "valid" value would be,.. maybe they can help you on the knoppix forum.
Last edited by GarryRicketson on 2015-10-22 01:06, edited 1 time in total.
User avatar
GarryRicketson
 
Posts: 5872
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby spacex » 2015-10-22 01:04

I'm going to take it seriously :D

Why should Apt accept Wheezy as default release, when your sources points to Jessie? Try with Jessie instead :P
spacex
 
Posts: 637
Joined: 2015-01-17 01:27

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby Wheelerof4te » 2015-10-22 08:22

I think that OP is a troll. Either that, or he saw this list somewhere and copied it?

If I'm wrong, sorry OP. And, for the love of Lenny, just reinstall Stable.
Wheelerof4te
 
Posts: 1454
Joined: 2015-08-30 20:14

Re: E: The value 'wheezy' is invalid for APT::Default-Releas

Postby dasein » 2015-10-22 15:06

fireExit wrote:interesting! the same sources.list as here

Priceless!! :lol: :lol:

Maybe the "mysteriously mutating" system caused the poster's user account to mysteriously mutate too.

Maybe or maybe not troll, but certainly walking PEBKAC (with DramaQueen frosting... "every page" indeed :roll:)

(Nothing to see here, folks... move along please)
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable