cryptsetup: lvm is not available

Kernels & Hardware, configuring network, installing services

cryptsetup: lvm is not available

Postby rovernut » 2016-02-15 15:12

I just installed Jessie 8.3 to a computer I'm refurbishing for my brother. It will have a good bit of personal financial information on it so I set it up with encrypted drives and the boot partition on a thumb drive.
It's a single new 1TB drive partitioned:
Code: Select all

One thing I hadn't done that I usually do with a new drive is to run a SMART test to make sure it checks out.

It was working fine, had rebooted several times without issue. Then yesterday I shut it down to install some more memory that I found, going from 2GB to 4GB. I hadn't made any system changes or done any updates between booting it yesterday morning and shutting it down to replace the memory.

On reboot it asked for the passphrase for sda1_crypt which it accepted, but that's as far as it gets. This is what I see
Code: Select all
Please unlock disk sda1_crypt
crptsetup: sda1_crypt set up successfuly
cryptsetup: lvm is not available
cryptsetup: lvm is not available
cryptsetup: lvm is not available

and so on until it eventually drops to this screen


The first thing I did was put the old memory back in. I thought it unlikely to be the issue, but wanted to rule it out.
Once I was back to the the prompt I ran
Code: Select all
and the missing uuid is definitely not there.
Code: Select all
cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.16.0-4-amd64 root=/dev/mapper/sda1_crypt ro single

Since this is a fresh install and all I've done is some customization I could just start over, but I'm looking at this as a learning experience, so I'd like to recover from it. Assuming that's possible.
I'm sure I'm not the first to experience this, but I've done some googling but didn't see anyone that appeared to have the same issue.

Any suggestions for next steps?
Tom Rowe

Four wheel drive allows you to get stuck
in places even more inaccessible.
Posts: 82
Joined: 2013-11-20 10:50

Re: cryptsetup: lvm is not available

Postby efrpcabo » 2017-04-03 21:46

Same thing happened to me today after I took my disk and connect it to a second computer, in which it ran fine.

But, when I put it back in the first computer, it gave me the same errors (except uuid are different, of course).

I also couldn't solve this.

Any ideas?
Posts: 10
Joined: 2013-08-08 06:36

Re: cryptsetup: lvm is not available

Postby efrpcabo » 2017-04-03 23:46

Well, finally solved it.
The solution was quite simple and fast, took me about 5m, because I had the Debian DVD around from the initial installation:
1 - booted with a Debian 8 DVD
2 - chose rescue mode, then country, keymap, etc
3 - then, the installer found automatically my encripted partitions and asked me for its passwords
4 - then, it asked me where was my root partition, in my case /dev/mapper/sda3_crypt
5 - then, I chose the option "reinstall grub" and it reinstalled but gave me some errors about some missing modules
6 - afterwards, I chose "drop to a shell in /dev/mapper/sda3_crypt" and then I did: update-initramfs -u -k all
7 - finally, I rebooted and it worked like a charm
That was it!
Posts: 10
Joined: 2013-08-08 06:36

Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests