Error message {RESOLVED}

Kernels & Hardware, configuring network, installing services

Error message {RESOLVED}

Postby wmittz » 2016-11-19 21:22

"The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user 'root' executing apt-key". I upgraded to the 4.8.7-1 kernel, running sid, started after the update. i've looked around for a solution, but no luck so far. when I tried apt-key update it says it is depreciated. I can still update, although not in the normal way, install packages etc. If anyone could point me in the right direction it would be greatly appreciated.

Thanks
Last edited by wmittz on 2016-12-16 12:46, edited 1 time in total.
wmittz
 
Posts: 58
Joined: 2010-06-03 16:18

Re: Error message

Postby bw123 » 2016-11-19 22:38

when I tried apt-key update it says it is depreciated


Most apps that warn about deprecated usage still perform the task. Does apt-key have any other info like a --vvv setting or something? Maybe the new keys aren't available yet? can you download them somewhere?

debian-archive-keyring (for sid) would possibly be the package you need to update?

/etc/apt/trusted.gpg are ignored as the file is not readable by user 'root' executing apt-key


Funny trick.. well is the file there? who is it readable by if not root?
User avatar
bw123
 
Posts: 2378
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Error message

Postby wmittz » 2016-11-20 03:00

W: http://http.us.debian.org/debian/dists/ ... /InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user 'root' executing apt-key.
W: http://www.deb-multimedia.org/dists/sid/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user 'root' executing apt-key.

Above is what I get from apt-get update. You may be right about new keys being available. I read somewhere that they increased security for the new kernel, but i have not been able find the article again. I fell back to an earlier kernel, same results, I've been looking for change logs but haven't seen mention of the changes.

The results for apt-key update,
Warning: 'apt-key update' is deprecated and should not be used anymore!
Note: In your distribution this command is a no-op and can therefore be removed safely.

It seems like there is a security/permission issue.
wmittz
 
Posts: 58
Joined: 2010-06-03 16:18

Re: Error message

Postby Bulkley » 2016-11-20 03:22

wmittz wrote:"The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user 'root' executing apt-key". I upgraded to the 4.8.7-1 kernel, running sid, started after the update.

What happens when you use the previous kernel? You did save it, didn't you?

i've looked around for a solution, but no luck so far. when I tried apt-key update it says it is depreciated. I can still update, although not in the normal way, install packages etc. If anyone could point me in the right direction it would be greatly appreciated.

Sid (Unstable) is the bad boy of Debian. Breaks are expected. As a user of Sid you should find a fix and send a bug fix. Or you could wait a week or two for someone else to fix and report and the software to catch up. If you are in a hurry, install Jessie (Stable) which won't have this problem.
Bulkley
 
Posts: 5284
Joined: 2006-02-11 18:35

Re: Error message

Postby wmittz » 2016-11-20 15:47

"What happens when you use the previous kernel? You did save it, didn't you?" I get the same error message. I went back and rebooted the 4.7 kernel, deleted the 4.8, still the same. As a side note I had the 4.8 headers running for a few days before the kernel update with no issues. So to me the issue is how the kernel is looking at different security permissions which have changed with the install of the 4.8 kernel.

"Sid (Unstable) is the bad boy of Debian. Breaks are expected." I've been running Sid for about 5 yrs, I find that if you are careful, lol, its not to bad, although I've made my share of mistakes. Sid is a hobby type of thing, stable is great, but a little boring. I'll continue to look for a solution, when I installed the 4.8 kernel there were no bug reports at that time. Thanks
wmittz
 
Posts: 58
Joined: 2010-06-03 16:18

Re: Error message

Postby Bulkley » 2016-11-20 17:00

wmittz wrote:"What happens when you use the previous kernel? You did save it, didn't you?" I get the same error message. I went back and rebooted the 4.7 kernel, deleted the 4.8, still the same. As a side note I had the 4.8 headers running for a few days before the kernel update with no issues. So to me the issue is how the kernel is looking at different security permissions which have changed with the install of the 4.8 kernel.

"Sid (Unstable) is the bad boy of Debian. Breaks are expected." I've been running Sid for about 5 yrs, I find that if you are careful, lol, its not to bad, although I've made my share of mistakes. Sid is a hobby type of thing, stable is great, but a little boring. I'll continue to look for a solution, when I installed the 4.8 kernel there were no bug reports at that time. Thanks

Sorry about that. As you know we get newbies here who jump in head first.

Now that we have my lecture out of the way here's an experiment you can try. No guarantees.

Copy and save /etc/apt/trusted.gpg under another name, maybe /etc/apt/trusted.gpg.wmittz. Then do
Code: Select all
rm /etc/apt/trusted.gpg

apt-key update
If that doesn't work, there is How to fix missing gpg key even though it should have been imported which has more detailed instructions.
Bulkley
 
Posts: 5284
Joined: 2006-02-11 18:35

Re: Error message

Postby wmittz » 2016-11-21 00:52

I still consider myself a newbie, lol. My skill level isn't that great.

I'll try some experiments.


Thanks
wmittz
 
Posts: 58
Joined: 2010-06-03 16:18

Re: Error message

Postby Bulkley » 2016-11-21 01:24

wmittz wrote:I still consider myself a newbie, lol. My skill level isn't that great.


I know the feeling. Generally I find that it isn't Debian or Linux that caused a problem but it was me doing something inadvertently. Sometimes the best troubleshooting tool is a mug of coffee a pencil and a notepad or whatever it takes to get comfortable and think about what I might have done.
Bulkley
 
Posts: 5284
Joined: 2006-02-11 18:35

Re: Error message

Postby wmittz » 2016-12-16 12:45

Well after trying a lot of things to resolve this problem, I gave up trying to repair it. I re-installed stable, then proceeded to upgrade to sid. I was able to replicate the same error message 3 different times at different times during the each upgrade (3). The first two attempts I ran into issues with docutils and the 4.8.0-1 kernel. The third attempt I held back upgrading the kernel to mid upgrade, ran the 4.7 bpo kernel, upgraded and continued on with no issues. Somewhere during during the last hundred or so upgrades the dreaded message reappeared. Last Sunday I started fresh again, this time they had upgraded the kernel to 4.8.11 which I used and it went well. Went directly from stable to sid on this upgrade, after the basic system packages, I bounced around upgrading the packages. I have had no issues since then and the system seems quite stable. Its not the typical "fix" but it worked for me.
wmittz
 
Posts: 58
Joined: 2010-06-03 16:18

not readable by user ‘_apt’ executing apt-key

Postby Onsemeliot » 2017-07-19 06:39

The problem of an unreadable "/etc/apt/trusted.gpg" seems to have surfaced again in Stretch. I expect many others might encounter this issue by getting the following error message when updating the software sources: "The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user ‘_apt’ executing apt-key."

After reading the whole long thread on the Debian user mailing list at least I could resolve the issue on a fresh install of Stretch by just deleting the file causing the problem: sudo rm -f /etc/apt/trusted.gpg.
User avatar
Onsemeliot
 
Posts: 144
Joined: 2010-12-15 14:43

Re: Error message

Postby eor2004 » 2017-07-31 22:27

Bulkley wrote:
Copy and save /etc/apt/trusted.gpg under another name, maybe /etc/apt/trusted.gpg.wmittz. Then do
Code: Select all
rm /etc/apt/trusted.gpg

apt-key update
If that doesn't work, there is How to fix missing gpg key even though it should have been imported which has more detailed instructions.


Thank you Bulkley for this command, worked like a charm for me, I did encountered this same issue with a new Debian stretch installation, I was pulling my hair off because I didn't find a clear answer for this on the interweb, only here in this forum, thank you again!
Debian Stretch x64, Gnome Shell 3.22, Kernel Linux 4.9.0-1-amd64, Pentium Dual-Core E5300 @ 2.6Ghz, Gigabyte G41M-ES2L, Intel 4 Series Integrated Graphics Controller, 1Tb Caviar Black WD1001FALS.
User avatar
eor2004
 
Posts: 150
Joined: 2013-10-01 22:49
Location: Puerto Rico


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable