polish signs for keybord

Kernels & Hardware, configuring network, installing services

polish signs for keybord

Postby cas_ccnp » 2017-01-27 14:34

hello

I have an issue with polish signs on my debian. Tried to change locale but it does not work:

Code: Select all
root@debian8:/home/cas# dpkg-reconfigure keyboard-configuration
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


please help
cas_ccnp
 
Posts: 11
Joined: 2015-01-04 09:25

Re: polish signs for keybord

Postby cronoik » 2017-01-27 17:19

Install the polish locales before you set the keyboard layout.
Code: Select all
dpkg-reconfigure locales
Have a nice day!
cronoik
 
Posts: 187
Joined: 2015-05-20 21:17

Re: polish signs for keybord

Postby cas_ccnp » 2017-02-05 16:21

I have that I guess:

Code: Select all
Default locale for the system environment:                                │ 
 │                                                                           │ 
 │                                None                                       │ 
 │                                pl_PL.UTF-8                                │ 
 │                                                                           │ 
 │                                                                           │ 
 │                    <Ok>                        <Cancel>   



Code: Select all
root@debian8:/etc/apt# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  pl_PL.UTF-8... done
Generation complete.
cas_ccnp
 
Posts: 11
Joined: 2015-01-04 09:25

Re: polish signs for keybord

Postby cas_ccnp » 2017-02-05 16:30

actaully, after I done it, it is working. ółąśżź :) thanks !
cas_ccnp
 
Posts: 11
Joined: 2015-01-04 09:25

Re: polish signs for keybord

Postby cas_ccnp » 2017-02-27 17:19

Damn. Today problem comes back. I repeted procedure and still no luck:

Code: Select all
root@debian8:/home/cas# dpkg-reconfigure locales
Generating locales (this might take a while)...
  pl_PL.UTF-8... done
Generation complete.

root@debian8:/home/cas# dpkg-reconfigure keyboard-configuration
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults


Please help ...
cas_ccnp
 
Posts: 11
Joined: 2015-01-04 09:25

Re: polish signs for keybord

Postby debiman » 2017-02-28 07:16

we will need additional output.
please search the debian wiki for locale-related stuff, do some troubleshooting, show us some config files etc.

ps:
on my system, tab completion for locale gives:
Code: Select all
locale      locale-gen  localectl   localedef
User avatar
debiman
 
Posts: 673
Joined: 2013-03-12 07:18

Re: polish signs for keybord

Postby margaretH » 2017-03-11 02:36

man 7 local
and apt-conf has a option for language`s.

http://www.tldp.org/HOWTO/Polish-HOWTO.html
margaretH
 
Posts: 14
Joined: 2017-01-23 20:22


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable