Bind9 not working reverse zone

Kernels & Hardware, configuring network, installing services

Bind9 not working reverse zone

Postby Carinavb » 2017-02-22 20:57

Hello everybody, I recently change my OS to debian jessie and I can't make the server work properly.
/etc/resolv.conf
================
nameserver xxx.yyy.zzz.2
nameserver 8.8.8.8
nameserver 8.8.4.4

hosts
======
/hosts
127.0.0.1 localhost
xxx.yyy.zzz.2 ns1.midominio.com ns1

named.conf.local
================
include "/etc/bind/named.conf.log";
//JUJUYTEL
//directa

zone "midominio.com" IN {
type master;
file "/etc/bind/directa/midominio.com1";
allow-query { any; };
};

//reversa
zone "zzz.yyy.xxx.IN-ADDR.ARPA" {
type master;
file "/etc/bind/midominio.com.reversa";
allow-query { any; };
};

//WEBMAIL
//directa

zone "webmail.midominio.com" IN {
type master;
file "/etc/bind/webmail.midominio.com";
allow-query { any; };
};

//MAIL
//directa

zone "mail.midominio.com" IN {
type master;
file "/etc/bind/mail.midominio.com";
allow-query { any; };
};

named.conf.options
==================

options {
directory "/var/cache/bind";
forwarders {
8.8.8.8;
};

version "No version";
auth-nxdomain no; # conform to RFC1035
allow-query { any; };
rate-limit {
responses-per-second 10;

};
};

zone midominio.com
====================
$ORIGIN midominio.com.
$TTL 1W
@ IN SOA ns1.midominio.com. root.ns1.midominio.com. (
2017022005 ; Serial
3600 ; Refresh
300 ; Retry
1209600 ; Expire
3600 ; Minimum
)

IN NS ns1.midominio.com.
IN NS web.midominio.com.
IN NS ns1.arnet.com.ar.
IN NS ns2.arnet.com.ar.
IN MX 0 mail.midominio.com.
;--------------------------------------------------------------
localhost IN A 127.0.0.1

ns1 IN A xxx.yyy.zzz.2
IN HINFO DNS Server

web IN A xxx.yyy.zzz.5
IN HINFO Web Server

mail IN A xxx.yyy.zzz.6
IN HINFO Mail Server


www IN CNAME web.midominio.com.
webmail IN CNAME mail.midominio.com.
proxy IN CNAME ns1.midominio.com.

reverse zone
============
;
; BIND reverse data file for local loopback interface
;
$TTL 604800
@ IN SOA ns1.midominio.com. root.midominio.com. (
2017022002 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL
;
@ IN NS ns1.midominio.com.
2 IN PTR ns1.midominio.com.
5 IN PTR web.midominio.com.
6 IN PTR mail.midominio.com.


I get this error
============
nslookup
> xxx.yyy.zzz.2
;; Got SERVFAIL reply from xxx.yyy.zzz.2, trying next server
;; Got SERVFAIL reply from 8.8.8.8, trying next server
Server: 8.8.4.4
Address: 8.8.4.4#53

** server can't find 2.zzz.yyy.xxx.in-addr.arpa: SERVFAIL

I hope someone can guide me with this.
Best regards.
Carinavb
 
Posts: 6
Joined: 2014-01-16 22:49

Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable