Bluetooth's turned on but isn't scanning

Kernels & Hardware, configuring network, installing services

Bluetooth's turned on but isn't scanning

Postby serpastorg » 2017-02-27 16:52

One of the rules of this kind of forums is that if you have another question different than the original one, you must make another thread.
My former question was Bluetooth started in systemctl but no adapters found (, and it was almost solved. The problem I had was a firmware one. After updating firmware to the one from backports, Jessie recognized my laptop's bluetooth device...
But there's another problem, that is related to, but is not the same...

I've searched for this problem, and there's a lot of threads asking the same thing on the Internet. The only difference is that those threads were for another distros, and they were from 2012, 2013 and before :roll: . There's nothing even from 2016, and 4.8 kernel (the one I have) is more updated...

Some people said booting Windows solved their problem for a strange reason... It didn't work for me.

On the Internet, there's a lot of unsolved threads about this reason.
One order the PC to scan for Bluetooth devices (such as smartphones, keyboards, TVs, headphones, etc) and it doesn't do that.
It times out searching for other devices (and they are visible),

Code: Select all
root@roberto:/home/sergio# hcitool scan
Scanning ...
Inquiry failed: Connection timed out

Code: Select all
sergio@roberto:~$ bluetoothctl
[NEW] Controller C8:FF:28:C4:5F:98 roberto [default]
[bluetooth]# scan on
Discovery started
[bluetooth]# quit
[DEL] Controller C8:FF:28:C4:5F:98 roberto [default]

Can someone help me?
Thanks a lot to people in this forum :)
Posts: 19
Joined: 2016-11-18 00:16
Location: Bogotá, Colombia

Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests