Exim4 problem cant install mailserver

Kernels & Hardware, configuring network, installing services

Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-06 19:35

hello

I cant install exim4 on Debian 8 Jessie it gives me this errors :

Code: Select all
root@nsxxxxxx:~# apt-get install exim4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package exim4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'exim4' has no installation candidate


I have ovh repository (SYS dedicated server)

Can any1 help me? :(
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 16:31

Any1? pls
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby GarryRicketson » 2017-03-07 17:01

Look at what the error message says:
This may mean that the package is missing, has been obsoleted, or
is only available from another source

The package is not available from the source you are using.

Please, give us some more information,. for example:
what your /etc/apt/sources.list file has in it.


exim4 on Debian 8 Jessie

https://wiki.debian.org/Exim

Installation
Exim generally comes with default Debian installation. If you need to use ACL and other features you may need to install exim4-daemon-heavy

So some details on how you installed Debian ? It should have been included,
unless it was a very minimal install,..I can not guess at that, please give details.

There is more details here:
https://packages.debian.org/jessie/exim4

I know, somebody will probably jump in , and tell me I should not try to answer
this , because I can't,...the main reason is because the OP does not include enough
details, but since no one else seems to be willing to try to help , I figure at least
it may help them to know more details are needed.
Or a little search "foo", on how to install packages on Debian, etc. and the OP might be able to figure it out on their own.
I apologize, for not knowing the exact answer, and for what probably is just another use less post on my part.
If any body else has a better answer, I am sure the OP will appreciate it.
User avatar
GarryRicketson
 
Posts: 3963
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Exim4 problem cant install mailserver

Postby wizard10000 » 2017-03-07 17:17

exim4 is already installed by default in Debian.
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1082
Joined: 2011-05-09 20:02
Location: midwestern us

Re: Exim4 problem cant install mailserver

Postby GarryRicketson » 2017-03-07 17:40

That is what the wiki says, and also on my systems it was installed be default.
I would try using a different source, like the error message says.
User avatar
GarryRicketson
 
Posts: 3963
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Exim4 problem cant install mailserver

Postby wizard10000 » 2017-03-07 17:42

Yeah - my reading comprehension is a little off; probably gotta quit multitasking. You did say that it was installed by default :)
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1082
Joined: 2011-05-09 20:02
Location: midwestern us

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 17:51

The problem is i purge this package and cant install it back =/

Code: Select all
deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
 
# jessie-updates, previously known as 'volatile'
deb http://debian.mirrors.ovh.net/debian/ jessie-updates main
deb-src http://debian.mirrors.ovh.net/debian/ jessie-updates main
 
# jessie-backports, previously on backports.debian.org
deb http://debian.mirrors.ovh.net/debian/ jessie-backports main
deb-src http://debian.mirrors.ovh.net/debian/ jessie-backports main
 
deb http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free
deb-src http://debian.mirrors.ovh.net/debian/ jessie main contrib non-free

#jessie repository
deb http://ftp.de.debian.org/debian jessie main
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby Zill » 2017-03-07 19:33

zoxovsky: It could just be that your chosen mirror was down when you ran the install command. I suggest you post the output of the following two commands:
Code: Select all
sudo apt-get update
sudo apt-get -s upgrade

Note that the "-s" in the last command is a simulation just to show what can be upgraded. Unless you have a reason not to upgrade one or more packages then it is generally best to keep a Debian stable system fully upgraded.

If the above shows the "four zeros", indicating that your system is up to date, then I suggest you post the output of the following two commands:
Code: Select all
sudo apt-get install exim4
apt-cache policy exim4
User avatar
Zill
 
Posts: 18
Joined: 2011-03-25 16:16
Location: Lincolnshire, UK

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 19:44

Zill wrote:zoxovsky: It could just be that your chosen mirror was down when you ran the install command. I suggest you post the output of the following two commands:
Code: Select all
sudo apt-get update
sudo apt-get -s upgrade

Note that the "-s" in the last command is a simulation just to show what can be upgraded. Unless you have a reason not to upgrade one or more packages then it is generally best to keep a Debian stable system fully upgraded.

If the above shows the "four zeros", indicating that your system is up to date, then I suggest you post the output of the following two commands:
Code: Select all
sudo apt-get install exim4
apt-cache policy exim4


srsly this cant help me =/

Code: Select all
# sudo apt-get -s upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Code: Select all
sudo apt-get install exim4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package exim4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'exim4' has no installation candidate


Code: Select all
# apt-cache policy exim4
exim4:
  Installed: (none)
  Candidate: (none)
  Version table:
     4.84.2-2+deb8u3 0
        100 /var/lib/dpkg/status


Im srsly done with it.
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby GarryRicketson » 2017-03-07 20:03

Postby Zill » 2017-03-07 13:33
zoxovsky: It could just be that your chosen mirror was down when you ran the install



Either try using some different sources,...or wait, I just noticed this:
http://debian.mirrors.ovh.net/debian/
[DIR] Parent Directory -
[ ] Archive-Update-in-Progress-debian.mirrors.ovh.net 07-Mar-2017 20:04 6
[ ] README


It appears there is a archives update , in progress,..when that is done it may work better.
User avatar
GarryRicketson
 
Posts: 3963
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 20:15

GarryRicketson wrote:
Postby Zill » 2017-03-07 13:33
zoxovsky: It could just be that your chosen mirror was down when you ran the install



Either try using some different sources,...or wait, I just noticed this:
http://debian.mirrors.ovh.net/debian/
[DIR] Parent Directory -
[ ] Archive-Update-in-Progress-debian.mirrors.ovh.net 07-Mar-2017 20:04 6
[ ] README


It appears there is a archives update , in progress,..when that is done it may work better.


So what i should change in my source.list? Can you paste ready to write? :D
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby GarryRicketson » 2017-03-07 20:23

https://wiki.debian.org/SourcesList

Example sources.list

Below is an example of a sources.list for Debian 8/Jessie.

Code: Select all
deb http://httpredir.debian.org/debian jessie main
deb-src http://httpredir.debian.org/debian jessie main

deb http://httpredir.debian.org/debian jessie-updates main
deb-src http://httpredir.debian.org/debian jessie-updates main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main


Note , it is intended as a example, but you should be ok with it..it would be best to read the page
on the wiki, for more details.
I am assuming you know how to edit the /etc/apt/sources.list

===== just in case=====
You can use this: # in front of the sources you have, the # sign will comment them out,...that way, later if you want to use them, just remove the #.
You need to use 'su' or 'sudo' to edit, any editor is ok, but nano, or vi are preferred.
===== edit====
There also a list of many others, here :
https://www.debian.org/mirror/list
Last edited by GarryRicketson on 2017-03-07 20:32, edited 1 time in total.
User avatar
GarryRicketson
 
Posts: 3963
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 20:27

GarryRicketson wrote:https://wiki.debian.org/SourcesList

Example sources.list

Below is an example of a sources.list for Debian 8/Jessie.

Code: Select all
deb http://httpredir.debian.org/debian jessie main
deb-src http://httpredir.debian.org/debian jessie main

deb http://httpredir.debian.org/debian jessie-updates main
deb-src http://httpredir.debian.org/debian jessie-updates main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main


Note , it is intended as a example, but you should be ok with it..it would be best to read the page
on the wiki, for more details.
I am assuming you know how to edit the /etc/apt/sources.list


Holy **** the same errors, im just crying there. :cry:
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby zoxovsky » 2017-03-07 20:30

No way haha my file sources.list was "sources.list~" Cant believe that!!!!!!! HAHA :D
zoxovsky
 
Posts: 19
Joined: 2017-02-27 20:42

Re: Exim4 problem cant install mailserver

Postby GarryRicketson » 2017-03-07 20:33

Ooops :D
No way haha my file sources.list was "sources.list~"
User avatar
GarryRicketson
 
Posts: 3963
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Next

Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable