Gnome doesn't start - (assertions failed)

Kernels & Hardware, configuring network, installing services

Gnome doesn't start - (assertions failed)

Postby Ecco » 2017-03-18 13:37

Hey @all,
is there maybe someone out there who can give me a hint where to find infos/solutions for my problems with gnome? :-)
I installed the gnome-core package on my home-server, but can't get it to work ("something has gone wrong.."). Seems like there are several problems and assertions, including that the power-plugin is thinking I got an monitor with controllable backlight, tried to disable that with
Code: Select all
gconftool-2 --set --type boolean "/apps/gnome-power-manager/backlight/enable" false

but all remains the same. Any hint?
Relevant part of the log:

    Mar 18 14:42:16 eserver systemd[1]: Started PackageKit Daemon.
    Mar 18 14:42:16 eserver gnome-session[1511]: (gnome-settings-daemon:1534): power-plugin-CRITICAL **: gsd_power_backlight_abs_to_percentage: assertion 'max > min' failed
    Mar 18 14:42:16 eserver gnome-session[1511]: LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
    Mar 18 14:42:17 eserver gnome-session[1511]: Gjs-Message: JS LOG: Failed to launch ibus-daemon: Kindprozess »ibus-daemon« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
    Mar 18 14:42:17 eserver gnome-session[1511]: (gnome-settings-daemon:1534): power-plugin-CRITICAL **: gsd_power_backlight_abs_to_percentage: assertion 'max > min' failed
    Mar 18 14:42:17 eserver gnome-session[1511]: LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
    Mar 18 14:42:17 eserver gnome-session[1511]: gnome-session[1511]: WARNING: App 'gnome-shell.desktop' respawning too quickly
    Mar 18 14:42:17 eserver gnome-session[1511]: WARNING: App 'gnome-shell.desktop' respawning too quickly
    Mar 18 14:42:17 eserver gnome-session[1511]: Unrecoverable failure in required component gnome-shell.desktop
    Mar 18 14:42:18 eserver gnome-session[1511]: (gnome-settings-daemon:1534): GLib-GIO-CRITICAL **: g_dbus_proxy_call_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
    Mar 18 14:42:18 eserver gnome-session[1511]: (gnome-settings-daemon:1534): GLib-GIO-CRITICAL **: g_dbus_proxy_call_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed

Thanks in advance,

(Debian GNU/Linux 8.7)
Ecco
 
Posts: 2
Joined: 2017-03-18 13:30

Re: Gnome doesn't start - (assertions failed)

Postby phenest » 2017-03-21 22:09

Your hardware spec would be useful and the entire log, rather than a snippet.
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Gnome doesn't start - (assertions failed)

Postby Ecco » 2017-03-26 07:37

Hey, thanks for the reply.
Well, I think the most important specs are:
  • Intel(R) Pentium(R) CPU G4400 @ 3.30GHz
  • Asus B150M-K D3 with Intel B150 chipset
  • 4GB RAM
  • 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07)
but maybe there is something useful i gathered with lshw (don't think so :)): http://pastebin.com/3AN81NKk

Last but not least the whole syslog for a system-startup:
http://pastebin.com/AXyqdH6b
Ecco
 
Posts: 2
Joined: 2017-03-18 13:30

Re: Gnome doesn't start - (assertions failed)

Postby Head_on_a_Stick » 2017-03-26 10:02

https://forums.bunsenlabs.org/viewtopic.php?id=1185

@stevepusser, does this count for the drinking game? :mrgreen:
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6673
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable