CentOS fails to install as Xen domU

Kernels & Hardware, configuring network, installing services

CentOS fails to install as Xen domU

Postby devzero » 2017-03-20 00:48

Domain0 is a Jessie with 4.7.0-0.bpo.1-amd64.

domU installation works great if domU is also a Jessie:
Code: Select all
# virt-install --connect xen:/// --paravirt --name d81 --vcpus 2 --memory 512 --disk /dev/VG0/d81 --graphics none --os-variant generic --location http://ftp.tu-chemnitz.de/pub/linux/debian/debian/dists/stable/main/installer-amd64/


But as I try to install a CentOS7 domU with the same command:
Code: Select all
# virt-install --connect xen:/// --paravirt --name c71 --vcpus 2 --memory 512 --disk /dev/VG0/c71 --graphics none --os-variant generic --location http://mirror.i3d.net/pub/centos/7/os/x86_64/

It always stucks before anaconda becomes alive:
Code: Select all
         Starting udev Kernel Device Manager...
[  OK  ] Started udev Kernel Device Manager.
         Starting dracut pre-trigger hook...
[  OK  ] Started dracut pre-trigger hook.
         Starting udev Coldplug all Devices...
         Mounting Configuration File System...
[  OK  ] Started udev Coldplug all Devices.
         Starting Device-Mapper Multipath Device Controller...
         Starting Show Plymouth Boot Screen...
[    7.515493] AES CTR mode by8 optimization enabled
[  OK  ] Mounted Configuration File System.
[  OK  ] Reached target System Initialization.
[  OK  ] Listening on Open-iSCSI iscsiuio Socket.
[  OK  ] Reached target Sockets.
[  OK  ] Started Show Plymouth Boot Screen.
[  OK  ] Reached target Paths.
[  OK  ] Reached target Basic System.
[    7.521940] xen_netfront: Initialising Xen virtual ethernet driver
[    7.527902] blkfront: xvda: flush diskcache: enabled; persistent grants: enabled; indirect descriptors: disabled;
[    7.535893] Setting capacity to 16777216
[    7.535910] xvda: detected capacity change from 0 to 8589934592
[    7.547542] 8021q: 802.1Q VLAN Support v1.8
[  OK  ] Started Device-Mapper Multipath Device Controller.
         Starting Open-iSCSI...
[    7.563710] alg: No test for __gcm-aes-aesni (__driver-gcm-aes-aesni)
[  OK  ] Started Open-iSCSI.
         Starting dracut initqueue hook...
[    7.577891] alg: No test for crc32 (crc32-pclmul)
[    7.672294] dracut-initqueue[592]: RTNETLINK answers: File exists
[   11.267143] dracut-initqueue[592]: % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
[   11.267534] dracut-initqueue[592]: Dload  Upload   Total   Spent    Left  Speed
 21  317M   21 67.0M    0     0  3562k      0  0:01:31  0:00:19  0:01:12 3415k  0 --:--:-- --:--:-- --:--:--     0
[   30.527287] dracut-initqueue[592]: curl: (23) Failed writing body (1312 != 1440)
[   30.838913] loop: module loaded
[   30.851475] dracut-initqueue[592]: mount: wrong fs type, bad option, bad superblock on /dev/loop0,
[   30.851981] dracut-initqueue[592]: missing codepage or helper program, or other error
[   30.852474] dracut-initqueue[592]: In some cases useful info is found in syslog - try
[   370.852860] dracut-initqueue[592]: dmesg | tail or so.
[   30.858454] dracut-initqueue[592]: umount: /run/initramfs/squashfs: not mounted
[   30.865350] dracut-initqueue[592]: /sbin/dmsquash-live-root: line 273: printf: write error: No space left on device

/dev/VG0/c71 is an empty LVM2 logical volume ...
Anyone an idea what's wrong here?
devzero
 
Posts: 5
Joined: 2016-11-14 04:03

Re: CentOS fails to install as Xen domU

Postby dilberts_left_nut » 2017-03-20 08:52

No idea, sorry.
It does seem to be something specific to the Cent7 install method, so you might get better info via their channels - unless someone looking here has run into it too.
Do the Xen docs have any tips or requirements for the two different OS's?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4548
Joined: 2009-10-05 07:54
Location: enzed

Re: CentOS fails to install as Xen domU

Postby arochester » 2017-03-20 09:09

Debian Users Forum - for questions specific to the Debian official distribution (stable, testing, or unstable); if you are using a derivative of Debian (e.g. Mint, Ubuntu, Kali, etc), then please use that distribution’s forum.
arochester
 
Posts: 903
Joined: 2010-12-07 19:55

Re: CentOS fails to install as Xen domU

Postby debiman » 2017-03-21 07:17

arochester wrote:CentOS Forums >>> https://www.centos.org/forums/

come on, try to be a little nicer.
maybe op posted on centos forums already and they sent him here because it's "not a centos problem"?

unfortunately i know NOTHING about the topic at hand...
User avatar
debiman
 
Posts: 964
Joined: 2013-03-12 07:18


Return to System configuration

Who is online

Users browsing this forum: stevepusser and 3 guests

fashionable